Bug 427636 - OpenGL compositor crashes with newish NVIDIA card and latest driver
Summary: OpenGL compositor crashes with newish NVIDIA card and latest driver
Status: RESOLVED DUPLICATE of bug 432570
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: unspecified
Platform: Kubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-13 14:48 UTC by RalphB
Modified: 2021-02-09 17:49 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description RalphB 2020-10-13 14:48:51 UTC
I recently installed Kubuntu 20.04, 64 bit on my new system with an NVIDIA GTX 1660 card, using the latest proprietary NVIDIA driver 450.66.

I noticed that if I enable OpenGL 2.0 or OpenGL 3.1 compositor in system-settings, kwin and/or the compositor crash with Segfault immediately after pressing Apply.  Only XRender works without flaws.

What kind of additional information should I attach so that you can work on this issue?  (I cannot use Submit Bug Report, as it would open the wrong browser.)
Comment 1 Vlad Zahorodnii 2020-10-14 06:19:06 UTC
> (I cannot use Submit Bug Report, as it would open the wrong browser.)

Can you copy-paste the backtrace in DrKonqi window?
Comment 2 RalphB 2020-10-16 12:47:59 UTC
Here is the stack trace:

Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f3b32f82800 (LWP 10502))]

Thread 5 (Thread 0x7f3b2bfff700 (LWP 10538)):
#0  0x00007f3b39d39bf6 in __ppoll (fds=0x562b64244308, nfds=1, timeout=<optimized out>, sigmask=0x0) at ../sysdeps/unix/sysv/linux/ppoll.c:44
#1  0x00007f3b387353c0 in qt_safe_poll(pollfd*, unsigned long, timespec const*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#2  0x00007f3b38736a14 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x00007f3b386e04db in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f3b38518785 in QThread::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f3b385199d2 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f3b37ad7609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#7  0x00007f3b39d46293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f3b28efa700 (LWP 10513)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x7f3b38122fb8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x7f3b38122f68, cond=0x7f3b38122f90) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x7f3b38122f90, mutex=0x7f3b38122f68) at pthread_cond_wait.c:638
#3  0x00007f3b380255fa in ?? () from /lib/x86_64-linux-gnu/libQt5Script.so.5
#4  0x00007f3b3802561f in ?? () from /lib/x86_64-linux-gnu/libQt5Script.so.5
#5  0x00007f3b37ad7609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f3b39d46293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f3b2b56f700 (LWP 10510)):
#0  0x00007f3b39d39bf6 in __ppoll (fds=0x7f3b18000d68, nfds=1, timeout=<optimized out>, sigmask=0x0) at ../sysdeps/unix/sysv/linux/ppoll.c:44
#1  0x00007f3b387354a9 in qt_safe_poll(pollfd*, unsigned long, timespec const*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#2  0x00007f3b38736a14 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x00007f3b386e04db in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f3b38518785 in QThread::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f3b3724b1a9 in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#6  0x00007f3b385199d2 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f3b37ad7609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#8  0x00007f3b39d46293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f3b31800700 (LWP 10505)):
#0  0x00007f3b39d39bf6 in __ppoll (fds=0x7f3b2400ea58, nfds=1, timeout=<optimized out>, sigmask=0x0) at ../sysdeps/unix/sysv/linux/ppoll.c:44
#1  0x00007f3b387354a9 in qt_safe_poll(pollfd*, unsigned long, timespec const*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#2  0x00007f3b38736a14 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x00007f3b386e04db in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f3b38518785 in QThread::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f3b3974aefa in ?? () from /lib/x86_64-linux-gnu/libQt5DBus.so.5
#6  0x00007f3b385199d2 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f3b37ad7609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#8  0x00007f3b39d46293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f3b32f82800 (LWP 10502)):
[KCrash Handler]
#6  0x0000562b64045010 in ?? ()
#7  0x00007f3b2b5d1324 in KWin::SceneOpenGL::createScene(QObject*) () from /usr/lib/x86_64-linux-gnu/qt5/plugins/org.kde.kwin.scenes/KWinSceneOpenGL.so
#8  0x00007f3b2b5d49cd in KWin::OpenGLFactory::create(QObject*) const () from /usr/lib/x86_64-linux-gnu/qt5/plugins/org.kde.kwin.scenes/KWinSceneOpenGL.so
#9  0x00007f3b399ca373 in ?? () from /lib/x86_64-linux-gnu/libkwin.so.5
#10 0x00007f3b399cb5a6 in KWin::X11Compositor::start() () from /lib/x86_64-linux-gnu/libkwin.so.5
#11 0x00007f3b399cc12b in KWin::Compositor::reinitialize() () from /lib/x86_64-linux-gnu/libkwin.so.5
#12 0x00007f3b3998b35a in ?? () from /lib/x86_64-linux-gnu/libkwin.so.5
#13 0x00007f3b39993a03 in ?? () from /lib/x86_64-linux-gnu/libkwin.so.5
#14 0x00007f3b3975763b in ?? () from /lib/x86_64-linux-gnu/libQt5DBus.so.5
#15 0x00007f3b3870dd5a in QObject::event(QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#16 0x00007f3b390fba66 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#17 0x00007f3b391050f0 in QApplication::notify(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#18 0x00007f3b386e193a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#19 0x00007f3b386e45b8 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#20 0x00007f3b38736827 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#21 0x00007f3b328836e2 in ?? () from /lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#22 0x00007f3b386e04db in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#23 0x00007f3b386e8246 in QCoreApplication::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#24 0x00007f3b39e1f9ef in kdemain () from /lib/x86_64-linux-gnu/libkdeinit5_kwin_x11.so
#25 0x00007f3b39c4b0b3 in __libc_start_main (main=0x562b62551060, argc=3, argv=0x7fff86d72528, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff86d72518) at ../csu/libc-start.c:308
#26 0x0000562b6255109e in _start ()
[Inferior 1 (process 10502) detached]
Comment 3 Nate Graham 2021-02-09 17:49:43 UTC

*** This bug has been marked as a duplicate of bug 432570 ***