Bug 427314 - System settings crashes installing new themes
Summary: System settings crashes installing new themes
Status: RESOLVED DUPLICATE of bug 426410
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: 5.19.5
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-10-04 03:27 UTC by Ou Yei
Modified: 2020-10-05 20:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ou Yei 2020-10-04 03:27:54 UTC
Application: systemsettings5 (5.19.5)

Qt Version: 5.15.1
Frameworks Version: 5.74.0
Operating System: Linux 5.8.10-1-default x86_64
Windowing system: X11
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
- What I was doing when the application crashed:

Installing new Plasma theme and waiting for the process to finish.

The crash can be reproduced sometimes.

-- Backtrace:
Application: Preferencias del sistema (systemsettings5), signal: Segmentation fault

[KCrash Handler]
#4  0x0000000000000000 in ?? ()
#5  0x00007f91da9ce285 in KPackageTask::~KPackageTask (this=<optimized out>, this=<optimized out>) at /usr/src/debug/knewstuff-5.74.0-1.1.x86_64/src/core/jobs/kpackagejob.cpp:63
#6  KPackageTask::~KPackageTask (this=<optimized out>, this=<optimized out>) at /usr/src/debug/knewstuff-5.74.0-1.1.x86_64/src/core/jobs/kpackagejob.cpp:65
#7  0x00007f920528bc7e in QObjectPrivate::deleteChildren (this=0x55b8d09836a0) at kernel/qobject.cpp:2104
#8  0x00007f9205296854 in QObject::~QObject (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1082
#9  0x00007f91da9cdac7 in KNSCore::KPackageJob::~KPackageJob (this=<optimized out>, this=<optimized out>) at /usr/src/debug/knewstuff-5.74.0-1.1.x86_64/src/core/jobs/kpackagejob.cpp:133
#10 KNSCore::KPackageJob::~KPackageJob (this=<optimized out>, this=<optimized out>) at /usr/src/debug/knewstuff-5.74.0-1.1.x86_64/src/core/jobs/kpackagejob.cpp:136
#11 0x00007f920528de4f in QObject::event (this=0x55b8d5d4d090, e=0x55b8d6b34ec0) at kernel/qobject.cpp:1301
#12 0x00007f9205db914f in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x55b8d5d4d090, e=0x55b8d6b34ec0) at kernel/qapplication.cpp:3630
#13 0x00007f920526205a in QCoreApplication::notifyInternal2 (receiver=0x55b8d5d4d090, event=0x55b8d6b34ec0) at ../../include/QtCore/5.15.1/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:325
#14 0x00007f9205264a91 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x55b8cc96d6c0) at kernel/qcoreapplication.cpp:1817
#15 0x00007f92052b9f23 in postEventSourceDispatch (s=0x55b8cca48c70) at kernel/qeventdispatcher_glib.cpp:277
#16 0x00007f9202eec2b7 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#17 0x00007f9202eec638 in ?? () from /usr/lib64/libglib-2.0.so.0
#18 0x00007f9202eec6ef in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f92052b95af in QEventDispatcherGlib::processEvents (this=0x55b8cca408c0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#20 0x00007f9205260a1b in QEventLoop::exec (this=this@entry=0x7ffd70c88350, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#21 0x00007f9205268c90 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#22 0x000055b8cb5f4fd9 in main (argc=<optimized out>, argv=0x7ffd70c88460) at /usr/src/debug/systemsettings5-5.19.5-1.1.x86_64/app/main.cpp:168
[Inferior 1 (process 10505) detached]

Possible duplicates by query: bug 426047, bug 425463, bug 424086, bug 423874, bug 423459.

Reported using DrKonqi
Comment 1 Nate Graham 2020-10-05 20:44:16 UTC

*** This bug has been marked as a duplicate of bug 426410 ***