Bug 427289 - "Now Playing" page says "Nothing playing" when Elisa is launched with a file that was already in the playlist
Summary: "Now Playing" page says "Nothing playing" when Elisa is launched with a file ...
Status: RESOLVED FIXED
Alias: None
Product: Elisa
Classification: Applications
Component: general (show other bugs)
Version: 21.08.1
Platform: Archlinux Linux
: NOR normal
Target Milestone: ---
Assignee: Matthieu Gallien
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-03 11:52 UTC by Patrick Silva
Modified: 2022-01-27 15:23 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
test file (3.70 MB, audio/mpeg)
2020-10-03 12:04 UTC, Patrick Silva
Details
screenshot (163.02 KB, image/png)
2020-10-03 12:04 UTC, Patrick Silva
Details
Elisa show nothing playing while music is on (2.10 MB, video/mp4)
2021-05-19 23:53 UTC, medin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2020-10-03 11:52:10 UTC
STEPS TO REPRODUCE
1. download the attached test file
2. play the downloaded file with Elisa
3. click on "Now Playing" in the left side

OBSERVED RESULT
As we can see in the attached screenshot, "Now Playing" page says "Nothing playing"

EXPECTED RESULT
Elisa should not say "Nothing playing" during playback

SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.20.80
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.0
Comment 1 Patrick Silva 2020-10-03 12:04:01 UTC
Created attachment 132085 [details]
test file
Comment 2 Patrick Silva 2020-10-03 12:04:41 UTC
Created attachment 132086 [details]
screenshot
Comment 3 Fabian Baumanis 2020-10-03 17:20:18 UTC
The test file only has a title in the ID3 tags.
The check for the "Nothing played" message doesn't include a check on the title, therefore the message is displayed.

I've created a patch for it and opened a Merge Request: https://invent.kde.org/multimedia/elisa/-/merge_requests/174
Comment 4 Matthieu Gallien 2020-10-11 17:34:20 UTC
Git commit 36fcaa2be6bbffba55f2b36e1c10caa0fdf568aa by Matthieu Gallien, on behalf of Fabian Baumanis.
Committed on 11/10/2020 at 17:34.
Pushed by mgallien into branch 'master'.

Fix "Nothing played" message when a file only with a title tag is played

M  +1    -0    src/qml/ContextView.qml

https://invent.kde.org/multimedia/elisa/commit/36fcaa2be6bbffba55f2b36e1c10caa0fdf568aa
Comment 5 medin 2021-05-19 23:52:48 UTC
The problem is still persistent with Plasma 5.21.5, see attached video for more info.
Comment 6 medin 2021-05-19 23:53:36 UTC
Created attachment 138583 [details]
Elisa show nothing playing while music is on
Comment 7 Nate Graham 2021-05-20 15:27:01 UTC
Got it, can reproduce now. Updating title.
Comment 8 Patrick Silva 2021-09-19 19:32:19 UTC
New tests done with the attached audio file located in a folder not indexed by Elisa and opened via Dolphin...
While Elisa 21.08.1 plays the attached file without metadata, "Now playing" page only says "No lyrics found". After adding Artist and Album metadata to the same file, "Now playing" page displays the following information together "No lyrics found":

rating
year
channels
bit rate
sample rate
last played
play count
duration

I think the expected is displaying the information above regardless the file has metadata or not.
Comment 9 Yerrey Dev 2022-01-27 15:23:57 UTC
Git commit fe5f08cb7dff65cc2b1e6cb8e6e45706201c233c by Yerrey Dev.
Committed on 27/01/2022 at 12:02.
Pushed by ngraham into branch 'master'.

Fix metadata not updating when track is opened from Files-browser

This was caused by files being opened as ElisaUtils::FileName TrackType instead of
ElisaUtils::Track, to fix this, we just add that into ModelDataLoader::loadDataByDatabaseIdAndUrl.
Related: bug 448043, bug 445382

M  +1    -1    src/modeldataloader.cpp

https://invent.kde.org/multimedia/elisa/commit/fe5f08cb7dff65cc2b1e6cb8e6e45706201c233c