Bug 427281 - List of all Events is unreadable
Summary: List of all Events is unreadable
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Digital Clock (show other bugs)
Version: 5.19.90
Platform: OpenSUSE Linux
: VHI normal
Target Milestone: 1.0
Assignee: Nate Graham
URL:
Keywords: regression
: 426140 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-10-03 06:45 UTC by Robby Engelmann
Modified: 2020-10-10 18:49 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.20


Attachments
screenshot (302.23 KB, image/jpeg)
2020-10-03 06:45 UTC, Robby Engelmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robby Engelmann 2020-10-03 06:45:58 UTC
Created attachment 132082 [details]
screenshot

SUMMARY
Event list on the right side is not readable

STEPS TO REPRODUCE
1. show events from a calender (multiple ones per day)
2. go to the date in Digital Clock widget
3. see picture as shown in attached figure

OBSERVED RESULT


EXPECTED RESULT


SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2020-10-05 20:38:22 UTC
Oh dear. Will fix ASAP.
Comment 2 Nate Graham 2020-10-05 22:18:06 UTC
Probably a regression from the port to PlasmaExtras.ListItem.
Comment 3 Nate Graham 2020-10-05 22:31:02 UTC
Git commit 654f0c9e55ae9bf2adcffbeb6a47d035388e53d4 by Nate Graham.
Committed on 05/10/2020 at 22:30.
Pushed by ngraham into branch 'master'.

[applets/digital-clock] Fix event list item height

Because the content is manufactured from scratch, we need to set the
height manually, or else everything will get scrunched together.
FIXED-IN: 5.20

M  +1    -0    applets/digital-clock/package/contents/ui/CalendarView.qml

https://invent.kde.org/plasma/plasma-workspace/commit/654f0c9e55ae9bf2adcffbeb6a47d035388e53d4
Comment 4 Nate Graham 2020-10-05 22:31:21 UTC
Git commit f0c7e2d19f274fbc479d6a913d54b178c2909d04 by Nate Graham.
Committed on 05/10/2020 at 22:30.
Pushed by ngraham into branch 'Plasma/5.20'.

[applets/digital-clock] Fix event list item height

Because the content is manufactured from scratch, we need to set the
height manually, or else everything will get scrunched together.
FIXED-IN: 5.20

M  +1    -0    applets/digital-clock/package/contents/ui/CalendarView.qml

https://invent.kde.org/plasma/plasma-workspace/commit/f0c7e2d19f274fbc479d6a913d54b178c2909d04
Comment 5 Nate Graham 2020-10-10 18:49:00 UTC
*** Bug 426140 has been marked as a duplicate of this bug. ***