Bug 427245 - Task's Thumbnail does not show GIMP window on Wayland
Summary: Task's Thumbnail does not show GIMP window on Wayland
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: 5.20.90
Platform: Archlinux Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords: wayland
Depends on:
Blocks:
 
Reported: 2020-10-02 13:14 UTC by Patrick Silva
Modified: 2021-09-18 13:29 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.21


Attachments
screenshot (92.10 KB, image/png)
2020-10-02 13:14 UTC, Patrick Silva
Details
screenshot of java app (100.70 KB, image/png)
2020-10-06 15:21 UTC, Patrick Silva
Details
Screenshot of GIMP (105.75 KB, image/png)
2020-10-06 15:29 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2020-10-02 13:14:42 UTC
Created attachment 132068 [details]
screenshot

SUMMARY
Reproducible on both Arch (Plasma 5.20 beta) and neon unstable,
at least Discord and Skype electron apps are affected.
See the attached screenshot please.

EXPECTED RESULT
tooltip should show preview of any app

SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.20.80
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.0
Comment 1 Patrick Silva 2020-10-06 15:21:39 UTC
Created attachment 132151 [details]
screenshot of java app

Java apps are also affected. My screenshot shows BiglyBT torrent client.
Comment 2 Patrick Silva 2020-10-06 15:29:33 UTC
Created attachment 132152 [details]
Screenshot of GIMP

Humm, apparently the preview only works with Qt5 and GTK3 apps.
No preview for GTK2 GIMP too.
Comment 3 Aleix Pol 2020-12-01 12:51:53 UTC
This is already fixed by a3f5d4310010dd6fb2f4d1359d0490cbc31c783f in Plasma 5.20 and cea2781318c9a24b25d3f4a43e2efccc32a5e371 in master.

The problem wasn't the toolkit itself but the use of XWayland.
Comment 4 Patrick Silva 2020-12-10 10:48:39 UTC
Still no preview for electron (Discord) and gtk2 apps (inkscape and gimp).

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.20.80
KDE Frameworks Version: 5.77.0
Qt Version: 5.15.2
Comment 5 Aleix Pol 2021-02-05 03:34:34 UTC
I'm unable to reproduce with Discord, Inkscape and GIMP. :(
Comment 6 Patrick Silva 2021-09-18 13:29:17 UTC
I'm unable to reproduce on Plasma 5.23 beta.

Operating System: Arch Linux
KDE Plasma Version: 5.22.90
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
Graphics Platform: Wayland