Bug 427021 - Crash when reading mail with Mozilla Thunderbird
Summary: Crash when reading mail with Mozilla Thunderbird
Status: RESOLVED DUPLICATE of bug 425205
Alias: None
Product: Akonadi
Classification: Unclassified
Component: server (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-09-27 11:20 UTC by Mike McCarthy
Modified: 2021-03-09 20:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (181.18 KB, text/plain)
2020-09-27 11:20 UTC, Mike McCarthy
Details
New crash information added by DrKonqi (131.61 KB, text/plain)
2020-10-15 19:42 UTC, Mike McCarthy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike McCarthy 2020-09-27 11:20:33 UTC
Application: akonadiserver (5.14.2 (20.04.2))

Qt Version: 5.12.7
Frameworks Version: 5.71.0
Operating System: Linux 5.3.18-lp152.41-default x86_64
Windowing system: X11
Distribution: "openSUSE Leap 15.2"

-- Information about the crash:
Running openSUSE 15.2 in Virtualbox. Crashes repeatedly when invoking Mozilla Thunderbird when mailbox contains large number of emails.

The crash can be reproduced every time.

-- Backtrace (Reduced):
#4  0x00007f4a51e359fc in std::__atomic_base<int>::load (__m=std::memory_order_relaxed, this=0x0) at /usr/include/c++/7/bits/atomic_base.h:396
#5  QAtomicOps<int>::load<int> (_q_value=...) at ../../include/QtCore/../../src/corelib/thread/qatomic_cxx11.h:227
#6  QBasicAtomicInteger<int>::load (this=0x0) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:103
[...]
#8  QString::operator= (this=this@entry=0x7f49f08fdf78, other=...) at tools/qstring.cpp:2417
#9  0x0000564ed1dac8d5 in Akonadi::Server::ItemRetrievalManager::retrievalJobFinished (this=0x564ed3610070, request=0x7f49f08fdf60, errorMsg=...) at /usr/src/debug/akonadi-server-20.04.2-lp152.2.3.1.x86_64/src/server/storage/itemretrievalmanager.cpp:176


The reporter indicates this bug may be a duplicate of or related to bug 409515.

Possible duplicates by query: bug 425931, bug 425842, bug 425340, bug 425205, bug 423579.

Reported using DrKonqi
Comment 1 Mike McCarthy 2020-09-27 11:20:34 UTC
Created attachment 131957 [details]
New crash information added by DrKonqi

DrKonqi auto-attaching complete backtrace.
Comment 2 Mike McCarthy 2020-10-15 19:42:45 UTC
Created attachment 132397 [details]
New crash information added by DrKonqi

akonadiserver (5.14.2 (20.04.2)) using Qt 5.12.7

- What I was doing when the application crashed:

Reading mail with Thuinderbird. OpenSUSE Virtualbox VM running on Windows 10 host.

-- Backtrace (Reduced):
#5  0x000056250689222b in QHash<QString, Akonadi::Server::AbstractItemRetrievalJob*>::findNode (this=this@entry=0x562507be6288, akey=..., ahp=ahp@entry=0x0) at /usr/include/qt5/QtCore/qhash.h:934
#6  0x000056250689289a in QHash<QString, Akonadi::Server::AbstractItemRetrievalJob*>::remove (this=this@entry=0x562507be6288, akey=...) at /usr/include/qt5/QtCore/qhash.h:806
#7  0x000056250688f8ef in Akonadi::Server::ItemRetrievalManager::retrievalJobFinished (this=0x562507be6250, request=0x7f25c80c5490, errorMsg=...) at /usr/src/debug/akonadi-server-20.04.2-lp152.2.3.1.x86_64/src/server/storage/itemretrievalmanager.cpp:179
[...]
#9  0x00005625068e07e4 in Akonadi::Server::AbstractItemRetrievalJob::requestCompleted (this=this@entry=0x7f25c8b40340, _t1=<optimized out>, _t2=...) at /usr/src/debug/akonadi-server-20.04.2-lp152.2.3.1.x86_64/build/src/server/libakonadiserver_autogen/5XLNPBDXWK/moc_itemretrievaljob.cpp:135
#10 0x000056250689306e in Akonadi::Server::ItemRetrievalJob::callFinished (this=0x7f25c8b40340, watcher=<optimized out>) at /usr/src/debug/akonadi-server-20.04.2-lp152.2.3.1.x86_64/src/server/storage/itemretrievaljob.cpp:76
Comment 3 Christophe Giboudeaux 2021-03-09 20:01:27 UTC

*** This bug has been marked as a duplicate of bug 425205 ***