Bug 426994 - Window Preview Should Disappear When Other Menus Appear
Summary: Window Preview Should Disappear When Other Menus Appear
Status: RESOLVED DUPLICATE of bug 417939
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 5.19.90
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-26 14:45 UTC by Andres Betts
Modified: 2020-09-27 15:25 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
previewsovermenu (2.44 MB, image/png)
2020-09-26 14:45 UTC, Andres Betts
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andres Betts 2020-09-26 14:45:11 UTC
Created attachment 131947 [details]
previewsovermenu

SUMMARY
Window previous in the panels should not obscure or interfere with other elements of the UI. Previous should only appear when there is a hover action. Hover action should be disabled when a click event, right or left click are executed.

Otherwise, the window preview appears when the user is trying to select items from the right click application menu and interferes with the action.

Screenshot attached.

STEPS TO REPRODUCE
1. Right click application menu
2. Move pointer in and out of application icon
3. Preview appears on top of the menu
Comment 1 Nate Graham 2020-09-26 15:24:26 UTC
Are you using Wayland?
Comment 2 Andres Betts 2020-09-27 13:33:41 UTC
Yes
Comment 3 Patrick Silva 2020-09-27 15:25:32 UTC

*** This bug has been marked as a duplicate of bug 417939 ***