Bug 426731 - Top-level categories with only one item in them confusingly display an arrow
Summary: Top-level categories with only one item in them confusingly display an arrow
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Unclassified
Component: sidebarview (show other bugs)
Version: 5.19.90
Platform: Neon Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2020-09-19 14:35 UTC by Patrick Silva
Modified: 2020-09-25 13:31 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.20


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2020-09-19 14:35:11 UTC
STEPS TO REPRODUCE
1. open system settings on Wayland ("Font" item has an arrow)
2. click on "Font"
3. 

OBSERVED RESULT
no sub-item available despite the arrow indicating the oppsosite

EXPECTED RESULT
"Font" should not have an arrow on Wayland

SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.19.90
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.0
Comment 1 Nate Graham 2020-09-23 16:52:52 UTC
Makes sense. Technically the Fonts item it's a top-level category, but since it has only one item in it, System Settings helpfully omits the single-item category view and takes you straight to that one item. The arrow needs to take this into account as well, somehow.
Comment 2 Bug Janitor Service 2020-09-25 08:20:34 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/systemsettings/-/merge_requests/18
Comment 3 David Redondo 2020-09-25 08:29:27 UTC
Git commit 9eb9aa4490680ab3ef5df998ae8eeeca8e39fd3d by David Redondo.
Committed on 25/09/2020 at 08:24.
Pushed by davidre into branch 'master'.

Don't show an arrow when the category only contains one item
FIXED-IN:5.20

M  +7    -1    sidebar/package/contents/ui/CategoriesPage.qml

https://invent.kde.org/plasma/systemsettings/commit/9eb9aa4490680ab3ef5df998ae8eeeca8e39fd3d
Comment 4 Nate Graham 2020-09-25 13:31:28 UTC
Git commit 7967ed6330d6e00686e27e0854ea77dfae8543d5 by Nate Graham, on behalf of David Redondo.
Committed on 25/09/2020 at 13:31.
Pushed by ngraham into branch 'Plasma/5.20'.

Don't show an arrow when the category only contains one item
FIXED-IN:5.20


(cherry picked from commit 9eb9aa4490680ab3ef5df998ae8eeeca8e39fd3d)

M  +7    -1    sidebar/package/contents/ui/CategoriesPage.qml

https://invent.kde.org/plasma/systemsettings/commit/7967ed6330d6e00686e27e0854ea77dfae8543d5