Bug 426686 - The animation for hiding/showing a plasma panel is absent in Plasma 5.19.90
Summary: The animation for hiding/showing a plasma panel is absent in Plasma 5.19.90
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: effects-various (show other bugs)
Version: 5.19.90
Platform: Archlinux Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: regression
: 427365 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-09-18 13:56 UTC by Reiddragon
Modified: 2020-10-05 20:34 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.20


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Reiddragon 2020-09-18 13:56:25 UTC
SUMMARY
The animation for hiding/showing a plasma panel is absent

STEPS TO REPRODUCE
1. set a panel to autohide

OBSERVED RESULT
The panel shows/hides w/o an animation

EXPECTED RESULT
The panel is supposed to have a showing/hiding animation

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch Linux
KDE Plasma Version: 5.19.90
KDE Frameworks Version: 5.74
Qt Version: 5.15.1
Comment 1 Nate Graham 2020-09-18 21:27:21 UTC
Heh really? I don't think I've ever seen it. I guess you did, which means that its absence is a regression somewhere along the line.
Comment 2 Vlad Zahorodnii 2020-09-24 10:28:18 UTC
It looks like a kwin regression.
Comment 3 Bug Janitor Service 2020-09-24 11:09:55 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/kwin/-/merge_requests/289
Comment 4 David Edmundson 2020-09-24 11:16:35 UTC
Git commit 095cdcd37476cd1bdf9e7c0cecbf818568af829b by David Edmundson.
Committed on 24/09/2020 at 11:09.
Pushed by vladz into branch 'master'.

Revert "[effects/slidingpopups] Start the animation on only windowAdded or windowClosed"

This reverts commit 9d4c8fda0989a66d4eb8c876d16fc344815816a9.

Unlike other effects this wasn't using hide/show as a hack for not
having a created/destroyed signal but because the window is internally
hidden when it's in auto-hide mode despite being still mapped.

M  +2    -0    effects/slidingpopups/slidingpopups.cpp

https://invent.kde.org/plasma/kwin/commit/095cdcd37476cd1bdf9e7c0cecbf818568af829b
Comment 5 Vlad Zahorodnii 2020-09-24 11:17:01 UTC
Git commit 23b85e2b852573c5dc3d794e45c1a1a46e56d837 by Vlad Zahorodnii, on behalf of David Edmundson.
Committed on 24/09/2020 at 11:16.
Pushed by vladz into branch 'Plasma/5.20'.

Revert "[effects/slidingpopups] Start the animation on only windowAdded or windowClosed"

This reverts commit 9d4c8fda0989a66d4eb8c876d16fc344815816a9.

Unlike other effects this wasn't using hide/show as a hack for not
having a created/destroyed signal but because the window is internally
hidden when it's in auto-hide mode despite being still mapped.


(cherry picked from commit 095cdcd37476cd1bdf9e7c0cecbf818568af829b)

M  +2    -0    effects/slidingpopups/slidingpopups.cpp

https://invent.kde.org/plasma/kwin/commit/23b85e2b852573c5dc3d794e45c1a1a46e56d837
Comment 6 Podagric 2020-10-05 20:34:32 UTC
*** Bug 427365 has been marked as a duplicate of this bug. ***