Bug 426605 - Several options disappear from menus after a tab to be closed
Summary: Several options disappear from menus after a tab to be closed
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Neon Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 425471 425896 427784 428097 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-09-16 12:54 UTC by Patrick Silva
Modified: 2020-10-27 07:44 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 20.08.2


Attachments
"File" menu before the steps (144.57 KB, image/png)
2020-09-16 12:54 UTC, Patrick Silva
Details
"File" menu after the steps (86.29 KB, image/png)
2020-09-16 12:54 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2020-09-16 12:54:03 UTC
Created attachment 131696 [details]
"File" menu before the steps

STEPS TO REPRODUCE
1. open Kate
2. press ctrl+n to open a tab
3. close a tab
4. open "File" menu

OBSERVED RESULT
Several options disappeared from "File" menu, compare the attached screenshots please. Edit, View and Tools menus are also affected.

EXPECTED RESULT


SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.19.80
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.0
Comment 1 Patrick Silva 2020-09-16 12:54:44 UTC
Created attachment 131697 [details]
"File" menu after the steps
Comment 2 Christoph Cullmann 2020-09-16 12:58:16 UTC
This seems like a regression already in 20.08, the view switching is not correctly propagated and we miss to plug/unplug stuff :/
Comment 3 Christoph Cullmann 2020-09-16 18:15:01 UTC
Git commit d679aca69c946c21a5bfa7ca1eb4e146ea90d139 by Christoph Cullmann.
Committed on 16/09/2020 at 18:14.
Pushed by cullmann into branch 'master'.

avoid that the KTextEditor::View XMLGUI elements are lost after a tab is closed

M  +6    -1    kate/kateviewmanager.cpp

https://invent.kde.org/utilities/kate/commit/d679aca69c946c21a5bfa7ca1eb4e146ea90d139
Comment 4 Christoph Cullmann 2020-09-17 07:51:55 UTC
Git commit 972903d2620932477c91c62b8b8c56e8d3bf40bd by Christoph Cullmann.
Committed on 17/09/2020 at 07:51.
Pushed by cullmann into branch 'release/20.08'.

avoid that the KTextEditor::View XMLGUI elements are lost after a tab is closed

M  +6    -1    kate/kateviewmanager.cpp

https://invent.kde.org/utilities/kate/commit/972903d2620932477c91c62b8b8c56e8d3bf40bd
Comment 5 Patrick Silva 2020-09-17 11:37:38 UTC
After this fix, bug 425471 is no longer reproducble.
Comment 6 Christoph Cullmann 2020-09-17 11:43:22 UTC
True, that is the same issue =)
Comment 7 Christoph Cullmann 2020-09-17 11:43:26 UTC
*** Bug 425471 has been marked as a duplicate of this bug. ***
Comment 8 Nate Graham 2020-09-22 13:43:26 UTC
*** Bug 425896 has been marked as a duplicate of this bug. ***
Comment 9 Christoph Feck 2020-10-17 14:21:27 UTC
*** Bug 427784 has been marked as a duplicate of this bug. ***
Comment 10 Christoph Feck 2020-10-27 07:44:51 UTC
*** Bug 428097 has been marked as a duplicate of this bug. ***