Bug 426556 - ToolButton icons are mis-colored in lock and logout screens
Summary: ToolButton icons are mis-colored in lock and logout screens
Status: RESOLVED FIXED
Alias: None
Product: frameworks-plasma
Classification: Unclassified
Component: components (show other bugs)
Version: 5.74.0
Platform: Neon Packages Linux
: VHI normal (vote)
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords: regression
: 426824 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-09-15 11:53 UTC by Patrick Silva
Modified: 2020-11-05 14:24 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.75


Attachments
screenshot (489.53 KB, image/png)
2020-09-15 11:53 UTC, Patrick Silva
Details
Discover (126.44 KB, image/png)
2020-09-15 16:47 UTC, Patrick Silva
Details
GHNS window (498.52 KB, image/png)
2020-09-15 16:47 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2020-09-15 11:53:20 UTC
Created attachment 131670 [details]
screenshot

SUMMARY
See the attached screenshot please.
virtual keyboard, keyboard layout and playback control icons are barely visible
in the screen locker. In SDDM, virtual keyboad icon and the arrow of the dropdown
to choose a desktop sesson are barely visible too.

EXPECTED RESULT
icons with better visibility

SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.19.80
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.0
Comment 1 Nate Graham 2020-09-15 15:57:56 UTC
The icons' colors are wrong, weird. What color scheme and Plasma theme are you using?
Comment 2 Patrick Silva 2020-09-15 16:32:06 UTC
The bug occurs when I use Breeze global theme. The icons are correct with Breeze Dark.
Comment 3 Patrick Silva 2020-09-15 16:47:31 UTC
Created attachment 131681 [details]
Discover

I'm not sure if these issues are related, but the header bars of Discover and GHNS windows have barely visible/readable icons/text.
Comment 4 Patrick Silva 2020-09-15 16:47:54 UTC
Created attachment 131682 [details]
GHNS window
Comment 5 Nate Graham 2020-09-15 17:19:30 UTC
Somehow your color scheme is all messed up. :/

Can you make a backup of your kdeglobals config file, then try switching to a different color scheme in the colors KCM, and then see if that fixes it? If that does, let's see if we we can locate any  relevant differences between the broken kdeglobals file and the working one.
Comment 6 Patrick Silva 2020-09-15 17:50:06 UTC
I applied Krita Bright and then switched back to Breeze color scheme. Discover and GHNS windows are now fixed but screen locker and SDDM are still buggy.
I think that my color scheme got corrupted when kwin crashed on Wayland after I change the global theme (known issue).
Comment 7 Nate Graham 2020-09-15 18:33:11 UTC
Is there a bug report for that issue?
Comment 8 Patrick Silva 2020-09-15 18:37:32 UTC
bug 422424
Comment 9 Nate Graham 2020-09-15 21:01:13 UTC
Do the colors get fixed if you switch to another color scheme and then back?
Comment 10 Patrick Silva 2020-09-15 21:30:05 UTC
No. I applied several color schemes (light and dark) available on my system then applied the Breeze after each, but the issue with screen locker persists.
Comment 11 Nate Graham 2020-09-17 22:26:36 UTC
I just started to experience this in my dev session. Does not seem to be related to the color scheme as it reproduces with every one I try. It affects the virtual keyboard icon and the icons in the media control toolbuttons.
Comment 12 Nate Graham 2020-09-19 02:10:34 UTC
This appears to be a regression in how PlasmaComponents3 ToolButtons react to inheriting the PlasmaCore.Theme.ComplementaryColorGroup color group. Big bisect says it's:

commit 7838a4ecc906edf4f99bd5ffa0e1abb9d788470f
Author: Noah Davis <noahadvs@gmail.com>
Date:   Sun Aug 30 02:09:38 2020 -0400

    Add private/ButtonContent.qml for PC3 Buttons and ToolButtons


Noah, could you have a look when you get the chance?
Comment 13 Nate Graham 2020-09-19 02:11:19 UTC
*git bisect lol
Comment 14 Nate Graham 2020-09-21 20:20:57 UTC
*** Bug 426824 has been marked as a duplicate of this bug. ***
Comment 15 Bug Janitor Service 2020-09-24 00:35:01 UTC
A possibly relevant merge request was started @ https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/95
Comment 16 Noah Davis 2020-09-24 00:45:13 UTC
Git commit 3167717797d07a8645391e093fa91526c4645f4f by Noah Davis.
Committed on 24/09/2020 at 00:33.
Pushed by ndavis into branch 'master'.

Fix PC3 Button/ToolButton icons not always having the right color set
FIXED-IN: 5.75

M  +1    -1    src/declarativeimports/plasmacomponents3/private/ButtonContent.qml

https://invent.kde.org/frameworks/plasma-framework/commit/3167717797d07a8645391e093fa91526c4645f4f