Bug 426253 - In plasma-wayland-session appmenu-gtk-module doesn't work.Menus remain in app windows,not displayed on panel.
Summary: In plasma-wayland-session appmenu-gtk-module doesn't work.Menus remain in app...
Status: RESOLVED DUPLICATE of bug 424485
Alias: None
Product: plasmashell
Classification: Plasma
Component: Global Menu (show other bugs)
Version: 5.19.5
Platform: Arch Linux Linux
: NOR normal
Target Milestone: 1.0
Assignee: Kai Uwe Broulik
URL:
Keywords: wayland
: 444609 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-09-06 17:00 UTC by alenertz
Modified: 2022-01-12 16:29 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alenertz 2020-09-06 17:00:33 UTC
SUMMARY


STEPS TO REPRODUCE
1. 
2. 
3. 

OBSERVED RESULT


EXPECTED RESULT


SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version:5.19.5 
KDE Frameworks Version:5.73.0 
Qt Version:5.15.0 

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2020-09-08 13:16:05 UTC
I'm afraid you'll need to provide a bit more information than this. Please fill out the template so we can see exactly how you set things up, what versions of things you're using, etc. Moving to Plasmashell | Global menu for now.
Comment 2 alenertz 2020-09-08 19:39:10 UTC
(In reply to alexjp.lenertz from comment #0)
> SUMMARY
> 
> 
> STEPS TO REPRODUCE
> 1. 
> 2. 
> 3. 
> 
> OBSERVED RESULT
> 
> 
> EXPECTED RESULT
> 
> 
> SOFTWARE/OS VERSIONS
> Windows: 
> macOS: 
> Linux/KDE Plasma: 
> (available in About System)
> KDE Plasma Version:5.19.5 
> KDE Frameworks Version:5.73.0 
> Qt Version:5.15.0 
> 
> ADDITIONAL INFORMATION

In Plasma-Wayland-Session activate global menu in widgets,install appmenu-gtk-module and a gtk app.When you open the gtk app,say brasero or handbrake,you see that the window menus are not displayed on the panel,but the menus remain in the app window.I'm using and testing Arch Linux Kde on an external harddisk and want to make it my daily driver.I'm a fan of the MacOS-Layout.Currently I'm using Manjaro Cinnamon.
Comment 3 Nate Graham 2020-09-08 20:07:44 UTC
Thanks for the info.
Comment 4 phrxmd 2021-12-22 19:54:27 UTC
*** Bug 444609 has been marked as a duplicate of this bug. ***
Comment 5 indecisiveautomator 2021-12-23 03:16:22 UTC
This is still present in Plasma 5.23.4.
Comment 6 phrxmd 2021-12-23 11:52:54 UTC
I get different behaviour: with GTK3 apps the global menu does not work, but the program doesn't display the menu either, so effectively there is no menu.  I think this is bug 424485. 

Arguably this is even worse. If there's a way to get the menu to display at least in the app, I'd be happier.
Comment 7 David Redondo 2022-01-12 16:29:47 UTC

*** This bug has been marked as a duplicate of bug 424485 ***