Bug 425891 - Akonadi crash in KMail
Summary: Akonadi crash in KMail
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: server (show other bugs)
Version: 5.15.0
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-08-28 06:23 UTC by Roland Koornstra
Modified: 2020-10-19 04:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
PrintScreen (973.79 KB, image/png)
2020-08-28 06:30 UTC, Roland Koornstra
Details
PrintScreen (366.09 KB, image/png)
2020-08-28 06:31 UTC, Roland Koornstra
Details
PrintScreen (268.99 KB, image/png)
2020-08-28 06:31 UTC, Roland Koornstra
Details
PrintScreen (189.16 KB, image/png)
2020-08-28 06:32 UTC, Roland Koornstra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roland Koornstra 2020-08-28 06:23:29 UTC
Application: akonadiserver (5.15.0 (20.08.0))

Qt Version: 5.15.0
Frameworks Version: 5.73.0
Operating System: Linux 5.8.0-1-default x86_64
Windowing system: X11
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
- What I was doing when the application crashed:
Starting KMail
Start took extremely long (afew minutes)
- Custom settings of the application:
Just IMAP
Using KGPG encryption & signing
Using >10 emailaccounts

The crash can be reproduced every time.

-- Backtrace:
Application: Akonadi Server (akonadiserver), signal: Aborted

[KCrash Handler]
#4  0x00007f0b9363a4b1 in raise () from /lib64/libc.so.6
#5  0x00007f0b93623539 in abort () from /lib64/libc.so.6
#6  0x00007f0b93881876 in ?? () from /usr/lib64/libstdc++.so.6
#7  0x00007f0b9388d0fc in ?? () from /usr/lib64/libstdc++.so.6
#8  0x00007f0b9388d167 in std::terminate() () from /usr/lib64/libstdc++.so.6
#9  0x00007f0b9388d419 in __cxa_throw () from /usr/lib64/libstdc++.so.6
#10 0x0000561c08794a3f in Akonadi::Server::DbIntrospector::hasIndex (this=<optimized out>, tableName=..., indexName=...) at /usr/src/debug/akonadi-server-20.08.0-1.1.x86_64/src/server/storage/dbintrospector.cpp:56
#11 0x0000561c0883ab35 in Akonadi::Server::DbInitializer::checkIndexes (this=0x561c0929e050, tableDescription=...) at /usr/include/qt5/QtCore/qsharedpointer_impl.h:306
#12 0x0000561c08815ce6 in Akonadi::Server::DbInitializer::updateIndexesAndConstraints (this=0x561c0929e050) at /usr/src/debug/akonadi-server-20.08.0-1.1.x86_64/src/server/storage/dbinitializer.cpp:220
#13 Akonadi::Server::DataStore::init (this=<optimized out>) at /usr/src/debug/akonadi-server-20.08.0-1.1.x86_64/src/server/storage/datastore.cpp:195
#14 0x0000561c087a57e4 in Akonadi::Server::AkonadiServer::setupDatabase (this=<optimized out>) at /usr/src/debug/akonadi-server-20.08.0-1.1.x86_64/src/server/akonadi.cpp:264
#15 0x0000561c087a7478 in Akonadi::Server::AkonadiServer::init (this=0x7fff4be92dc0) at /usr/src/debug/akonadi-server-20.08.0-1.1.x86_64/src/server/akonadi.cpp:107
#16 0x00007f0b93c9eb41 in QObject::event (this=0x7fff4be92dc0, e=0x561c09290920) at kernel/qobject.cpp:1314
#17 0x00007f0b93c72bef in doNotify (event=0x561c09290920, receiver=0x7fff4be92dc0) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:116
#18 QCoreApplication::notify (event=<optimized out>, receiver=<optimized out>, this=<optimized out>) at kernel/qcoreapplication.cpp:1137
#19 QCoreApplication::notifyInternal2 (receiver=0x7fff4be92dc0, event=0x561c09290920) at kernel/qcoreapplication.cpp:1061
#20 0x00007f0b93c75641 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x561c09282e10) at kernel/qcoreapplication.cpp:1815
#21 0x00007f0b93cca9d3 in postEventSourceDispatch (s=0x561c0928a9d0) at kernel/qeventdispatcher_glib.cpp:277
#22 0x00007f0b920072b7 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#23 0x00007f0b92007638 in ?? () from /usr/lib64/libglib-2.0.so.0
#24 0x00007f0b920076ef in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#25 0x00007f0b93cca05f in QEventDispatcherGlib::processEvents (this=0x561c09287e60, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#26 0x00007f0b93c715db in QEventLoop::exec (this=this@entry=0x7fff4be92c20, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#27 0x00007f0b93c79840 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#28 0x0000561c087a0c06 in AkApplicationBase::exec (this=0x7fff4be92d90) at /usr/src/debug/akonadi-server-20.08.0-1.1.x86_64/src/shared/akapplication.cpp:109
#29 main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/akonadi-server-20.08.0-1.1.x86_64/src/server/main.cpp:66
[Inferior 1 (process 4406) detached]

Reported using DrKonqi
Comment 1 Roland Koornstra 2020-08-28 06:30:34 UTC
Created attachment 131228 [details]
PrintScreen
Comment 2 Roland Koornstra 2020-08-28 06:31:26 UTC
Created attachment 131229 [details]
PrintScreen
Comment 3 Roland Koornstra 2020-08-28 06:31:55 UTC
Created attachment 131230 [details]
PrintScreen
Comment 4 Roland Koornstra 2020-08-28 06:32:42 UTC
Created attachment 131231 [details]
PrintScreen
Comment 5 Roland Koornstra 2020-08-28 06:35:55 UTC
It just came to mind that this happened when I just landed and restarted my Laptop and when the system was updated the time zone corrected during the yast2 systemupdate.
Comment 6 Ahmad Samir 2020-09-14 17:11:25 UTC
First stop akonadiserver:
akonadictl stop

then start it:
akonadictl start

then post the output here? thanks.
Comment 7 Ahmad Samir 2020-09-19 19:14:24 UTC
Forgot to set NEEDSINFO status.
Comment 8 Bug Janitor Service 2020-10-04 04:33:16 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 9 Bug Janitor Service 2020-10-19 04:33:22 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!