Bug 425779 - Lockup in xcb_wait_for_reply after unplugging monitor on wayland
Summary: Lockup in xcb_wait_for_reply after unplugging monitor on wayland
Status: RESOLVED DUPLICATE of bug 442846
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: git master
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-25 13:30 UTC by David Edmundson
Modified: 2022-03-30 14:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Edmundson 2020-08-25 13:30:26 UTC
Thread 1 "kwin_wayland" received signal SIGINT, Interrupt.
0x00007fcbfcead05f in poll () from /usr/lib/libc.so.6
(gdb) bt
#0  0x00007fcbfcead05f in poll () at /usr/lib/libc.so.6
#1  0x00007fcbfd3f863b in  () at /usr/lib/libxcb.so.1
#2  0x00007fcbfd3fa08f in  () at /usr/lib/libxcb.so.1
#3  0x00007fcbfd3fa1a2 in xcb_wait_for_reply () at /usr/lib/libxcb.so.1
#4  0x00007fcc01c8ad2e in KWin::Xcb::AbstractWrapper<KWin::Xcb::TreeData>::getReply() (this=0x56374807f7d0)
    at /home/david/projects/kde5/src/kde/workspace/kwin/xcbutils.h:323
#5  0x00007fcc01c8ac7c in KWin::Xcb::AbstractWrapper<KWin::Xcb::TreeData>::isNull() (this=0x56374807f7d0)
    at /home/david/projects/kde5/src/kde/workspace/kwin/xcbutils.h:254
#6  0x00007fcc01ce5f6a in KWin::Workspace::updateXStackingOrder() (this=0x5637473668d0)
    at /home/david/projects/kde5/src/kde/workspace/kwin/layers.cpp:732
#7  0x00007fcc01ce5dec in KWin::Workspace::xStackingOrder() const (this=0x5637473668d0)
    at /home/david/projects/kde5/src/kde/workspace/kwin/layers.cpp:719
#8  0x00007fcc01bf3743 in KWin::Compositor::performCompositing() (this=0x563747106850)
    at /home/david/projects/kde5/src/kde/workspace/kwin/composite.cpp:615
#9  0x00007fcc01bf3699 in KWin::Compositor::bufferSwapComplete() (this=0x563747106850)
    at /home/david/projects/kde5/src/kde/workspace/kwin/composite.cpp:593


I'm tempted to say we should queue performCompositing() to happen next event loop. We don't really want to be doing performing big actions in an event handler of DRM events. Though I can't immediately see why that would be the cause.
Comment 1 David Edmundson 2022-03-30 14:44:49 UTC

*** This bug has been marked as a duplicate of bug 442846 ***