Bug 425691 - Add downloaded/total Mb and estimated time remaining to Tasks sheet
Summary: Add downloaded/total Mb and estimated time remaining to Tasks sheet
Status: RESOLVED FIXED
Alias: None
Product: Discover
Classification: Unclassified
Component: discover (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR wishlist
Target Milestone: ---
Assignee: Dan Leinir Turthra Jensen
URL:
Keywords:
: 408587 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-08-22 21:58 UTC by RYDeN
Modified: 2020-12-10 14:07 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
now (8.01 KB, image/png)
2020-08-22 21:58 UTC, RYDeN
Details
I capture ir from google chrome, my suggestion (19.94 KB, image/png)
2020-08-22 21:58 UTC, RYDeN
Details

Note You need to log in before you can comment on or make changes to this bug.
Description RYDeN 2020-08-22 21:58:00 UTC
Created attachment 131107 [details]
now

SUMMARY
I see the Discover's download page incomplete. Most download progams also shows downloaded MB, total MB and time remaining. Look at the attachment please.

STEPS TO REPRODUCE
1. Download something in Discover
2. Click on the download page
3. You can only see, download speed.

OBSERVED RESULT

You can only see, download speed.


EXPECTED RESULT

See more data, such as downloaded MB, total of MB, and time remaining.

SOFTWARE/OS VERSIONS

Operating System: KDE neon 5.19
KDE Plasma Version: 5.19.4
KDE Frameworks Version: 5.73.0
Qt Version: 5.14.2
Kernel Version: 5.4.0-42-generic
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-2600K CPU @ 3.40GHz
Memory: 7.7 GiB of RAM
Graphics Processor: AMD PITCAIRN
Comment 1 RYDeN 2020-08-22 21:58:33 UTC
Created attachment 131108 [details]
I capture ir from google chrome, my suggestion
Comment 2 Nate Graham 2020-08-26 03:06:05 UTC
*** Bug 408587 has been marked as a duplicate of this bug. ***
Comment 3 Bug Janitor Service 2020-10-07 00:47:43 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/discover/-/merge_requests/41
Comment 4 Aleix Pol 2020-12-10 14:07:20 UTC
Git commit 25456fb842bf7842e95aa197b824896adfdbe41f by Aleix Pol Gonzalez, on behalf of Aleix Pol.
Committed on 10/12/2020 at 14:07.
Pushed by apol into branch 'master'.

Make it possible to display the remaining time for a transaction

It will work for backends that specify it.
For now just PackageKit supports it.

M  +2    -1    discover/qml/ProgressView.qml
M  +13   -0    libdiscover/Transaction/Transaction.cpp
M  +9    -0    libdiscover/Transaction/Transaction.h
M  +3    -0    libdiscover/backends/PackageKitBackend/PKTransaction.cpp

https://invent.kde.org/plasma/discover/commit/25456fb842bf7842e95aa197b824896adfdbe41f