Bug 425061 - Inconsistency with menu order KWrite vs Kate (Settings >)
Summary: Inconsistency with menu order KWrite vs Kate (Settings >)
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Applications
Component: kwrite (show other bugs)
Version: 19.12.3
Platform: Kubuntu Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-06 04:45 UTC by Ivar Erikson
Modified: 2022-03-30 20:16 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 22.08.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivar Erikson 2020-08-06 04:45:39 UTC
SUMMARY
The order of settings under Settings toolbar in KWrite and Kate should be the same, since they are more or less "the same" editor, only Kate having access to more advanced funcitons and plugins, where KWrite is a more simple notepad.


Pressing Settings on Kate (which I view as the master application, from which KWrite inherits it's stuff), you'll get the following order og settings:
"""
Colour Theme
Show Menubar
Show Toolbar
Show Statusbar
Show Tabs
Show Path in Titlebar
________
Configure Keyboard Shortcuts
Configure Toolbars
Configure Kate
"""

KWrite have the following: 
"""
Show Menubar
Show Statusbar
Show Toolbar
Show Path in Titlebar
________
Configure Editor (# This should maybe be called Configure KWrite instead?)
Configure Keyboard Shortcuts
Configure Toolbars
"""


As you see, the Show Statusbar and Show Toolbar have switched place from Kate to Kwrite.
Configure Kate and Configure Editor (KWrite) are also in different positions.

My suggestion is that KWrite's menu order be changed to reflect Kate, since Kate likely is the "main" application (both in terms of functionality, and in terms of which application more people are fammiliar with (I'm guessing))

I discovered this by wondering why I'm always hitting the wrong button in KWrite when trying to enter Configure KWrite, and it just dawned on me that the settings order is different :)



STEPS TO REPRODUCE
1. Click Settings (toolbar) in Kate and KWrite
2. Notice that the settings are ordered slighlty differently.
3. 

OBSERVED RESULT
Different menu order.

EXPECTED RESULT
Expected that the settings have the same order. 

SOFTWARE/OS VERSIONS
Operating System: Kubuntu 20.04
KDE Plasma Version: 5.18.5
KDE Frameworks Version: 5.68.0
Qt Version: 5.12.8
Kernel Version: 5.4.0-42-generic
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-4870HQ CPU @ 2.50GHz
Memory: 15,5 GiB of RAM
 

ADDITIONAL INFORMATION
I was not able to get a screenshot of the two menus. Spectacle didn't want to trigger with the menu open. Dunno if this is a limitation of Xorg or Spectacle, but I'm guessing the former. Anyway, it's readily available to anyone interested to simply click the Settings menu in both apps :)

Also, this "bug" might very well be true for the other menus, but I suppose there are easier and faster ways of comparing this in the code somewhere, than by clicking the menus and snapping pictures with your phone to compare.
Comment 1 Christoph Cullmann 2022-03-30 20:15:13 UTC
Git commit ea043f3c389f6ef32949794573da56fd7462ff7f by Christoph Cullmann.
Committed on 30/03/2022 at 20:09.
Pushed by cullmann into branch 'master'.

add simplified session config

this allows some basic stuff to be configured for KWrite

e.g. should it close on last document, how many recent files
and when to clear meta info

as requested in
Related: bug 448786, bug 438783

overall menu consistency is fixed, too

M  +31   -29   kate/kateconfigdialog.cpp
M  +3    -3    kate/ui/sessionconfigwidget.ui

https://invent.kde.org/utilities/kate/commit/ea043f3c389f6ef32949794573da56fd7462ff7f