Bug 424909 - Dolphin crash *after* copying file between USB-attached Android and external HD in tabs
Summary: Dolphin crash *after* copying file between USB-attached Android and external ...
Status: RESOLVED DUPLICATE of bug 422282
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 20.07.80
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-08-02 03:16 UTC by Edward
Modified: 2020-09-08 10:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Edward 2020-08-02 03:16:48 UTC
Application: dolphin (20.07.80)

Qt Version: 5.15.0
Frameworks Version: 5.72.0
Operating System: Linux 4.12.14-lp151.28.52-default x86_64
Windowing system: X11
Distribution: "openSUSE Leap 15.1"

-- Information about the crash:
- What I was doing when the application crashed:
I had a USB-attached external HD open in one dolphin tab, and a USB-attached Android in another, and I dragged a movie file from the former to the latter for copying. The copying completed successfully. Then I went to close the first tab, and dolphin crashed.

-- Backtrace:
Application: Dolphin (dolphin), signal: Aborted

[KCrash Handler]
#4  0x00007f4f15dc6520 in raise () from /lib64/libc.so.6
#5  0x00007f4f15dc7b01 in abort () from /lib64/libc.so.6
#6  0x00007f4f15e09957 in __libc_message () from /lib64/libc.so.6
#7  0x00007f4f15e10173 in malloc_printerr () from /lib64/libc.so.6
#8  0x00007f4f15e11a79 in _int_free () from /lib64/libc.so.6
#9  0x00007f4f0f55bb74 in QHashData::free_helper (this=0x5575bb53bbf0, node_delete=0x7f4f15abaca0 <QHash<QByteArray, QVariant>::deleteNode2(QHashData::Node*)>) at tools/qhash.cpp:573
#10 0x00007f4f15abe6c4 in QHash<QByteArray, QVariant>::freeData (this=0x7f4ef8003628, x=<optimized out>) at /usr/include/qt5/QtCore/qhash.h:619
#11 QHash<QByteArray, QVariant>::~QHash (this=0x7f4ef8003628, __in_chrg=<optimized out>) at /usr/include/qt5/QtCore/qhash.h:250
#12 KFileItemModel::ItemData::~ItemData (this=0x7f4ef8003620, __in_chrg=<optimized out>) at /usr/src/debug/dolphin-20.07.80-lp151.219.1.x86_64/src/kitemviews/kfileitemmodel.h:298
#13 KFileItemModel::removeItems (this=0x5575bbf00d70, itemRanges=..., behavior=KFileItemModel::DeleteItemData) at /usr/src/debug/dolphin-20.07.80-lp151.219.1.x86_64/src/kitemviews/kfileitemmodel.cpp:1296
#14 0x00007f4f15acaa3a in KFileItemModel::setExpanded (this=0x5575bbf00d70, index=1, expanded=<optimized out>) at /usr/src/debug/dolphin-20.07.80-lp151.219.1.x86_64/src/kitemviews/kfileitemmodel.cpp:580
#15 0x00007f4f15adfa43 in KItemListController::mouseReleaseEvent (this=0x5575bb8d5bf0, event=0x7ffd52f52190, transform=...) at /usr/src/debug/dolphin-20.07.80-lp151.219.1.x86_64/src/kitemviews/kitemlistcontroller.cpp:783
#16 0x00007f4f15ae0fd2 in KItemListController::processEvent (this=this@entry=0x5575bb8d5bf0, event=event@entry=0x7ffd52f52190, transform=...) at /usr/src/debug/dolphin-20.07.80-lp151.219.1.x86_64/src/kitemviews/kitemlistcontroller.cpp:1060
#17 0x00007f4f15aefedc in KItemListView::event (this=0x5575bb8d2f50, event=0x7ffd52f52190) at /usr/src/debug/dolphin-20.07.80-lp151.219.1.x86_64/src/kitemviews/kitemlistview.cpp:917
#18 0x00007f4f10b2f2fc in QApplicationPrivate::notify_helper (this=this@entry=0x5575bb0a9ee0, receiver=receiver@entry=0x5575bb8d2f50, e=e@entry=0x7ffd52f52190) at kernel/qapplication.cpp:3671
#19 0x00007f4f10b36210 in QApplication::notify (this=0x7ffd52f530b0, receiver=0x5575bb8d2f50, e=0x7ffd52f52190) at kernel/qapplication.cpp:3417
#20 0x00007f4f0f713f33 in QCoreApplication::notifyInternal2 (receiver=0x5575bb8d2f50, event=0x7ffd52f52190) at kernel/qcoreapplication.cpp:1061
#21 0x00007f4f0f71411e in QCoreApplication::sendSpontaneousEvent (receiver=<optimized out>, event=<optimized out>) at kernel/qcoreapplication.cpp:1468
#22 0x00007f4f10b2f615 in qt_sendSpontaneousEvent (receiver=<optimized out>, event=<optimized out>) at kernel/qapplication.cpp:4092
#23 0x00007f4f10e3ff0d in QGraphicsScenePrivate::sendEvent (this=<optimized out>, item=0x5575bb8d2f60, event=0x7ffd52f52190) at graphicsview/qgraphicsscene.cpp:1254
#24 0x00007f4f10e402f2 in QGraphicsScenePrivate::sendMouseEvent (this=this@entry=0x5575bbd744a0, mouseEvent=mouseEvent@entry=0x7ffd52f52190) at graphicsview/qgraphicsscene.cpp:1335
#25 0x00007f4f10e4569a in QGraphicsScene::mouseReleaseEvent (this=<optimized out>, mouseEvent=0x7ffd52f52190) at graphicsview/qgraphicsscene.cpp:4123
#26 0x00007f4f10e4fbc0 in QGraphicsScene::event (this=0x5575bb528930, event=0x7ffd52f52190) at graphicsview/qgraphicsscene.cpp:3436
#27 0x00007f4f10b2f2fc in QApplicationPrivate::notify_helper (this=this@entry=0x5575bb0a9ee0, receiver=receiver@entry=0x5575bb528930, e=e@entry=0x7ffd52f52190) at kernel/qapplication.cpp:3671
#28 0x00007f4f10b36210 in QApplication::notify (this=0x7ffd52f530b0, receiver=0x5575bb528930, e=0x7ffd52f52190) at kernel/qapplication.cpp:3417
#29 0x00007f4f0f713f33 in QCoreApplication::notifyInternal2 (receiver=0x5575bb528930, event=0x7ffd52f52190) at kernel/qcoreapplication.cpp:1061
#30 0x00007f4f0f71411e in QCoreApplication::sendSpontaneousEvent (receiver=<optimized out>, event=event@entry=0x7ffd52f52190) at kernel/qcoreapplication.cpp:1468
#31 0x00007f4f10b2f615 in qt_sendSpontaneousEvent (receiver=<optimized out>, event=event@entry=0x7ffd52f52190) at kernel/qapplication.cpp:4092
#32 0x00007f4f10e6f59c in QGraphicsView::mouseReleaseEvent (this=0x5575bb8eaa20, event=0x7ffd52f52790) at graphicsview/qgraphicsview.cpp:3430
#33 0x00007f4f10b6fbe8 in QWidget::event (this=this@entry=0x5575bb8eaa20, event=event@entry=0x7ffd52f52790) at kernel/qwidget.cpp:9027
#34 0x00007f4f10c1667e in QFrame::event (this=0x5575bb8eaa20, e=0x7ffd52f52790) at widgets/qframe.cpp:550
#35 0x00007f4f10e703a3 in QGraphicsView::viewportEvent (this=0x5575bb8eaa20, event=0x7ffd52f52790) at graphicsview/qgraphicsview.cpp:3014
#36 0x00007f4f0f713cc0 in QCoreApplicationPrivate::sendThroughObjectEventFilters (receiver=receiver@entry=0x5575bb5423e0, event=event@entry=0x7ffd52f52790) at kernel/qcoreapplication.cpp:1187
#37 0x00007f4f10b2f2d2 in QApplicationPrivate::notify_helper (this=this@entry=0x5575bb0a9ee0, receiver=receiver@entry=0x5575bb5423e0, e=e@entry=0x7ffd52f52790) at kernel/qapplication.cpp:3665
#38 0x00007f4f10b37058 in QApplication::notify (this=<optimized out>, receiver=0x5575bb5423e0, e=0x7ffd52f52790) at kernel/qapplication.cpp:3115
#39 0x00007f4f0f713f33 in QCoreApplication::notifyInternal2 (receiver=0x5575bb5423e0, event=0x7ffd52f52790) at kernel/qcoreapplication.cpp:1061
#40 0x00007f4f0f71411e in QCoreApplication::sendSpontaneousEvent (receiver=receiver@entry=0x5575bb5423e0, event=event@entry=0x7ffd52f52790) at kernel/qcoreapplication.cpp:1468
#41 0x00007f4f10b356df in QApplicationPrivate::sendMouseEvent (receiver=receiver@entry=0x5575bb5423e0, event=event@entry=0x7ffd52f52790, alienWidget=0x5575bb5423e0, nativeWidget=0x5575bb07ba30, buttonDown=buttonDown@entry=0x7f4f11241990 <qt_button_down>, lastMouseReceiver=..., spontaneous=true, onlyDispatchEnterLeave=false) at kernel/qapplication.cpp:2603
#42 0x00007f4f10b8a3d5 in QWidgetWindow::handleMouseEvent (this=this@entry=0x5575bb3b93d0, event=event@entry=0x7ffd52f52c00) at kernel/qwidgetwindow.cpp:675
#43 0x00007f4f10b8d43a in QWidgetWindow::event (this=0x5575bb3b93d0, event=0x7ffd52f52c00) at kernel/qwidgetwindow.cpp:295
#44 0x00007f4f10b2f2fc in QApplicationPrivate::notify_helper (this=this@entry=0x5575bb0a9ee0, receiver=receiver@entry=0x5575bb3b93d0, e=e@entry=0x7ffd52f52c00) at kernel/qapplication.cpp:3671
#45 0x00007f4f10b36210 in QApplication::notify (this=0x7ffd52f530b0, receiver=0x5575bb3b93d0, e=0x7ffd52f52c00) at kernel/qapplication.cpp:3417
#46 0x00007f4f0f713f33 in QCoreApplication::notifyInternal2 (receiver=0x5575bb3b93d0, event=0x7ffd52f52c00) at kernel/qcoreapplication.cpp:1061
#47 0x00007f4f0f71411e in QCoreApplication::sendSpontaneousEvent (receiver=receiver@entry=0x5575bb3b93d0, event=event@entry=0x7ffd52f52c00) at kernel/qcoreapplication.cpp:1468
#48 0x00007f4f1020d305 in QGuiApplicationPrivate::processMouseEvent (e=0x5575bb54f810) at kernel/qguiapplication.cpp:2214
#49 0x00007f4f1020e435 in QGuiApplicationPrivate::processWindowSystemEvent (e=e@entry=0x5575bb54f810) at kernel/qguiapplication.cpp:1946
#50 0x00007f4f101e62eb in QWindowSystemInterface::sendWindowSystemEvents (flags=flags@entry=...) at kernel/qwindowsysteminterface.cpp:1175
#51 0x00007f4f00565baa in xcbSourceDispatch (source=<optimized out>) at qxcbeventdispatcher.cpp:105
#52 0x00007f4f07478e87 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#53 0x00007f4f07479230 in ?? () from /usr/lib64/libglib-2.0.so.0
#54 0x00007f4f074792bc in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#55 0x00007f4f0f77658c in QEventDispatcherGlib::processEvents (this=0x5575bb1207c0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#56 0x00007f4f0f7127ba in QEventLoop::exec (this=this@entry=0x7ffd52f52fa0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:232
#57 0x00007f4f0f71bfb7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1369
#58 0x00007f4f10201e0c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1867
#59 0x00007f4f10b2f255 in QApplication::exec () at kernel/qapplication.cpp:2811
#60 0x00007f4f161936fb in kdemain (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/dolphin-20.07.80-lp151.219.1.x86_64/src/main.cpp:189
#61 0x00007f4f15db134a in __libc_start_main () from /lib64/libc.so.6
#62 0x00005575ba89880a in _start () at ../sysdeps/x86_64/start.S:120
[Inferior 1 (process 3654) detached]

Possible duplicates by query: bug 424295, bug 422282, bug 403691, bug 403665, bug 400686.

Reported using DrKonqi
Comment 1 Christoph Feck 2020-08-26 20:10:34 UTC
Are you using the Tree view in Dolphin?
Comment 2 Edward 2020-08-27 20:14:29 UTC
Yes, using Tree View.
Comment 3 Christoph Feck 2020-09-08 10:52:43 UTC

*** This bug has been marked as a duplicate of bug 422282 ***