Bug 424742 - Korganizer crashes when editing categories colors
Summary: Korganizer crashes when editing categories colors
Status: RESOLVED DUPLICATE of bug 413740
Alias: None
Product: korganizer
Classification: Applications
Component: general (show other bugs)
Version: 5.14.2
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-07-28 10:33 UTC by Andres Nogueiras
Modified: 2020-09-23 17:57 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (12.35 KB, text/plain)
2020-07-28 11:09 UTC, Andres Nogueiras
Details
New crash information added by DrKonqi (4.32 KB, text/plain)
2020-08-06 15:16 UTC, Kleber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andres Nogueiras 2020-07-28 10:33:48 UTC
Application: korganizer (5.14.2 (20.04.2))

Qt Version: 5.12.7
Frameworks Version: 5.71.0
Operating System: Linux 5.7.10-1.g6a1b5cf-default x86_64
Windowing system: X11
Distribution: "openSUSE Leap 15.2"

-- Information about the crash:
- What I was doing when the application crashed:

I was editing, on a fresh install, the colors of the categories, and it crashed

-- Backtrace:
Application: KOrganizer (korganizer), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe63881df00 (LWP 17662))]

Thread 13 (Thread 0x7fe5ef7fe700 (LWP 17690)):
#0  0x00007fe62bca787d in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe5fdda0e88 in ?? () from /usr/lib64/dri/swrast_dri.so
#2  0x00007fe5fdda0e07 in ?? () from /usr/lib64/dri/swrast_dri.so
#3  0x00007fe62bca14f9 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fe633efbf2f in clone () from /lib64/libc.so.6

Thread 12 (Thread 0x7fe5f4f72700 (LWP 17689)):
#0  0x00007fe62bca787d in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe5fdda0e88 in ?? () from /usr/lib64/dri/swrast_dri.so
#2  0x00007fe5fdda0e07 in ?? () from /usr/lib64/dri/swrast_dri.so
#3  0x00007fe62bca14f9 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fe633efbf2f in clone () from /lib64/libc.so.6

Thread 11 (Thread 0x7fe5f5773700 (LWP 17688)):
#0  0x00007fe62bca787d in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe5fdda0e88 in ?? () from /usr/lib64/dri/swrast_dri.so
#2  0x00007fe5fdda0e07 in ?? () from /usr/lib64/dri/swrast_dri.so
#3  0x00007fe62bca14f9 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fe633efbf2f in clone () from /lib64/libc.so.6

Thread 10 (Thread 0x7fe5f5f74700 (LWP 17687)):
#0  0x00007fe62bca787d in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe5fdda0e88 in ?? () from /usr/lib64/dri/swrast_dri.so
#2  0x00007fe5fdda0e07 in ?? () from /usr/lib64/dri/swrast_dri.so
#3  0x00007fe62bca14f9 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fe633efbf2f in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7fe5effff700 (LWP 17686)):
#0  0x00007fe62bca787d in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe5fdda398b in ?? () from /usr/lib64/dri/swrast_dri.so
#2  0x00007fe5fdda3807 in ?? () from /usr/lib64/dri/swrast_dri.so
#3  0x00007fe62bca14f9 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fe633efbf2f in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7fe5f6775700 (LWP 17685)):
#0  0x00007fe62bca787d in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe5fdda398b in ?? () from /usr/lib64/dri/swrast_dri.so
#2  0x00007fe5fdda3807 in ?? () from /usr/lib64/dri/swrast_dri.so
#3  0x00007fe62bca14f9 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fe633efbf2f in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7fe5f6f76700 (LWP 17684)):
#0  0x00007fe62bca787d in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe5fdda398b in ?? () from /usr/lib64/dri/swrast_dri.so
#2  0x00007fe5fdda3807 in ?? () from /usr/lib64/dri/swrast_dri.so
#3  0x00007fe62bca14f9 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fe633efbf2f in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7fe5f7777700 (LWP 17683)):
#0  0x00007fe62bca787d in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe5fdda398b in ?? () from /usr/lib64/dri/swrast_dri.so
#2  0x00007fe5fdda3807 in ?? () from /usr/lib64/dri/swrast_dri.so
#3  0x00007fe62bca14f9 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fe633efbf2f in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7fe6129df700 (LWP 17671)):
#0  0x00007fe629abbab9 in g_mutex_lock () from /usr/lib64/libglib-2.0.so.0
#1  0x00007fe629a6f80e in g_main_context_acquire () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fe629a70635 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fe629a7088c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007fe634a9f19b in QEventDispatcherGlib::processEvents (this=0x7fe600000b10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fe634a4032a in QEventLoop::exec (this=this@entry=0x7fe6129dec70, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#6  0x00007fe63486610a in QThread::exec (this=<optimized out>) at thread/qthread.cpp:531
#7  0x00007fe6348678b2 in QThreadPrivate::start (arg=0x5579a4db7bc0) at thread/qthread_unix.cpp:361
#8  0x00007fe62bca14f9 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fe633efbf2f in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fe6131e0700 (LWP 17668)):
#0  0x00007fe633ef16db in poll () from /lib64/libc.so.6
#1  0x00007fe629a70779 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fe629a7088c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fe634a9f19b in QEventDispatcherGlib::processEvents (this=0x7fe608000b10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fe634a4032a in QEventLoop::exec (this=this@entry=0x7fe6131dfc70, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007fe63486610a in QThread::exec (this=<optimized out>) at thread/qthread.cpp:531
#6  0x00007fe6348678b2 in QThreadPrivate::start (arg=0x5579a4d285a0) at thread/qthread_unix.cpp:361
#7  0x00007fe62bca14f9 in start_thread () from /lib64/libpthread.so.0
#8  0x00007fe633efbf2f in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fe618ca0700 (LWP 17664)):
#0  0x00007fe629abbad4 in g_mutex_unlock () from /usr/lib64/libglib-2.0.so.0
#1  0x00007fe629a7076e in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fe629a7088c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fe634a9f19b in QEventDispatcherGlib::processEvents (this=0x7fe60c000b10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fe634a4032a in QEventLoop::exec (this=this@entry=0x7fe618c9fc40, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007fe63486610a in QThread::exec (this=<optimized out>) at thread/qthread.cpp:531
#6  0x00007fe6333accd5 in ?? () from /usr/lib64/libQt5DBus.so.5
#7  0x00007fe6348678b2 in QThreadPrivate::start (arg=0x7fe633624d80) at thread/qthread_unix.cpp:361
#8  0x00007fe62bca14f9 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fe633efbf2f in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fe61b422700 (LWP 17663)):
#0  0x00007fe633ef16db in poll () from /lib64/libc.so.6
#1  0x00007fe6295fd397 in _xcb_conn_wait () from /usr/lib64/libxcb.so.1
#2  0x00007fe6295ff05a in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007fe61e00e300 in ?? () from /usr/lib64/libQt5XcbQpa.so.5
#4  0x00007fe6348678b2 in QThreadPrivate::start (arg=0x5579a4c18ed0) at thread/qthread_unix.cpp:361
#5  0x00007fe62bca14f9 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fe633efbf2f in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fe63881df00 (LWP 17662)):
[KCrash Handler]
#4  std::__atomic_base<int>::load (__m=std::memory_order_relaxed, this=0x18) at /usr/include/c++/7/bits/atomic_base.h:396
#5  QAtomicOps<int>::load<int> (_q_value=...) at ../../include/QtCore/../../src/corelib/thread/qatomic_cxx11.h:227
#6  QBasicAtomicInteger<int>::load (this=0x18) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:103
#7  QtPrivate::RefCount::ref (this=0x18) at ../../include/QtCore/../../src/corelib/tools/qrefcount.h:55
#8  0x00007fe6349f3674 in QVector<QPersistentModelIndexData*>::QVector (this=0x7fffb70019b0, v=...) at ../../include/QtCore/../../src/corelib/tools/qvector.h:359
#9  0x00007fe6349f432a in QStack<QVector<QPersistentModelIndexData*> >::pop (this=this@entry=0x5579a5626400) at ../../include/QtCore/../../src/corelib/tools/qstack.h:62
#10 0x00007fe6349edcd2 in QAbstractItemModelPrivate::itemsMoved (this=this@entry=0x5579a5626380, sourceParent=..., sourceFirst=sourceFirst@entry=-1519173008, sourceLast=sourceLast@entry=21881, destinationParent=..., destinationChild=destinationChild@entry=2, orientation=Qt::Vertical) at itemmodels/qabstractitemmodel.cpp:797
#11 0x00007fe6349f0f1b in QAbstractItemModel::endMoveRows (this=this@entry=0x5579a5611080) at itemmodels/qabstractitemmodel.cpp:2985
#12 0x00007fe6311b2300 in Akonadi::TagModelPrivate::monitoredTagChanged (this=0x5579a5624680, tag=...) at /usr/src/debug/akonadi-server-20.04.2-lp152.1.1.x86_64/src/core/models/tagmodel_p.cpp:208
#13 0x00007fe6311afa6d in Akonadi::TagModel::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/akonadi-server-20.04.2-lp152.1.1.x86_64/build/src/core/KF5AkonadiCore_autogen/include/moc_tagmodel.cpp:109
#14 0x00007fe634a71bf5 in QMetaObject::activate (sender=0x5579a561a020, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=22, argv=argv@entry=0x7fffb7001d60) at kernel/qobject.cpp:3804
#15 0x00007fe634a72307 in QMetaObject::activate (sender=<optimized out>, m=m@entry=0x7fe63142dde0 <Akonadi::Monitor::staticMetaObject>, local_signal_index=local_signal_index@entry=22, argv=argv@entry=0x7fffb7001d60) at kernel/qobject.cpp:3657
#16 0x00007fe6310c9505 in Akonadi::Monitor::tagChanged (this=<optimized out>, _t1=...) at /usr/src/debug/akonadi-server-20.04.2-lp152.1.1.x86_64/build/src/core/KF5AkonadiCore_autogen/include/moc_monitor.cpp:1055
#17 0x00007fe6310d410a in Akonadi::MonitorPrivate::emitToListeners<void (Akonadi::Monitor::*)(Akonadi::Tag const&), Akonadi::Tag> (signal=<optimized out>, this=0x5579a50343f0) at /usr/src/debug/akonadi-server-20.04.2-lp152.1.1.x86_64/src/core/monitor_p.h:404
#18 Akonadi::MonitorPrivate::emitTagNotification (this=this@entry=0x5579a50343f0, msg=..., tag=...) at /usr/src/debug/akonadi-server-20.04.2-lp152.1.1.x86_64/src/core/monitor_p.cpp:1153
#19 0x00007fe6310d86d6 in Akonadi::MonitorPrivate::emitNotification (this=0x5579a50343f0, msg=...) at /usr/src/debug/akonadi-server-20.04.2-lp152.1.1.x86_64/src/core/monitor_p.cpp:515
#20 0x00007fe6310d6c0c in Akonadi::MonitorPrivate::dispatchNotifications (this=this@entry=0x5579a50343f0) at /usr/src/debug/akonadi-server-20.04.2-lp152.1.1.x86_64/src/core/monitor_p.cpp:1003
#21 0x00007fe6310d6d89 in Akonadi::MonitorPrivate::slotNotify (this=0x5579a50343f0, msg=...) at /usr/src/debug/akonadi-server-20.04.2-lp152.1.1.x86_64/src/core/monitor_p.cpp:972
#22 0x00007fe6310d97c7 in Akonadi::MonitorPrivate::handleCommands (this=0x5579a50343f0) at /usr/src/debug/akonadi-server-20.04.2-lp152.1.1.x86_64/src/core/monitor_p.cpp:867
#23 0x00007fe634a727a2 in QObject::event (this=0x5579a561a020, e=<optimized out>) at kernel/qobject.cpp:1261
#24 0x00007fe635ad8a0c in QApplicationPrivate::notify_helper (this=this@entry=0x5579a4bf3e70, receiver=receiver@entry=0x5579a561a020, e=e@entry=0x7fe608081a80) at kernel/qapplication.cpp:3701
#25 0x00007fe635ae0020 in QApplication::notify (this=0x7fffb70027c0, receiver=0x5579a561a020, e=0x7fe608081a80) at kernel/qapplication.cpp:3447
#26 0x00007fe634a420d8 in QCoreApplication::notifyInternal2 (receiver=0x5579a561a020, event=0x7fe608081a80) at kernel/qcoreapplication.cpp:1088
#27 0x00007fe634a422ae in QCoreApplication::sendEvent (receiver=<optimized out>, event=event@entry=0x7fe608081a80) at kernel/qcoreapplication.cpp:1476
#28 0x00007fe634a44c97 in QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x5579a4beed90) at kernel/qcoreapplication.cpp:1825
#29 0x00007fe634a45238 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1679
#30 0x00007fe634a9fb63 in postEventSourceDispatch (s=0x5579a4cc91c0) at kernel/qeventdispatcher_glib.cpp:276
#31 0x00007fe629a70464 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#32 0x00007fe629a70800 in ?? () from /usr/lib64/libglib-2.0.so.0
#33 0x00007fe629a7088c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#34 0x00007fe634a9f17f in QEventDispatcherGlib::processEvents (this=0x5579a4cc9fd0, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#35 0x00007fe634a4032a in QEventLoop::exec (this=this@entry=0x7fffb70026e0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#36 0x00007fe634a49530 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1389
#37 0x00005579a2bdd647 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/korganizer-20.04.2-lp152.1.1.x86_64/src/main.cpp:64
[Inferior 1 (process 17662) detached]

The reporter indicates this bug may be a duplicate of or related to bug 413740.

Possible duplicates by query: bug 423579, bug 422092, bug 421812, bug 421668, bug 421501.

Reported using DrKonqi
Comment 1 Andres Nogueiras 2020-07-28 11:09:47 UTC
Created attachment 130456 [details]
New crash information added by DrKonqi

korganizer (5.14.2 (20.04.2)) using Qt 5.12.7

- What I was doing when the application crashed:

Once again, I was changing and setting colors for the categories (labels). Once I click on "Aceptar" (OK/DONE) the app crashes

-- Backtrace (Reduced):
#4  std::__atomic_base<int>::load (__m=std::memory_order_relaxed, this=0x18) at /usr/include/c++/7/bits/atomic_base.h:396
#5  QAtomicOps<int>::load<int> (_q_value=...) at ../../include/QtCore/../../src/corelib/thread/qatomic_cxx11.h:227
#6  QBasicAtomicInteger<int>::load (this=0x18) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:103
[...]
#8  0x00007f7e5b99f674 in QVector<QPersistentModelIndexData*>::QVector (this=0x7ffd674f6880, v=...) at ../../include/QtCore/../../src/corelib/tools/qvector.h:359
#9  0x00007f7e5b9a032a in QStack<QVector<QPersistentModelIndexData*> >::pop (this=this@entry=0x55f159d16c70) at ../../include/QtCore/../../src/corelib/tools/qstack.h:62
Comment 2 gjditchfield 2020-07-28 14:12:36 UTC
Also affects 5.14.3, Frameworks 5.72.0, QT 5.14.2, KDE Neon.  Crash occurs when changing colors in Configure dialog, Colors and Fonts tab.
Comment 3 Kleber 2020-08-06 15:16:02 UTC
Created attachment 130680 [details]
New crash information added by DrKonqi

kontact (5.14.3 (20.04.3)) using Qt 5.15.0

- What I was doing when the application crashed:
I was changing the color of a message tag when applying, kontact crash.

-- Backtrace (Reduced):
#4  0x00007f1f8255ca7f in std::__atomic_base<int>::load (__m=std::memory_order_relaxed, this=<optimized out>) at /usr/include/c++/10/bits/atomic_base.h:420
#5  QAtomicOps<int>::loadRelaxed<int> (_q_value=...) at ../../include/QtCore/../../src/corelib/thread/qatomic_cxx11.h:239
#6  QBasicAtomicInteger<int>::loadRelaxed (this=<optimized out>) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:107
[...]
#8  QVector<QPersistentModelIndexData*>::QVector (this=0x7fffa83c7800, v=...) at ../../include/QtCore/../../src/corelib/tools/qvector.h:380
#9  0x00007f1f8255d414 in QStack<QVector<QPersistentModelIndexData*> >::pop (this=this@entry=0x55cb97b52288) at ../../include/QtCore/../../src/corelib/tools/qvector.h:88
Comment 4 Wolfgang Bauer 2020-09-23 17:57:39 UTC

*** This bug has been marked as a duplicate of bug 413740 ***