Bug 424740 - [libzip] Incorrect access time (atime) for extracted folder
Summary: [libzip] Incorrect access time (atime) for extracted folder
Status: RESOLVED DUPLICATE of bug 450125
Alias: None
Product: ark
Classification: Applications
Component: plugins (show other bugs)
Version: 21.04.1
Platform: Arch Linux Linux
: NOR normal
Target Milestone: ---
Assignee: Ragnar Thomsen
Depends on:
Reported: 2020-07-28 09:45 UTC by 2wxsy58236r3
Modified: 2022-02-14 10:02 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description 2wxsy58236r3 2020-07-28 09:45:17 UTC

After extracting files from a particular ZIP archive using the libzip backend, the extracted folder has incorrect access time.


1. Download Attachment 109492 [details] (from Bug 387996).
2. Since the ZIP uses LZMA, the latest git master of libzip has to be used.
3. Use Ark + libzip (git master) to extract the ZIP.
4. Use other programs, such as p7zip, to extract the ZIP to another location and compare the results.


The access time date can be something like 4436086-12-21 or 4426948-12-29 (Year-Month-Date).

The timestamp is different each time the file is extracted, and the Year value is always wrong and impossible.


The following comment by libzip's author may be useful:
Comment 1 valdikss 2021-08-06 13:48:10 UTC
Thanks Ark for finding year 2038 problem in Wine.

This is how I spotted the bug:

1. Downloaded a small freeware game in .zip archive
2. Unpacked it with Ark, the access time was year 2446
3. Tried to run the game, it hangs silently
4. Tried to copy the game directory with `cp -r`, the game works, since cp changes access time

Took almost an hour to debug this magic.
Comment 2 Albert Astals Cid 2022-02-14 10:02:14 UTC

*** This bug has been marked as a duplicate of bug 450125 ***