Bug 424154 - Track progress and volume sliders can be moved by clicking outside of them
Summary: Track progress and volume sliders can be moved by clicking outside of them
Status: RESOLVED FIXED
Alias: None
Product: Elisa
Classification: Unclassified
Component: general (show other bugs)
Version: 20.04.3
Platform: Archlinux Packages Linux
: VHI normal
Target Milestone: ---
Assignee: Nate Graham
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2020-07-13 13:24 UTC by Matej Mrenica
Modified: 2020-08-02 15:50 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 20.08.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matej Mrenica 2020-07-13 13:24:38 UTC
STEPS TO REPRODUCE
1. Play a song 
2. Click somewhere around the artist or album name

OBSERVED RESULT
The playing track progress slider will move to the spot bellow where you clicked.
The same applies for sound volume slider.

EXPECTED RESULT
Track and volume sliders are only triggered by clicking in their areas.

SOFTWARE/OS VERSIONS
KDE Frameworks Version: 5.72
Qt Version: 5.15.0
Comment 1 Nate Graham 2020-07-13 18:16:15 UTC
Yep, I just noticed this. The background is also misplaced, which seems to be related.

We should fix this before 20.08 ships.
Comment 2 Matthieu Gallien 2020-07-27 20:35:06 UTC
I will work on this.
Comment 3 Matthieu Gallien 2020-07-27 21:00:32 UTC
(In reply to Nate Graham from comment #1)
> Yep, I just noticed this. The background is also misplaced, which seems to
> be related.
> 
> We should fix this before 20.08 ships.

I am not sure I understand the problem with respect to the background.

The fact that the active zone of the slider extends to the full height looks like a deliberate choice made in https://phabricator.kde.org/D22951 . We have to decide if we want to keep the easy usage of if we want to revert those changes.

I can confirm that reverting the changes indeed solves the issue here.
Comment 4 Nate Graham 2020-07-27 21:01:48 UTC
That change did not result in this regression for me until very recently, so I suspect some other relevant thing changed between then and now to trigger the bug.
Comment 5 Nate Graham 2020-07-27 21:10:56 UTC
I have found the problem and will submit a merge request soon.
Comment 6 Bug Janitor Service 2020-07-27 21:19:51 UTC
A possibly relevant merge request was started @ https://invent.kde.org/multimedia/elisa/-/merge_requests/138
Comment 7 Nate Graham 2020-07-27 22:24:22 UTC
Git commit f07a85bf3adc8619b2af952aa8c4a15bc96efede by Nate Graham.
Committed on 27/07/2020 at 21:18.
Pushed by ngraham into branch 'release/20.08'.

Fix misplaced slider backgrounds

Binding x and y to padding values makes no sense, so let's use anchors
instead.
FIXED-IN: 20.08.0

M  +4    -6    src/qml/MediaPlayerControl.qml

https://invent.kde.org/multimedia/elisa/commit/f07a85bf3adc8619b2af952aa8c4a15bc96efede
Comment 8 Patrick Silva 2020-08-02 15:10:18 UTC
This behavior is still reproducible with Elisa 20.08 RC when I click below the album name.

Operating System: Arch Linux
KDE Plasma Version: 5.19.4
KDE Frameworks Version: 5.72.0
Qt Version: 5.15.0
Comment 9 Nate Graham 2020-08-02 15:26:39 UTC
Oh goodness you're right.

I think I know what's up, and I'll fix that too.
Comment 10 Nate Graham 2020-08-02 15:49:08 UTC
Git commit adcba7aa89637b2be21e840a6befca9a774986d5 by Nate Graham.
Committed on 02/08/2020 at 15:48.
Pushed by ngraham into branch 'release/20.08'.

Fix excessively tall hit areas for playback and volume sliders

M  +4    -5    src/qml/MediaPlayerControl.qml

https://invent.kde.org/multimedia/elisa/commit/adcba7aa89637b2be21e840a6befca9a774986d5
Comment 11 Nate Graham 2020-08-02 15:50:18 UTC
That should do it for the final release.

Thanks for your excellent QA, as always. :)