Bug 423995 - Plasma 5.19.3 overwrites systemwide locale settings despite "no change" is selected in kcm_formats
Summary: Plasma 5.19.3 overwrites systemwide locale settings despite "no change" is se...
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_formats (show other bugs)
Version: 5.19.3
Platform: Gentoo Packages Linux
: VHI normal with 1 vote (vote)
Target Milestone: ---
Assignee: Sebastian Kügler
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2020-07-08 14:07 UTC by Till Schäfer
Modified: 2020-07-15 19:31 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.19.4


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Till Schäfer 2020-07-08 14:07:12 UTC
Since Plasma 5.19.3 (upgraded from 5.19.2) my clock and all other applications changed from the German time format to the US format.

Somehow Plasma does no longer respect my global / system wide settings of LANG/LC_ environment variables despite the fact, that I have selected "no change" and disabled the checkbox "detailed settings" in kcm_formats. 

This is traceable using the commands locale and env inside plasma and on some TTY:

INSIDE PLASMA
$ env | grep -e "LANG\|LC_"
LANGUAGE=
LC_MONETARY=en_US.utf8
LANG=en_US.utf8
LC_MEASUREMENT=en_US.utf8
LC_TIME=en_US.utf8
LC_COLLATE=C
LC_NUMERIC=en_US.utf8

$ locale
LANG=en_US.utf8
LC_CTYPE="en_US.utf8"
LC_NUMERIC=en_US.utf8
LC_TIME=en_US.utf8
LC_COLLATE=C
LC_MONETARY=en_US.utf8
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT=en_US.utf8
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=


ON TTY
$ env | grep -e "LANG\|LC_"
LANG=en_US.utf8
LC_TIME=de_DE.utf8
LC_COLLATE=C

$ locale
LANG=en_US.utf8
LC_CTYPE="en_US.utf8"
LC_NUMERIC="en_US.utf8"
LC_TIME=de_DE.utf8
LC_COLLATE=C
LC_MONETARY="en_US.utf8"
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT="en_US.utf8"
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=


I have tried to delete ~/.config/plasma-localerc, but this did not changed anything. The config was recreated using the following settings.

$ cat ~/.config/plasma-localerc 
[Formats]
LANG=en_US.utf8



Operating System: Gentoo Linux
KDE Plasma Version: 5.19.3
KDE Frameworks Version: 5.71.0
Qt Version: 5.15.0
Kernel Version: 5.7.7-gentoo
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-4790K CPU @ 4.00GHz
Memory: 23.5 GiB of RAM
Graphics Processor: GeForce GTX 970/PCIe/SSE2
Comment 1 Till Schäfer 2020-07-08 14:21:47 UTC
This become especially problematic in combination with Bug 403580
Comment 2 Nate Graham 2020-07-09 03:11:11 UTC
Alexander, would you mind taking a look to see if this is related to your work in https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/100 which landed in Plasma 5.19.3? Thanks!
Comment 3 Alexander Lohnau 2020-07-09 05:50:32 UTC
Yes this seems related to the MR, really sorry for causing issues :/

I would recommend reverting the commit since it causes issues and then settling for a different approach to the original issue.

PS: The MR is not related to the invalid suggestions mentioned in BUG 403580, just saying.
Comment 4 Till Schäfer 2020-07-09 09:38:03 UTC
I can confirm that the mentioned commit is the issue. I have applied the revert patch here on top of plasma 5.19.3 and it fixes the problem.
Comment 5 Nate Graham 2020-07-15 19:31:18 UTC
Git commit bd8aa17588233dd6f8927c17aef193f6e1df5e58 by Nate Graham.
Committed on 15/07/2020 at 19:30.
Pushed by ngraham into branch 'Plasma/5.19'.

Revert "Fix broken ENV variables for detailed settings"

This reverts commit edc64d04a1e569d7032c41e6ee0ebf59833c26f2.

This commit unfortunately caused a serious regression. Another approach
will be needed to solve 176650 and 417070.
FIXED-IN: 5.19.4
CCMAIL: alexander.lohnau@gmx.de

M  +10   -21   startkde/startplasma.cpp

https://invent.kde.org/plasma/plasma-workspace/commit/bd8aa17588233dd6f8927c17aef193f6e1df5e58
Comment 6 Nate Graham 2020-07-15 19:31:49 UTC
Git commit 1cfd9e882df3af50219b730493947e8ee02b5ed4 by Nate Graham.
Committed on 15/07/2020 at 19:31.
Pushed by ngraham into branch 'master'.

Revert "Fix broken ENV variables for detailed settings"

This reverts commit edc64d04a1e569d7032c41e6ee0ebf59833c26f2.

This commit unfortunately caused a serious regression. Another approach
will be needed to solve 176650 and 417070.
FIXED-IN: 5.19.4
CCMAIL: alexander.lohnau@gmx.de

M  +10   -21   startkde/startplasma.cpp

https://invent.kde.org/plasma/plasma-workspace/commit/1cfd9e882df3af50219b730493947e8ee02b5ed4