Bug 423810 - Device Notifier tries to auto-mount a NTFS partition from Hard Disk at login
Summary: Device Notifier tries to auto-mount a NTFS partition from Hard Disk at login
Status: RESOLVED DUPLICATE of bug 407192
Alias: None
Product: frameworks-solid
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 5.71.0
Platform: OpenSUSE Linux
: NOR normal
Target Milestone: ---
Assignee: Lukáš Tinkl
URL: https://bugzilla.opensuse.org/show_bu...
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-02 19:50 UTC by Guilherme Silva
Modified: 2021-04-28 22:01 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
My settings for Device Notifier (69.49 KB, image/png)
2020-07-02 19:50 UTC, Guilherme Silva
Details
Device Notifier trying to mount NTFS partition from hard drive at login (70.98 KB, image/png)
2020-07-02 19:52 UTC, Guilherme Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guilherme Silva 2020-07-02 19:50:29 UTC
SUMMARY
I have configured Device Notifier to "automatically mount all removable media at login", but for some reason, it is still asking me to mount a NTFS partition from my hard disk, every time I login.

The offending partition resides on /dev/sdb, which is a 1 TB hard disk:

# fdisk -l /dev/sdb
Disk /dev/sdb: 931,53 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: ST1000DM003-1CH1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt

Device         Start        End   Sectors   Size Type
/dev/sdb1     208904  976976909 976768006 465,8G Microsoft basic data
/dev/sdb2  976977920 1953523711 976545792 465,7G Linux LVM

As you can see, there is actually two partitions in that disk, but Device Notifier only tries to mount the first one - I know because it prompts me for my root password every time I log in.

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20200630
KDE Plasma Version: 5.19.2
KDE Frameworks Version: 5.71.0
Qt Version: 5.15.0
Kernel Version: 5.7.5-1-default
OS Type: 64-bit

ADDITIONAL INFORMATION
The time I was using Arch Linux I was also experiencing this, but I didn't actually report to you guys because I thought I was messing something up. But this openSUSE installation is fresh, so it wasn't actually me.
Comment 1 Guilherme Silva 2020-07-02 19:50:54 UTC
Created attachment 129850 [details]
My settings for Device Notifier
Comment 2 Guilherme Silva 2020-07-02 19:52:17 UTC
Created attachment 129851 [details]
Device Notifier trying to mount NTFS partition from hard drive at login
Comment 3 Patrick Silva 2020-07-18 21:37:19 UTC
Same thing here.
The hard disk where my system is installed has an additional EXT4 partition to store personal data and 2 NTFS partitions, Plasma only tries to mount the ETX4 one after login. This EXT4 partition is already mounted on boot (I edited fstab file to it) but Plasma tries to mount it again after login and asks for my password.
I use other 2 hard disks, but Plasma only tries to mount the additional EXT4 partition of the hard disk where my system is installed.
This behavior only occurs on my system if "Enable automatic mounting of removable media"
option is checked in System Settings > Removable Storage > Removable Devices. 

In my case Plasma tries to mount sda4 partition

Device     Boot     Start        End    Sectors   Size Id Type
/dev/sda1            2048     206846     204799   100M  7 HPFS/NTFS/exFAT
/dev/sda2          206848  315870028  315663181 150.5G  7 HPFS/NTFS/exFAT
/dev/sda3  *    315871232  630444031  314572800   150G 83 Linux
/dev/sda4       630444032 1953519615 1323075584 630.9G 83 Linux

Operating System: Arch Linux
KDE Plasma Version: 5.19.3
KDE Frameworks Version: 5.72.0
Qt Version: 5.15.0
Comment 4 Patrick Silva 2020-09-27 11:19:09 UTC
possibly related to bug 407192
Comment 5 Nate Graham 2020-11-25 01:08:44 UTC
Are any of these partitions encrypted? If so, this may be an openSUSE bug: https://bugzilla.opensuse.org/show_bug.cgi?id=1171215

Otherwise, yeah, it might be Bug 407192.

Either way, it's not an issue in the Device Notifier, which isn't responsible for these kinds of mounting decisions. Moving to Solid for now.
Comment 6 Patrick Silva 2020-11-25 01:16:50 UTC
I do not use any encrypted partition.
Comment 7 Nate Graham 2020-11-25 01:18:14 UTC
Did you use Partition Manager or the Calamares installer (which does use Partition Manager under the hood) to create the affected partition? If so, it's probably Bug 407192. If not, I guess we have to keep looking.
Comment 8 Patrick Silva 2020-11-25 01:51:27 UTC
I did not use Calamares installer. Possibly I created my affected ext4
partition with KDE Partition Manager, I'm not sure.
Comment 9 Nate Graham 2020-11-25 02:24:07 UTC
Al right, well let's take the path of least resistance and assume so. :)

*** This bug has been marked as a duplicate of bug 407192 ***
Comment 10 Guilherme Silva 2021-04-28 22:01:41 UTC
I know this has been marked as duplicate, but I'm not sure about it.

Pardon my ignorance, but why does the Device Notifier is trying to mount a hard disk in the first place? Because I've configured it to only mount removable devices.