Bug 423747 - Barely readable caption text when Breeze global theme and Breeze Dark plasma style are used
Summary: Barely readable caption text when Breeze global theme and Breeze Dark plasma ...
Status: RESOLVED FIXED
Alias: None
Product: ksysguard
Classification: Applications
Component: Plasmoid / Applet (show other bugs)
Version: 5.19.2
Platform: Neon Linux
: HI normal (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: regression
: 422448 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-07-01 15:00 UTC by Rik Mills
Modified: 2020-07-14 14:37 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.19.3


Attachments
Dark caption (76.44 KB, image/png)
2020-07-01 15:00 UTC, Rik Mills
Details
Weather widget on 5.19.3 (14.54 KB, image/png)
2020-07-08 04:58 UTC, Komorebi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rik Mills 2020-07-01 15:00:45 UTC
Created attachment 129821 [details]
Dark caption

SUMMARY

The system monitor widgets caption text is barely readable when a light Breeze UI colour scheme and dark plasma theme is used (as is default in Kubuntu)

STEPS TO REPRODUCE
1. Set Breeze colour UI theme and Breeze dark Plasma theme.
2. Add one of the many available system monitor widgets

OBSERVED RESULT

Dark main caption text.

EXPECTED RESULT

Light main caption text as would be expected in breeze dark plasma theme.


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Neon User Ed, and Kubuntu 20.10
KDE Plasma Version: 5.19.2
KDE Frameworks Version: 5.71.0
Qt Version: 5.14.2
Comment 1 Nate Graham 2020-07-01 15:05:25 UTC
This is caused by LegendDelegate in kquickcharts using a QQC2 label instead of a PC3 label. This is fine when the graph is drawn in a desktop app, or in a Plasma widget with a Plasma theme that respects the current color scheme. But when using a Plasma theme that has its own color scheme (e.g. Breeze Dark) that differs from the apps color scheme, the label is drawn with the wrong color.

The current solution for this problem is to use a PlasmaComponents Label instead of a QQC2 label. However that option doesn't seem to be available because the code that draws this label lives in the kquicksharts framework, which can't know anything about the final presentation.

Unless I'm missing something, we appear to have two options:
1. Fork kquicksharts into a Plasma version that uses PC3 items instead of QQC2 items (dear god no)
2. Come up with a solution for displaying QQC2 elements in Plasma. See https://phabricator.kde.org/T13256
Comment 2 Marco Martin 2020-07-01 15:44:53 UTC
after some investigation, this happens only on plasmoids that are created by the user, not those that are restored and created at startup
Comment 3 Marco Martin 2020-07-01 16:46:12 UTC
Git commit 1a19f67c5f3bcac0196d2315efa61704f5ab54fa by Marco Martin.
Committed on 01/07/2020 at 16:44.
Pushed by mart into branch 'Plasma/5.19'.

Theme shouldn't inherit

we are setting custom Kirigami.Theme colors, so those colors shouldn't
be automatically updated by its parent or it would break the binding

M  +1    -0    applets/systemmonitor/systemmonitor/package/contents/ui/CompactRepresentation.qml
M  +1    -0    applets/systemmonitor/systemmonitor/package/contents/ui/FullRepresentation.qml

https://invent.kde.org/plasma/plasma-workspace/commit/1a19f67c5f3bcac0196d2315efa61704f5ab54fa
Comment 4 Marco Martin 2020-07-01 16:46:13 UTC
Git commit 7474d3970fe85cfdf8c877496fcbcc26315068fd by Marco Martin.
Committed on 01/07/2020 at 16:44.
Pushed by mart into branch 'master'.

Theme shouldn't inherit

we are setting custom Kirigami.Theme colors, so those colors shouldn't
be automatically updated by its parent or it would break the binding

M  +1    -0    applets/systemmonitor/systemmonitor/package/contents/ui/CompactRepresentation.qml
M  +1    -0    applets/systemmonitor/systemmonitor/package/contents/ui/FullRepresentation.qml

https://invent.kde.org/plasma/plasma-workspace/commit/7474d3970fe85cfdf8c877496fcbcc26315068fd
Comment 5 Komorebi 2020-07-08 04:58:05 UTC
Created attachment 129967 [details]
Weather widget on 5.19.3
Comment 6 Komorebi 2020-07-08 04:59:12 UTC
Well, I'm not 5.19.3 and the issue is still here. Weather and notifications widgets are affected.
Comment 7 Komorebi 2020-07-08 04:59:50 UTC
*I'm on.
Comment 8 Nate Graham 2020-07-08 13:45:21 UTC
That's a separate issue. Please file a new bug report for it. Thanks!
Comment 9 Komorebi 2020-07-08 14:24:22 UTC
I don't feel like there's a reason to create multiple bug reports since most of widgets (at least weather, bluetooth, clipboard and notifications) are affected and the issue must be the same for all of them.
Comment 10 Nate Graham 2020-07-08 14:28:03 UTC
It's not, they are all caused by different things. I'm the one who introduced some of these issues accidentally and then later fixed them (sorry), so I know what I'm talking about here. :)

The issues with the Bluetooth, Clipboard, and Notifications applets have already been fixed for Plasma 5.20, see Bug 422684. I have advides distros on how to backport the fix; if you're still seeing the problem, you should bug your distro to follow my advice and backport the fix for you. And sorry again for causing this problem!

The issue with the dark text in the weather widget would be caused by something entirely different, likely in the tab bar component of the PlasmaComponents library.

So please file a separate bug for the tab bar issue with your weather widget.
Comment 11 Komorebi 2020-07-08 14:31:03 UTC
Ok, thank you, will file a bug for weather and wait for 5.20 (I use neon).
Comment 12 Nate Graham 2020-07-08 14:31:57 UTC
Thanks!
Comment 13 Patrick Silva 2020-07-14 14:37:49 UTC
*** Bug 422448 has been marked as a duplicate of this bug. ***