Bug 423421 - Plasmashell occasionally 'forgets' to load widgets and wallpaper
Summary: Plasmashell occasionally 'forgets' to load widgets and wallpaper
Status: RESOLVED DUPLICATE of bug 427861
Alias: None
Product: plasmashell
Classification: Plasma
Component: Desktop Containment (show other bugs)
Version: 5.18.5
Platform: Ubuntu Linux
: VHI normal
Target Milestone: 1.0
Assignee: Marco Martin
Depends on:
Reported: 2020-06-24 07:41 UTC by Thomas Weissel
Modified: 2021-01-08 21:18 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:

both states side by side (2.36 MB, image/png)
2020-06-24 07:41 UTC, Thomas Weissel
3 identical virtual machines boot the same iso (1.42 MB, application/octet-stream)
2020-06-24 07:43 UTC, Thomas Weissel
xsession-errors from a failed plasma start (25.59 KB, text/plain)
2020-10-04 20:23 UTC, Thomas Weissel
activity switcher (1.73 MB, image/png)
2020-10-19 09:41 UTC, Thomas Weissel
xsession-errors for 3 display setup (16.48 KB, text/plain)
2020-10-31 09:38 UTC, Arek Guzinski

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Weissel 2020-06-24 07:41:33 UTC
Created attachment 129625 [details]
both states side by side

Plasmashell occasionally forgets to load widgets (folderview and application launchers) and displays the default desktop wallpaper. opposed to what can be found in the configuration file "plasma-org.kde.plasma.desktop-appletsrc"

this should be reproducable with the following image (basically kubuntu 20.04 with extra applications)

no need to copy this on a flashdrive - it's also reproducable in virtualbox

1. new virtual machine (ubuntu 64, no disk) - add iso as live cd (i made 3 vms in order to test faster)
2. start virtual machine
3. observe


PARTS of the "plasma-org.kde.plasma.desktop-appletsrc" are ignored (they stay in the configfile but they are ignored)
desktop starts with default desktop wallpaper - without widgets in the containment
plasma panel has the correct configuration as defined in the config and widgets in the plasma panel also work as expected

load configured desktop with all widgets and launchers


Linux/KDE Plasma: 

KDE Plasma Version: 5.18.5
KDE Frameworks Version: 5.68.0
Qt Version: 5.12.8


it is absolutely not reproducable.. first it happend when booting macs with the live usb flashdrive without acpi
it made no sense 

then i tried in virtualbox and played with the settings.. nothing came up.. it happens absolutely RANDOM
i have 3 identical virtual machines.. if i start them one after the other.. at least one of them will display only half of the configuration correctly

i already deleted the configuration files und started from scratch with a fresh config.. same thing happend so it shouldn't be a bug in the config
Comment 1 Thomas Weissel 2020-06-24 07:43:53 UTC
Created attachment 129626 [details]
3 identical virtual machines boot the same iso
Comment 2 Thomas Weissel 2020-06-24 08:13:49 UTC
i have to add information about the configuration:

[Containments][2] stays exactly the same.. (the panel)
[Containments][7] stays exactly the same.. (systemtray)

[Containment][22]  org.kde.desktopcontainment 
(which holds all of the widgets and the desktop wallpaper)

is replaced by

[Containment][49] org.kde.folder 
(wallpaper only)

The activityId also stays the same..

so the question is.. what in the world makes plasma think it can switch from desktop containment to folderview RANDOMLY ???

it is also resultion independend.. it happens on vga, svga, hd, fullhd
Comment 3 Thomas Weissel 2020-10-04 20:23:29 UTC
Created attachment 132120 [details]
xsession-errors from a failed plasma start

org.kde.plasma: requesting config for "Arbeitsfläche" without a containment!

this is one thing that seems to be related :-)
Comment 4 Thomas Weissel 2020-10-04 20:26:44 UTC
this bug seems to be related
Comment 5 Thomas Weissel 2020-10-04 20:29:13 UTC
this bug is related to

thx to the live image i created you can replay this as often as you want (just reset the virtualbox vm as long as neccesary to reproduce the behaviour - then analyze ;-)
Comment 6 Thomas Weissel 2020-10-19 09:41:46 UTC
Created attachment 132552 [details]
activity switcher

on the left side there is no activity visible even if the "default" activity is still there in the activity settings dialog
Comment 7 Thomas Weissel 2020-10-19 09:42:34 UTC
so i tried to clean up everything kscreen related.. it didn't help.

i just figured out that the problem is most likely related to "ACTIVITIES"

when i hit "meta+tab" in a working VM the "activity bar" shows up on the left side of the screen.

in the faulty VW nothing happens.
the "activity bar" shows up when i use the desktop context menu and for some reason it is empty


the "default" activity is still visible in the activity settings but it seems to be unused
Comment 8 Nate Graham 2020-10-30 14:39:11 UTC
*** Bug 428463 has been marked as a duplicate of this bug. ***
Comment 9 Arek Guzinski 2020-10-31 09:37:32 UTC
Same thing happens to me on current KDE Neon with Plasma 5.20.1 (and a few versions before).

Things that might be useful to know:
it's a 3 display setup and when it happens, it's per screen - meaning it usually affects one or two of them.
activity switcher shows only "New Activity" on all screens - "Desktop" (the other configured one) is not shown.

I'll attach my xsession-errors, too.
Comment 10 Arek Guzinski 2020-10-31 09:38:52 UTC
Created attachment 132905 [details]
xsession-errors for 3 display setup
Comment 11 krzmbrzl 2020-11-11 16:12:03 UTC
I have the same issue on KDE Neon 5.20

I have a dual monitor setup and it is always the right one (the secondary monitor) that looses its wallpaper that looses it every so often after booting up my computer.

I don't have anything else on the Desktop of the 2nd screen so I can't tell whether it would mess with that as well.

Note also that I have the same wallpaper on my left screen as I have on the right one, so it can't be related to Plasma not finding the image (yet).
Comment 12 Nate Graham 2021-01-08 21:18:26 UTC

*** This bug has been marked as a duplicate of bug 427861 ***