Bug 423055 - Not all Plasma widgets installed via GHNS window are listed in Widget Explorer when its "Uninstallable" filter is selected
Summary: Not all Plasma widgets installed via GHNS window are listed in Widget Explore...
Status: RESOLVED FIXED
Alias: None
Product: frameworks-knewstuff
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 5.71.0
Platform: Archlinux Linux
: NOR normal
Target Milestone: ---
Assignee: Jeremy Whiting
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-16 13:11 UTC by Patrick Silva
Modified: 2020-09-01 08:10 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.20


Attachments
screenshot (250.02 KB, image/png)
2020-06-16 13:11 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2020-06-16 13:11:29 UTC
Created attachment 129413 [details]
screenshot

SUMMARY
See the attached screenshot please.
I have several Plasma widgets from KDE Store installed on my system, but the Widget Explorer only lists 2 of them when its "Uninstallable" filter is selected.
When I want to uninstall any Plasma widget not listed in the Widget Explorer, I need to open "Download new plasma widgets" window and select "Installed" radio button. 

STEPS TO REPRODUCE
1. install some Plasma widgets from KDE Store
2. open the Widget Explorer and select "Uninstallable" filter on top
3. 

EXPECTED RESULT
Widget Explorer should list all widgets installed from KDE Sore when its "Uninstallable" filter is selected.

SOFTWARE/OS VERSIONS
Operating System: Arch Linux 
KDE Plasma Version: 5.19.0
KDE Frameworks Version: 5.71.0
Qt Version: 5.15.0
Comment 1 Martin 2020-06-30 17:28:03 UTC
Confirmed.
Comment 2 Alexander Lohnau 2020-08-30 21:22:48 UTC
It works for me. Can you please try if you can remove these addons from within the KNS dialog? It might be possible that they are "orphaned" entries in the KNS config file (~/.local/share/knewstuff3/plasmoids.knsregistry).
Comment 3 Patrick Silva 2020-08-30 22:19:53 UTC
I have uninstalled all widgets via Widgets Explorer, they are no longer present in the Widget Explorer but they are still marked as installed in GHNS window
and when I click on their "Uninstall" buttons they bizarrely change to "Installing" and get stuck in such state. Then I installed all the widgets shown in my screenshot and now they are all listed when "Uninstallable" filter of the Widget Explorer is selected.

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.19.80
KDE Frameworks Version: 5.74.0
Qt Version: 5.14.2
Comment 4 Alexander Lohnau 2020-08-31 06:55:43 UTC
> I click on their "Uninstall" buttons they bizarrely change to "Installing" and get stuck in such state.
Is it possible that you have removed those entries using the "Delete" icon? There might also be a problem with the KNS kpackage support, should be an easy fix :)
Comment 5 Alexander Lohnau 2020-08-31 07:32:17 UTC
Git commit 5a27c8faad7ad10c99805e6ff6c9d013dad2cf9a by Alexander Lohnau.
Committed on 31/08/2020 at 07:31.
Pushed by alex into branch 'master'.

Fix edge case where KNS gets stuck

M  +6    -0    src/core/installation.cpp

https://invent.kde.org/frameworks/knewstuff/commit/5a27c8faad7ad10c99805e6ff6c9d013dad2cf9a
Comment 6 Bug Janitor Service 2020-08-31 07:40:53 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/236
Comment 7 Alexander Lohnau 2020-09-01 08:10:09 UTC
Git commit ce920603ea93ae4abf391d477001bb67cd429ed1 by Alexander Lohnau.
Committed on 01/09/2020 at 08:09.
Pushed by alex into branch 'master'.

Fix undetected KPackage installation

This was the last occurrence that didn't get ported/detected.
Because of that the updating did not work and uninstalling
an entry using the "Widget Explorer" did not work.
Related: bug 424429
FIXED-IN: 5.20

M  +2    -2    components/shellprivate/widgetexplorer/plasmoids.knsrc

https://invent.kde.org/plasma/plasma-workspace/commit/ce920603ea93ae4abf391d477001bb67cd429ed1