Bug 422972 - khelpcenter crashes on Wayland
Summary: khelpcenter crashes on Wayland
Status: RESOLVED FIXED
Alias: None
Product: khelpcenter
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Documentation Editorial Team
URL:
Keywords: drkonqi
: 416769 419685 425690 426203 437923 445378 447095 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-06-14 14:30 UTC by Patrick Silva
Modified: 2022-01-11 15:35 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.91


Attachments
New crash information added by DrKonqi (3.19 KB, text/plain)
2021-10-23 04:31 UTC, fyrefiend
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2020-06-14 14:30:13 UTC
Application: khelpcenter (5.7.6.20042)

Qt Version: 5.15.0
Frameworks Version: 5.71.0
Operating System: Linux 5.6.15-arch1-1 x86_64
Windowing system: Wayland
Distribution: Arch Linux

-- Information about the crash:
- What I was doing when the application crashed:
I can't reproduce this crash consistently, it occurs sometimes.
open klipper settings
cliick on "Actions" section in the left side
click on "Help" button on bottom

The crash can be reproduced sometimes.

-- Backtrace:
Application: Help Center (khelpcenter), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f387e9eb022 in XChangeWindowAttributes () from /usr/lib/libX11.so.6
#5  0x00007f3880db1c42 in KHTMLView::mouseMoveEvent(QMouseEvent*) () from /usr/lib/libKF5KHtml.so.5
#6  0x00007f387fe19c6e in QWidget::event (this=this@entry=0x556696f0e5c0, event=event@entry=0x7ffe637b7aa0) at kernel/qwidget.cpp:9027
#7  0x00007f387fec4f8f in QFrame::event (this=0x556696f0e5c0, e=0x7ffe637b7aa0) at widgets/qframe.cpp:550
#8  0x00007f3880dadca0 in KHTMLView::eventFilter(QObject*, QEvent*) () from /usr/lib/libKF5KHtml.so.5
#9  0x00007f387f1e6403 in QCoreApplicationPrivate::sendThroughObjectEventFilters (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.cpp:1187
#10 QCoreApplicationPrivate::sendThroughObjectEventFilters (receiver=receiver@entry=0x556697144a10, event=event@entry=0x7ffe637b7aa0) at kernel/qcoreapplication.cpp:1176
#11 0x00007f387fdd86e1 in QApplicationPrivate::notify_helper (this=this@entry=0x556696dfbbe0, receiver=receiver@entry=0x556697144a10, e=e@entry=0x7ffe637b7aa0) at kernel/qapplication.cpp:3665
#12 0x00007f387fddf967 in QApplication::notify (this=0x7ffe637b77a0, receiver=0x556697144a10, e=0x7ffe637b7aa0) at kernel/qapplication.cpp:3115
#13 0x00007f387f1e669a in QCoreApplication::notifyInternal2 (receiver=0x556697144a10, event=0x7ffe637b7aa0) at ../../include/QtCore/5.15.0/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:325
#14 0x00007f387fdde84e in QApplicationPrivate::sendMouseEvent (receiver=receiver@entry=0x556697144a10, event=event@entry=0x7ffe637b7aa0, alienWidget=alienWidget@entry=0x556697144a10, nativeWidget=0x556696ea4ca0, buttonDown=buttonDown@entry=0x7f3880311350 <qt_button_down>, lastMouseReceiver=..., spontaneous=true, onlyDispatchEnterLeave=false) at kernel/qapplication.cpp:2603
#15 0x00007f387fe323a2 in QWidgetWindow::handleMouseEvent (this=0x5566974ac6b0, event=0x7ffe637b7d60) at /usr/include/c++/10.1.0/bits/atomic_base.h:420
#16 0x00007f387fe3577f in QWidgetWindow::event (this=0x5566974ac6b0, event=0x7ffe637b7d60) at kernel/qwidgetwindow.cpp:295
#17 0x00007f387fdd86f2 in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x5566974ac6b0, e=0x7ffe637b7d60) at kernel/qapplication.cpp:3671
#18 0x00007f387f1e669a in QCoreApplication::notifyInternal2 (receiver=0x5566974ac6b0, event=0x7ffe637b7d60) at ../../include/QtCore/5.15.0/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:325
#19 0x00007f387f6dff1c in QGuiApplicationPrivate::processMouseEvent (e=0x556697841650) at kernel/qguiapplication.cpp:2214
#20 0x00007f387f6b56ec in QWindowSystemInterface::sendWindowSystemEvents (flags=...) at kernel/qwindowsysteminterface.cpp:1175
#21 0x00007f387a6e5081 in userEventSourceDispatch (source=<optimized out>) at qeventdispatcher_glib.cpp:74
#22 0x00007f387b7d143c in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0x00007f387b81efa9 in ?? () from /usr/lib/libglib-2.0.so.0
#24 0x00007f387b7d0221 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0x00007f387f23f211 in QEventDispatcherGlib::processEvents (this=0x556696e76d90, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#26 0x00007f387f1e501c in QEventLoop::exec (this=this@entry=0x7ffe637b8090, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#27 0x00007f387f1ed4a4 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#28 0x00007f387f6d338e in QGuiApplication::exec () at kernel/qguiapplication.cpp:1867
#29 0x00007f387fdd8666 in QApplication::exec () at kernel/qapplication.cpp:2811
#30 0x00007f3881582df7 in kdemain (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/khelpcenter-20.04.2/application.cpp:124
#31 0x00007f38813a1002 in __libc_start_main () from /usr/lib/libc.so.6
#32 0x000055669639605e in _start ()
[Inferior 1 (process 52331) detached]

Possible duplicates by query: bug 419798, bug 419685, bug 418660, bug 418351, bug 416769.

Reported using DrKonqi
Comment 1 Yuri Chornoivan 2020-09-05 06:28:07 UTC
*** Bug 426203 has been marked as a duplicate of this bug. ***
Comment 2 Sönke Holz 2021-09-18 11:35:42 UTC
I get the same bug when clicking the "Help" button in the firewall settings. The backtrace seems to be the same for me. Every time I hover over the translator's or the author's email address, khelpcenter crashes. If I select another page and then select the firewall page again, the bug no longer occurs.
Comment 3 fyrefiend 2021-10-23 04:31:34 UTC
Created attachment 142777 [details]
New crash information added by DrKonqi

khelpcenter (5.7.6.21082) using Qt 5.15.2

- What I was doing when the application crashed:
Opened Help Center from Konqueror and it crashed. When I relaunch it works about half the time

-- Backtrace (Reduced):
#4  0x00007f2eb888d154 in _XGetRequest () from /usr/lib/libX11.so.6
#5  0x00007f2eb8866f17 in XChangeWindowAttributes () from /usr/lib/libX11.so.6
#6  0x00007f2ebafb29e7 in KHTMLView::mouseMoveEvent(QMouseEvent*) () from /usr/lib/libKF5KHtml.so.5
#7  0x00007f2eb9ec50be in QWidget::event(QEvent*) () from /usr/lib/libQt5Widgets.so.5
#8  0x00007f2eb9f7485f in QFrame::event(QEvent*) () from /usr/lib/libQt5Widgets.so.5
Comment 4 Albert Astals Cid 2021-12-17 22:19:00 UTC
*** Bug 447095 has been marked as a duplicate of this bug. ***
Comment 5 Christoph Cullmann 2022-01-08 16:11:22 UTC
https://bugs.kde.org/show_bug.cgi?id=422972

If you have time you could try that patch.
Comment 6 Christoph Cullmann 2022-01-08 16:12:08 UTC
*** Bug 419685 has been marked as a duplicate of this bug. ***
Comment 7 Christoph Cullmann 2022-01-08 16:12:39 UTC
*** Bug 416769 has been marked as a duplicate of this bug. ***
Comment 8 Christoph Cullmann 2022-01-08 16:13:25 UTC
*** Bug 445378 has been marked as a duplicate of this bug. ***
Comment 9 Christoph Cullmann 2022-01-08 16:13:53 UTC
*** Bug 437923 has been marked as a duplicate of this bug. ***
Comment 10 Christoph Cullmann 2022-01-08 16:15:32 UTC
*** Bug 425690 has been marked as a duplicate of this bug. ***
Comment 11 Lyubomir 2022-01-08 16:37:14 UTC
(In reply to Christoph Cullmann from comment #5)
> https://bugs.kde.org/show_bug.cgi?id=422972
> 
> If you have time you could try that patch.

Hmm, this links to the current bug??
Comment 12 Christoph Cullmann 2022-01-08 16:40:51 UTC
Sorry, this is the fix ;=)

https://invent.kde.org/frameworks/khtml/-/merge_requests/4
Comment 13 Patrick Silva 2022-01-08 17:19:45 UTC
Unfortunately build dependencies are not available on neon unstable.

$ sudo apt build-dep khtml
...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 builddeps:essentials : Depends: build-essential but it is not going to be installed
 builddeps:khtml : Depends: debhelper (>= 11~) but it is not going to be installed
                   Depends: libjpeg-dev
                   Depends: libkf5archive-dev (>= 5.51.0~) but it is not going to be installed
                   Depends: libkf5codecs-dev (>= 5.51.0~) but it is not going to be installed
                   Depends: libkf5globalaccel-dev (>= 5.51.0~) but it is not going to be installed
                   Depends: libkf5i18n-dev (>= 5.51.0~) but it is not going to be installed
                   Depends: libkf5iconthemes-dev (>= 5.51.0~) but it is not going to be installed
                   Depends: libkf5kio-dev (>= 5.51.0~) but it is not going to be installed
                   Depends: libkf5kjs-dev (>= 5.51.0~) but it is not going to be installed
                   Depends: libkf5notifications-dev (>= 5.51.0~) but it is not going to be installed
                   Depends: libkf5parts-dev (>= 5.51.0~) but it is not going to be installed
                   Depends: libkf5sonnet-dev (>= 5.51.0~) but it is not going to be installed
                   Depends: libkf5textwidgets-dev (>= 5.51.0~) but it is not going to be installed
                   Depends: libkf5wallet-dev (>= 5.51.0~) but it is not going to be installed
                   Depends: libkf5widgetsaddons-dev (>= 5.51.0~) but it is not going to be installed
                   Depends: libkf5windowsystem-dev (>= 5.51.0~) but it is not going to be installed
                   Depends: libkf5xmlgui-dev (>= 5.51.0~) but it is not going to be installed
                   Depends: libphonon4qt5-dev (>= 4:4.6.0) but it is not going to be installed
                   Depends: libpng-dev but it is not going to be installed
                   Depends: libqt5x11extras5-dev (>= 5.8.0~) but it is not going to be installed
                   Depends: qtbase5-dev (>= 5.8.0~) but it is not going to be installed
                   Depends: zlib1g-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Comment 14 Nate Graham 2022-01-11 15:35:01 UTC
Fixed by Christoph Cullmann with https://invent.kde.org/frameworks/khtml/-/commit/04aa1739d06d3ff7d16a3296fd27fa392d8ba318 in Frameworks 5.91!