Bug 422965 - Close button of overlaySheet has pixelated icon
Summary: Close button of overlaySheet has pixelated icon
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kirigami
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 5.71.0
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: Not decided
Assignee: Marco Martin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-14 12:18 UTC by Patrick Silva
Modified: 2020-07-16 20:17 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.72


Attachments
screenshot (220.94 KB, image/png)
2020-06-14 12:18 UTC, Patrick Silva
Details
GHNS window on X11 (33.86 KB, image/png)
2020-06-16 12:01 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2020-06-14 12:18:07 UTC
Created attachment 129343 [details]
screenshot

SUMMARY
See the attached screenshot please.

EXPECTED RESULT
crisp icon

SOFTWARE/OS VERSIONS
Operating System: Arch Linux 
KDE Plasma Version: 5.19.0
KDE Frameworks Version: 5.71.0
Qt Version: 5.15.0
Comment 1 Nate Graham 2020-06-14 20:15:39 UTC
Are you using any kind of scaling?
Comment 2 Patrick Silva 2020-06-15 18:36:45 UTC
(In reply to Nate Graham from comment #1)
> Are you using any kind of scaling?

No, display scale 100%.
Weirdly I can't reproduce anymore.
If you also can not, feel free to close this bug.
Comment 3 Nate Graham 2020-06-15 18:45:57 UTC
Here's something to test: if you resize the window while the sheet is open, does the button become pixellated and then fix itself and then become pixellated again?
Comment 4 Patrick Silva 2020-06-15 19:17:11 UTC
(In reply to Nate Graham from comment #3)
> Here's something to test: if you resize the window while the sheet is open,
> does the button become pixellated and then fix itself and then become
> pixellated again?

I can't reproduce with your steps, but I have already found the exact ones.
This bug only occurs on Wayland when Discover opens not-maximized.

open Discover on Wayland
if it opens maximized, resize the window by dragging any border and restart Discover
now try to reproduce

The same steps on X11 results in a non-pixelated but weird icon.
"X" looks a bit distorted.
Comment 5 Nate Graham 2020-06-15 19:34:37 UTC
Cool.
Comment 6 Patrick Silva 2020-06-16 12:01:10 UTC
Created attachment 129411 [details]
GHNS window on X11
Comment 7 Bug Janitor Service 2020-06-29 16:06:51 UTC
A possibly relevant merge request was started @ https://invent.kde.org/frameworks/kirigami/-/merge_requests/41
Comment 8 Nicolas Fella 2020-06-30 11:49:18 UTC
Git commit fd6e61386fef38dcf3d4dea58ba8d86c6eb971c9 by Nicolas Fella.
Committed on 30/06/2020 at 11:49.
Pushed by nicolasfella into branch 'master'.

[overlaysheet] Avoid fractional height for contentLayout

Earlier in the calculation we are dividing several things by two, which may lead to non-integer results. Setting a non-integer size for contentLayout leads to broken text and icon rendering for child elements.

M  +2    -2    src/controls/templates/OverlaySheet.qml

https://invent.kde.org/frameworks/kirigami/commit/fd6e61386fef38dcf3d4dea58ba8d86c6eb971c9
Comment 9 Nate Graham 2020-07-16 20:17:23 UTC
*** Bug 418033 has been marked as a duplicate of this bug. ***