Bug 422329 - kglobalaccel has issue with modifiers when using options for keyboard layout
Summary: kglobalaccel has issue with modifiers when using options for keyboard layout
Status: RESOLVED DUPLICATE of bug 375518
Alias: None
Product: frameworks-kglobalaccel
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 5.70.0
Platform: OpenSUSE Linux
: NOR normal
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-01 13:10 UTC by Pierre
Modified: 2021-03-26 16:13 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre 2020-06-01 13:10:09 UTC
SUMMARY


STEPS TO REPRODUCE
1. In Settings>Input>Keyboard, choose layout "de(deadgraveacute)" and activate the option "altwin(swap_lalt_lwin)"
2. Exit session or reboot computer
3. Log in

OBSERVED RESULT
The global shortcuts do not work (Meta+... for example) with the new position of the modifiers.

EXPECTED RESULT
The shorcuts should work with the new position of the modifiers.


SOFTWARE/OS VERSIONS
OS: openSUSE Tumbleweed 20200528
KDE Plasma : 5.18.5 (using X11)
KDE Frameworks: 5.70.0
Qt: 5.14.1
Kernel: 5.6.14-1-default


ADDITIONAL INFORMATION
Running "killall kglobalaccel5 && (kglobalaccel5 &)" make the shortcuts work again.
My interpretation is that kglobalaccel5 initialize its modifiers and keys to grab with the general computer's XKB settings, not the ones of the current Plasma session. It may be a race condition with the application of these settings and kglobalaccel.

The solution cannot be to change the computer-wide XKB settings because we are several persons using this computer, each with different layout options.
Comment 1 Pierre 2020-06-01 13:37:00 UTC
setxkbmap -print

xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwertz)" };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+de(sundeadkeys)+inet(evdev)+terminate(ctrl_alt_bksp)+terminate(ctrl_alt_bksp)"      };
        xkb_geometry  { include "pc(pc105)"     };
};
Comment 2 Nate Graham 2021-03-26 16:12:51 UTC

*** This bug has been marked as a duplicate of bug 350816 ***
Comment 3 Nate Graham 2021-03-26 16:13:17 UTC

*** This bug has been marked as a duplicate of bug 375518 ***