Bug 421691 - New Account Wizard is not asking if the user wants to add a new payee
Summary: New Account Wizard is not asking if the user wants to add a new payee
Status: RESOLVED FIXED
Alias: None
Product: kmymoney
Classification: Unclassified
Component: general (show other bugs)
Version: git (master)
Platform: Manjaro Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-17 20:25 UTC by Robert Szczesiak
Modified: 2020-06-05 04:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.1.0


Attachments
Expected result when focusing out of the Payee text box (90.95 KB, image/png)
2020-05-17 20:25 UTC, Robert Szczesiak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Szczesiak 2020-05-17 20:25:27 UTC
Created attachment 128554 [details]
Expected result when focusing out of the Payee text box

SUMMARY
When the user enters a new payee name in the New Account Wizard and then changes focus to another form field by clicking the mouse, the user is not asked if he or she wants to add the new payee. The pop-up question window appears correctly if focus is changed by keyboard (e.g. by pressing the Tab key).

STEPS TO REPRODUCE
1. Go to the Accounts view and click the "New Account..." button.
2. Follow the instructions in the Wizard. From the Account type drop-down list select "Credit Card".
3. On the Schedule page enter a new payee name.
4. Click your left mouse button to change focus to another form field.

OBSERVED RESULT
The new payee name is kept in the Payee text box but the user is not asked about adding the new payee. The Next button remains disabled even if all the required fields are filled.

EXPECTED RESULT
"New payee/receiver" pop-up window should appear exactly like it does when the Tab key is pressed after providing a new payee name. After adding the new payee and filling all the required fields on the form, the Next button should be enabled.

SOFTWARE/OS VERSIONS
KDE Plasma Version: 5.18.4
KDE Frameworks Version: 5.69.0
Qt Version: 5.14.2

ADDITIONAL INFORMATION
Please find attached a screenshot presenting expected result.
Comment 1 Robert Szczesiak 2020-05-18 18:38:20 UTC
Git commit 6e1746e3d6ea238b435490881c6241c2a5bcfe18 by Robert Szczesiak.
Committed on 17/05/2020 at 20:28.
Pushed by tbaumgart into branch 'master'.

Fix new account wizard not asking if the user wants to add a new payee

When the user entered a new payee name in the New Account Wizard and
then changed focus to another form field by clicking the mouse, the user
was not asked if he or she wanted to add the new payee. The pop-up
question window appeared correctly if focus was changed by keyboard
(e.g. by pressing the Tab key).

This commit fixes the issue so that the user is asked about adding the
new payee when focus is lost due to a mouse click event.

M  +8    -6    kmymoney/widgets/kmymoneymvccombo.cpp

https://invent.kde.org/office/kmymoney/commit/6e1746e3d6ea238b435490881c6241c2a5bcfe18
Comment 2 Thomas Baumgart 2020-05-18 18:41:28 UTC
Git commit 509ab4e82ceea3da029c64de64fa7147781953a5 by Thomas Baumgart.
Committed on 18/05/2020 at 18:41.
Pushed by tbaumgart into branch '5.0'.

Fix new account wizard not asking if the user wants to add a new payee

When the user entered a new payee name in the New Account Wizard and
then changed focus to another form field by clicking the mouse, the user
was not asked if he or she wanted to add the new payee. The pop-up
question window appeared correctly if focus was changed by keyboard
(e.g. by pressing the Tab key).

This commit fixes the issue so that the user is asked about adding the
new payee when focus is lost due to a mouse click event.
FIXED-IN: 5.0.9

(cherry picked from commit 6e1746e3d6ea238b435490881c6241c2a5bcfe18)

M  +8    -6    kmymoney/widgets/kmymoneymvccombo.cpp

https://invent.kde.org/office/kmymoney/commit/509ab4e82ceea3da029c64de64fa7147781953a5