Bug 421522 - Elisa preventing Plasma from properly locking screen after passed time out
Summary: Elisa preventing Plasma from properly locking screen after passed time out
Status: RESOLVED DUPLICATE of bug 418433
Alias: None
Product: Elisa
Classification: Applications
Component: general (show other bugs)
Version: 20.04.0
Platform: openSUSE Linux
: NOR normal
Target Milestone: ---
Assignee: Matthieu Gallien
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-14 17:12 UTC by tneo
Modified: 2020-12-26 07:11 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tneo 2020-05-14 17:12:31 UTC
SUMMARY
Screen locking is not working when Elisa is actively playing songs. 

STEPS TO REPRODUCE
1. Start Elisa, play tunes
2. Wait for lock screen to become active
3. Activate screen

OBSERVED RESULT
When the screen locker is supposed to be active and the screen turns black. Upon reviving the screen there is no need to log into Plasma as opposed what is normal.

EXPECTED RESULT
User log-in prompt to activate desktop

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: openSUSE Tumbleweed 20200504
KDE Plasma Version: 5.18.4
KDE Frameworks Version: 5.69.0
Qt Version: 5.14.1

ADDITIONAL INFORMATION
Comment 1 Matthieu Gallien 2020-05-14 19:38:23 UTC
I can confirm that.
Comment 2 Matthieu Gallien 2020-05-14 21:18:28 UTC
https://invent.kde.org/kde/elisa/-/merge_requests/124 has a possible fix under review for this issue.

Can you test it ?
Comment 3 tneo 2020-05-15 03:34:26 UTC
I can test once it is available through openSUSE repo's. However based upon your description for the fix, I wonder it will fix this issue.
Comment 4 Matthieu Gallien 2020-05-15 10:11:36 UTC
(In reply to tneo from comment #3)
> I can test once it is available through openSUSE repo's. However based upon
> your description for the fix, I wonder it will fix this issue.

I was completely confused when looking at your report. You are true. Sorry for that.
Comment 5 Matthieu Gallien 2020-05-15 10:18:26 UTC
This is probably related to bug 418433.

I genuinely ignore if the application is responsible for that or the workspace.

I will have to dig that.

If somebody can beat me at that, it would be nice because the code modification is probably minimal but finding what to do is the complex part here.

You can add to that the needed support for other workspace than KDE Plasma (currently we support Windows, GNOME 3 and Plasma 5).
Comment 6 Nate Graham 2020-11-11 03:08:15 UTC
Yep, same issue.

*** This bug has been marked as a duplicate of bug 418433 ***
Comment 7 ace66130 2020-12-26 07:11:03 UTC
Under Manjaro plasma, Elisa always prevents the computer from going to sleep.