Bug 421443 - KOrganizer does not sync reliably with Zoho Calendars via CalDAV - pulls wrong remote CalDAV calendar URL
Summary: KOrganizer does not sync reliably with Zoho Calendars via CalDAV - pulls wron...
Status: RESOLVED DUPLICATE of bug 435232
Alias: None
Product: korganizer
Classification: Unclassified
Component: groupware (show other bugs)
Version: 5.13.3
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-13 02:32 UTC by JJ Emilien
Modified: 2021-11-03 11:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
partial screenshot of CalDAV remote URLs (59.58 KB, image/png)
2020-05-13 02:32 UTC, JJ Emilien
Details
screenshot of CalDAV remote URLs (57.23 KB, image/png)
2020-05-14 13:30 UTC, JJ Emilien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JJ Emilien 2020-05-13 02:32:16 UTC
Created attachment 128409 [details]
partial screenshot of CalDAV remote URLs

SUMMARY
KOrganizer does not pull events inbound from Zoho Calendars. It can only sync one event outbound to the Zoho Calendar. After successfully syncing that event to Zoho Calendar, akonadiconsole reports that the event is "dirty" and KOrganizer stops syncing any more events outbound to Zoho calendar.

STEPS TO REPRODUCE
1. Create a free email account at mail.zoho.com
2. With email account credentials, go to Zoho Calendar at https://calendar.zoho.com/mycalendar and create an event 
3. Subscribe to the US Holidays calendar on the Zoho Calendar website
4. Create a free account at trip planner website Tripit.com
5. Obtain the link for the Tripit calendar on Tripit.com
6. On the Zoho Calendar website, subscribe to the Tripit calendar
7. In mail.zoho.com settings, create app specific password for KOrganizer

OBSERVED RESULT
In KOrganizer, when adding the CalDAV configuration server URL https://calendar.zoho.com, KOrganizer will correctly fetch the Zoho calendar collection consisting of the zoho calendar (write + read),the US Holidays calendar (read only), and the Tripit calendar (read only).

The calDAV remote calendar URLs take the form https://calendar.zoho.com/caldav/calendarID/event

The Zoho calendar has the correct CalDAV remote URL

The US Holidays remote CalDAV URL is wrong. The calendarID for US Holidays is wrongly stringed together sequentially with the calendarID for Zoho calendar.

The Tripit remote CalDAV URL is wrong. The calendarID for Tripit is wrongly stringed together sequentially with the calendarID for Zoho calendar.

(See attachment for a partial screenshot of the remote CalDAV URLs)

The event created on the Zoho calendar website will not sync inbound to the KOrganizer calendar

The events from US Holidays calendar and Tripit calendar don't sync inbound to the KOrganizer calendar

One event added to the Zoho calendar in KOrganizer will sync outbound to the Zoho calendar website. But no more events will sync outbound to the Zoho calendar afterwards, as akonadiconsole reports that event created in KOrganizer as being "dirty"

EXPECTED RESULT
When adding the CalDAV configuration server URL https://calendar.zoho.com, it should fetch the entire calendar collection with the correct CalDAV remote URLs.
What's worse is there's no way to edit the wrong remote URLs.
In akonadiconsole, Browser tab, Calendar folder properties, Internals tab, the remote URL is there, but it says in red letters: "Do not even think about changing anything in here!"

Events from Zoho calendar in KOrganizer should sync both ways with the Zoho calendar website.
Events from US Holidays calendar should sync inbound in read-only with KOrganizer
Events from Tripit calendar should sync inbound in read-only with KOrganizer


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Kubuntu 20.04
(available in About System)
KDE Plasma Version: 5.18.4
KDE Frameworks Version: 5.68.0
Qt Version: 5.12.8

ADDITIONAL INFORMATION
Comment 1 JJ Emilien 2020-05-14 13:30:27 UTC
Created attachment 128451 [details]
screenshot of CalDAV remote URLs
Comment 2 Carl Schwan 2021-11-03 11:28:31 UTC

*** This bug has been marked as a duplicate of bug 435232 ***