Bug 421316 - Crash in ContainmentInterface::addContainmentActions() when right-clicking on desktop
Summary: Crash in ContainmentInterface::addContainmentActions() when right-clicking on...
Status: CLOSED DUPLICATE of bug 446195
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Desktop Containment (show other bugs)
Version: 5.17.5
Platform: Fedora RPMs Linux
: HI crash
Target Milestone: 1.0
Assignee: Marco Martin
URL:
Keywords: drkonqi
: 416702 417132 419922 426216 428082 431375 432737 434313 435261 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-05-11 07:12 UTC by mrjptux
Modified: 2022-03-22 14:00 UTC (History)
14 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mrjptux 2020-05-11 07:12:43 UTC
Application: plasmashell (5.17.5)

Qt Version: 5.13.2
Frameworks Version: 5.68.0
Operating System: Linux 5.6.8-200.fc31.x86_64 x86_64
Distribution: "Fedora release 31 (Thirty One)"

-- Information about the crash:
- What I was doing when the application crashed:
in wallpapers settings changed from sliding to one wallpaper

-- Backtrace:
Application: Плазма (plasmashell), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9d95c30800 (LWP 1290))]

Thread 10 (Thread 0x7f9d537fe700 (LWP 1689)):
#0  0x00007f9d98e10d45 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9d9995c943 in QWaitCondition::wait(QMutex*, QDeadlineTimer) () from /lib64/libQt5Core.so.5
#2  0x00007f9d9995c9d1 in QWaitCondition::wait(QMutex*, unsigned long) () from /lib64/libQt5Core.so.5
#3  0x00007f9d9b5a24e9 in QSGRenderThread::processEventsAndWaitForMore() () from /lib64/libQt5Quick.so.5
#4  0x00007f9d9b5a278d in QSGRenderThread::run() () from /lib64/libQt5Quick.so.5
#5  0x00007f9d99956e26 in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#6  0x00007f9d98e0a4e2 in start_thread () from /lib64/libpthread.so.0
#7  0x00007f9d995d36a3 in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7f9d5a040700 (LWP 1672)):
#0  0x00007f9d98e10d45 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9d9995c943 in QWaitCondition::wait(QMutex*, QDeadlineTimer) () from /lib64/libQt5Core.so.5
#2  0x00007f9d9995c9d1 in QWaitCondition::wait(QMutex*, unsigned long) () from /lib64/libQt5Core.so.5
#3  0x00007f9d9b5a24e9 in QSGRenderThread::processEventsAndWaitForMore() () from /lib64/libQt5Quick.so.5
#4  0x00007f9d9b5a278d in QSGRenderThread::run() () from /lib64/libQt5Quick.so.5
#5  0x00007f9d99956e26 in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#6  0x00007f9d98e0a4e2 in start_thread () from /lib64/libpthread.so.0
#7  0x00007f9d995d36a3 in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7f9d5b9c9700 (LWP 1620)):
#0  0x00007f9d995c8a3f in poll () from /lib64/libc.so.6
#1  0x00007f9d9818686e in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#2  0x00007f9d981869a3 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007f9d99b5b8a3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#4  0x00007f9d99b0523b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#5  0x00007f9d99955cd5 in QThread::exec() () from /lib64/libQt5Core.so.5
#6  0x00007f9d601f6d2c in KCupsConnection::run() () from /lib64/libkcupslib.so
#7  0x00007f9d99956e26 in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#8  0x00007f9d98e0a4e2 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f9d995d36a3 in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f9d60ccb700 (LWP 1613)):
#0  0x00007ffed0f86af6 in clock_gettime ()
#1  0x00007f9d9959a6ab in clock_gettime@GLIBC_2.2.5 () from /lib64/libc.so.6
#2  0x00007f9d99b5b095 in qt_gettime() () from /lib64/libQt5Core.so.5
#3  0x00007f9d99b59bdd in QTimerInfoList::updateCurrentTime() () from /lib64/libQt5Core.so.5
#4  0x00007f9d99b59fe9 in QTimerInfoList::timerWait(timespec&) () from /lib64/libQt5Core.so.5
#5  0x00007f9d99b5b554 in timerSourcePrepareHelper(GTimerSource*, int*) () from /lib64/libQt5Core.so.5
#6  0x00007f9d99b5b602 in timerSourcePrepare(_GSource*, int*) () from /lib64/libQt5Core.so.5
#7  0x00007f9d98185dea in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#8  0x00007f9d9818679b in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#9  0x00007f9d981869a3 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#10 0x00007f9d99b5b8a3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#11 0x00007f9d99b0523b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#12 0x00007f9d99955cd5 in QThread::exec() () from /lib64/libQt5Core.so.5
#13 0x00007f9d9b5170da in QQuickPixmapReader::run() () from /lib64/libQt5Quick.so.5
#14 0x00007f9d99956e26 in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#15 0x00007f9d98e0a4e2 in start_thread () from /lib64/libpthread.so.0
#16 0x00007f9d995d36a3 in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f9d7939c700 (LWP 1612)):
#0  0x00007f9d98e10d45 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9d9995c943 in QWaitCondition::wait(QMutex*, QDeadlineTimer) () from /lib64/libQt5Core.so.5
#2  0x00007f9d9995c9d1 in QWaitCondition::wait(QMutex*, unsigned long) () from /lib64/libQt5Core.so.5
#3  0x00007f9d9b5a24e9 in QSGRenderThread::processEventsAndWaitForMore() () from /lib64/libQt5Quick.so.5
#4  0x00007f9d9b5a278d in QSGRenderThread::run() () from /lib64/libQt5Quick.so.5
#5  0x00007f9d99956e26 in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#6  0x00007f9d98e0a4e2 in start_thread () from /lib64/libpthread.so.0
#7  0x00007f9d995d36a3 in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f9d79f65700 (LWP 1554)):
#0  0x00007f9d98e10d45 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9d9995c943 in QWaitCondition::wait(QMutex*, QDeadlineTimer) () from /lib64/libQt5Core.so.5
#2  0x00007f9d9995c9d1 in QWaitCondition::wait(QMutex*, unsigned long) () from /lib64/libQt5Core.so.5
#3  0x00007f9d9b5a24e9 in QSGRenderThread::processEventsAndWaitForMore() () from /lib64/libQt5Quick.so.5
#4  0x00007f9d9b5a278d in QSGRenderThread::run() () from /lib64/libQt5Quick.so.5
#5  0x00007f9d99956e26 in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#6  0x00007f9d98e0a4e2 in start_thread () from /lib64/libpthread.so.0
#7  0x00007f9d995d36a3 in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f9d7b7fa700 (LWP 1476)):
#0  0x00007f9d98e10d45 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9d80cad19b in util_queue_thread_func () from /usr/lib64/dri/i965_dri.so
#2  0x00007f9d80cacdab in impl_thrd_routine () from /usr/lib64/dri/i965_dri.so
#3  0x00007f9d98e0a4e2 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f9d995d36a3 in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f9d82a26700 (LWP 1439)):
#0  0x00007ffed0f86af6 in clock_gettime ()
#1  0x00007f9d9959a6ab in clock_gettime@GLIBC_2.2.5 () from /lib64/libc.so.6
#2  0x00007f9d99b5b095 in qt_gettime() () from /lib64/libQt5Core.so.5
#3  0x00007f9d99b59bdd in QTimerInfoList::updateCurrentTime() () from /lib64/libQt5Core.so.5
#4  0x00007f9d99b59fe9 in QTimerInfoList::timerWait(timespec&) () from /lib64/libQt5Core.so.5
#5  0x00007f9d99b5b554 in timerSourcePrepareHelper(GTimerSource*, int*) () from /lib64/libQt5Core.so.5
#6  0x00007f9d99b5b602 in timerSourcePrepare(_GSource*, int*) () from /lib64/libQt5Core.so.5
#7  0x00007f9d98185dea in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#8  0x00007f9d9818679b in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#9  0x00007f9d981869a3 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#10 0x00007f9d99b5b8a3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#11 0x00007f9d99b0523b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#12 0x00007f9d99955cd5 in QThread::exec() () from /lib64/libQt5Core.so.5
#13 0x00007f9d9b224399 in QQmlThreadPrivate::run() () from /lib64/libQt5Qml.so.5
#14 0x00007f9d99956e26 in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#15 0x00007f9d98e0a4e2 in start_thread () from /lib64/libpthread.so.0
#16 0x00007f9d995d36a3 in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f9d83cc6700 (LWP 1358)):
#0  0x00007ffed0f86af6 in clock_gettime ()
#1  0x00007f9d9959a6ab in clock_gettime@GLIBC_2.2.5 () from /lib64/libc.so.6
#2  0x00007f9d99b5b095 in qt_gettime() () from /lib64/libQt5Core.so.5
#3  0x00007f9d99b59bdd in QTimerInfoList::updateCurrentTime() () from /lib64/libQt5Core.so.5
#4  0x00007f9d99b59fe9 in QTimerInfoList::timerWait(timespec&) () from /lib64/libQt5Core.so.5
#5  0x00007f9d99b5b554 in timerSourcePrepareHelper(GTimerSource*, int*) () from /lib64/libQt5Core.so.5
#6  0x00007f9d99b5b602 in timerSourcePrepare(_GSource*, int*) () from /lib64/libQt5Core.so.5
#7  0x00007f9d98185dea in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#8  0x00007f9d9818679b in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#9  0x00007f9d981869a3 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#10 0x00007f9d99b5b8a3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#11 0x00007f9d99b0523b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#12 0x00007f9d99955cd5 in QThread::exec() () from /lib64/libQt5Core.so.5
#13 0x00007f9d9a37df6a in QDBusConnectionManager::run() () from /lib64/libQt5DBus.so.5
#14 0x00007f9d99956e26 in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#15 0x00007f9d98e0a4e2 in start_thread () from /lib64/libpthread.so.0
#16 0x00007f9d995d36a3 in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f9d95c30800 (LWP 1290)):
[KCrash Handler]
#6  0x00007f9d9a615784 in QList<QWidget*>::append(QWidget* const&) () from /lib64/libQt5Widgets.so.5
#7  0x00007f9d9a6420f8 in QWidget::insertAction(QAction*, QAction*) () from /lib64/libQt5Widgets.so.5
#8  0x00007f9d9a64222e in QWidget::addActions(QList<QAction*>) () from /lib64/libQt5Widgets.so.5
#9  0x00007f9d82a4921b in ContainmentInterface::addContainmentActions(QMenu*, QEvent*) () from /usr/lib64/qt5/plugins/plasma/scriptengines/plasma_appletscript_declarative.so
#10 0x00007f9d82a49e09 in ContainmentInterface::mousePressEvent(QMouseEvent*) () from /usr/lib64/qt5/plugins/plasma/scriptengines/plasma_appletscript_declarative.so
#11 0x00007f9d9b5e7088 in QQuickItem::event(QEvent*) () from /lib64/libQt5Quick.so.5
#12 0x00007f9d82a3faba in AppletInterface::event(QEvent*) () from /usr/lib64/qt5/plugins/plasma/scriptengines/plasma_appletscript_declarative.so
#13 0x00007f9d9a607ab6 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#14 0x00007f9d9a611150 in QApplication::notify(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#15 0x00007f9d99b06448 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#16 0x00007f9d9b600d00 in QQuickWindowPrivate::deliverMatchingPointsToItem(QQuickItem*, QQuickPointerEvent*, bool) () from /lib64/libQt5Quick.so.5
#17 0x00007f9d9b601ff4 in QQuickWindowPrivate::deliverPressOrReleaseEvent(QQuickPointerEvent*, bool) () from /lib64/libQt5Quick.so.5
#18 0x00007f9d9b6028bd in QQuickWindowPrivate::deliverMouseEvent(QQuickPointerMouseEvent*) () from /lib64/libQt5Quick.so.5
#19 0x00007f9d9b603ceb in QQuickWindowPrivate::deliverPointerEvent(QQuickPointerEvent*) () from /lib64/libQt5Quick.so.5
#20 0x00007f9d9b604a99 in QQuickWindowPrivate::handleMouseEvent(QMouseEvent*) () from /lib64/libQt5Quick.so.5
#21 0x00007f9d99eedbcd in QWindow::event(QEvent*) () from /lib64/libQt5Gui.so.5
#22 0x00007f9d9b605fe9 in QQuickWindow::event(QEvent*) () from /lib64/libQt5Quick.so.5
#23 0x00007f9d9a607ab6 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#24 0x00007f9d9a611150 in QApplication::notify(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#25 0x00007f9d99b06448 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#26 0x00007f9d99ee3b13 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) () from /lib64/libQt5Gui.so.5
#27 0x00007f9d99ee530b in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () from /lib64/libQt5Gui.so.5
#28 0x00007f9d99ec167b in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Gui.so.5
#29 0x00007f9d88b04d5e in xcbSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQt5XcbQpa.so.5
#30 0x00007f9d98186570 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#31 0x00007f9d98186900 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#32 0x00007f9d981869a3 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#33 0x00007f9d99b5b885 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#34 0x00007f9d99b0523b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#35 0x00007f9d99b0d116 in QCoreApplication::exec() () from /lib64/libQt5Core.so.5
#36 0x000055dc5e8a271a in main ()
[Inferior 1 (process 1290) detached]

Possible duplicates by query: bug 419922, bug 417132, bug 416702, bug 416260, bug 270025.

Reported using DrKonqi
Comment 1 Marco Martin 2020-05-21 11:40:58 UTC
*** Bug 419922 has been marked as a duplicate of this bug. ***
Comment 2 David Edmundson 2020-09-23 22:15:42 UTC
*** Bug 426216 has been marked as a duplicate of this bug. ***
Comment 3 Andy Great 2020-11-11 17:54:56 UTC
*** Bug 428082 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2021-02-24 05:39:26 UTC
*** Bug 431375 has been marked as a duplicate of this bug. ***
Comment 5 Nate Graham 2021-02-24 05:39:44 UTC
*** Bug 432737 has been marked as a duplicate of this bug. ***
Comment 6 Nate Graham 2021-03-08 23:16:02 UTC
*** Bug 416702 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2021-03-08 23:16:06 UTC
*** Bug 417132 has been marked as a duplicate of this bug. ***
Comment 8 Nate Graham 2021-03-16 02:48:10 UTC
*** Bug 434313 has been marked as a duplicate of this bug. ***
Comment 9 Nate Graham 2021-03-16 02:48:31 UTC
Got a duplicate report from 5.21.2; re-opening.
Comment 10 Nate Graham 2021-04-06 04:28:06 UTC
*** Bug 435261 has been marked as a duplicate of this bug. ***
Comment 11 Kelvie Wong 2021-09-12 19:51:45 UTC
I think I found an easy way to reproduce this -- just switch the desktop wallpaper plugin from slideshow (which adds context menu items) -> back to "Image", and right click the desktop.

It appears the slideshow plugin adds context menu QActions, but there is a dangling reference to them after the plugin gets cleaned up when it switches back to "Image".
Comment 12 galder 2022-01-26 14:31:20 UTC
moving to confirmed
Comment 13 Fushan Wen 2022-03-22 11:50:35 UTC
Should be already fixed.

*** This bug has been marked as a duplicate of bug 446195 ***