Bug 421217 - Plasma start menu toolbar crashes after pairing mobile with KDEConnect
Summary: Plasma start menu toolbar crashes after pairing mobile with KDEConnect
Status: RESOLVED DUPLICATE of bug 421100
Alias: None
Product: plasmashell
Classification: Unclassified
Component: general (show other bugs)
Version: 5.18.3
Platform: Fedora RPMs Linux
: NOR crash
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-05-09 10:42 UTC by Daniel Souza
Modified: 2020-05-21 12:01 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (81.68 KB, text/plain)
2020-05-09 10:42 UTC, Daniel Souza
Details
New crash information added by DrKonqi (13.37 KB, text/plain)
2020-05-12 23:54 UTC, Fabricio Henrique
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Souza 2020-05-09 10:42:23 UTC
Application: plasmashell (5.18.3)

Qt Version: 5.13.2
Frameworks Version: 5.68.0
Operating System: Linux 5.6.10-300.fc32.x86_64 x86_64
Windowing system: X11
Distribution: Fedora 32 (KDE Plasma)

-- Information about the crash:
- What I was doing when the application crashed:
Pairing mobile with KDE connect.
- Unusual behavior I noticed:
Plasma start menu toolbar crashes and now is hidden. Also the kwin shortcut to open menu (meta) does not work.

- Custom settings of the application:
- Fedora upgraded from 31 to 32, to have the latest KDE Plasma version 5.18.4 (however it came with 5.18.3).
- Compositor on OpenGL 3.1, with disabled option of applications to stop compositor effects.
- Native Nvidia Driver installed version (440.82) NVIDIA-Linux-x86_64-440.82.

The crash can be reproduced every time.

-- Backtrace (Reduced):
#6  0x00007fa6c318a1e8 in glyphRunWithInfo(QFontEngine*, QGlyphLayout const&, QPointF const&, QFlags<QGlyphRun::GlyphRunFlag> const&, QFixed const&, QFixed const&, int, int, unsigned short*, int, int) () at /lib64/libQt5Gui.so.5
#7  0x00007fa6c318b19e in QTextLine::glyphRuns(int, int) const () at /lib64/libQt5Gui.so.5
#8  0x00007fa6c46bb090 in QQuickTextNodeEngine::addGlyphsInRange(int, int, QColor const&, QColor const&, int, int) () at /lib64/libQt5Quick.so.5
#9  0x00007fa6c46bb6d4 in QQuickTextNodeEngine::addGlyphsForRanges(QVarLengthArray<QTextLayout::FormatRange, 256> const&, int, int, int, int) () at /lib64/libQt5Quick.so.5
#10 0x00007fa6c46bd819 in QQuickTextNodeEngine::addText(QTextBlock const&, QTextCharFormat const&, QColor const&, QVarLengthArray<QTextLayout::FormatRange, 256> const&, int, int, int, int) () at /lib64/libQt5Quick.so.5


Possible duplicates by query: bug 421196, bug 421100, bug 421089, bug 420808, bug 416068.

Reported using DrKonqi
Comment 1 Daniel Souza 2020-05-09 10:42:24 UTC
Created attachment 128278 [details]
New crash information added by DrKonqi

DrKonqi auto-attaching complete backtrace.
Comment 2 Fabricio Henrique 2020-05-12 23:54:09 UTC
Created attachment 128406 [details]
New crash information added by DrKonqi

plasmashell (5.18.5) using Qt 5.13.2

- What I was doing when the application crashed:

Connecting my phone to KDE Connect app

- Unusual behavior I noticed:

- PlasmaShell crashes stopping to work and only back when typing kstart5 plasmashell on terminal 

OBS.: I'm running FEDORA 32

-- Backtrace (Reduced):
#6  0x00007fd35a80a2ec in QFontEngineMulti::loadEngine(int) () from /lib64/libQt5Gui.so.5
#7  0x00007fd35a80aadf in QFontEngineMulti::ensureEngineAt(int) () from /lib64/libQt5Gui.so.5
#8  0x00007fd35a83a11a in QTextLine::glyphRuns(int, int) const () from /lib64/libQt5Gui.so.5
#9  0x00007fd35bd94090 in QQuickTextNodeEngine::addGlyphsInRange(int, int, QColor const&, QColor const&, int, int) () from /lib64/libQt5Quick.so.5
#10 0x00007fd35bd946d4 in QQuickTextNodeEngine::addGlyphsForRanges(QVarLengthArray<QTextLayout::FormatRange, 256> const&, int, int, int, int) () from /lib64/libQt5Quick.so.5
Comment 3 Marco Martin 2020-05-21 12:01:33 UTC

*** This bug has been marked as a duplicate of bug 421100 ***