Bug 420949 - Plasma crashes on Wayland when display scale is modified
Summary: Plasma crashes on Wayland when display scale is modified
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: general (show other bugs)
Version: master
Platform: unspecified Linux
: NOR crash
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-05-03 12:16 UTC by Patrick Silva
Modified: 2020-08-29 13:29 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2020-05-03 12:16:35 UTC
Application: plasmashell (5.18.80)

Qt Version: 5.14.2
Frameworks Version: 5.70.0
Operating System: Linux 5.3.0-45-generic x86_64
Windowing system: Wayland
Distribution: KDE neon Unstable Edition

-- Information about the crash:
- What I was doing when the application crashed:
open system settings > display and monitor
set display scale to 125%
plasma crashes

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault
Content of s_kcrashErrorMessage: [Current thread is 1 (Thread 0x7f2f9f0aec80 (LWP 31492))]
[KCrash Handler]
#6  0x00007f2f99097763 in qDeleteAll<QEvent* const*>(QEvent* const*, QEvent* const*) (end=<optimized out>, begin=0x7ffe373101e0) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:320
#7  0x00007f2f99097763 in qDeleteAll<QVarLengthArray<QEvent*, 256> >(QVarLengthArray<QEvent*, 256> const&) (c=...) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:328
#8  0x00007f2f99097763 in QCoreApplication::removePostedEvents(QObject*, int) (receiver=<optimized out>, eventType=0) at kernel/qcoreapplication.cpp:1890
#9  0x00007f2f990c5214 in QObjectPrivate::~QObjectPrivate() (this=0x55fcdadda830, __in_chrg=<optimized out>) at kernel/qobject.cpp:230
#10 0x00007f2f9cfed8a9 in QQuickItemPrivate::~QQuickItemPrivate() (this=0x55fcdadda830, __in_chrg=<optimized out>) at items/qquickitem.cpp:3276
#11 0x00007f2f990cbf96 in QScopedPointerDeleter<QObjectData>::cleanup(QObjectData*) (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:60
#12 0x00007f2f990cbf96 in QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> >::~QScopedPointer() (this=0x55fcdadda7a8, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:107
#13 0x00007f2f990cbf96 in QObject::~QObject() (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:997
#14 0x00007f2f9cff422d in QQuickItem::~QQuickItem() (this=0x55fcdadda7a0, __in_chrg=<optimized out>) at items/qquickitem.cpp:2383
#15 0x00007f2f9d124b39 in QQuickShaderEffectSource::~QQuickShaderEffectSource() (this=0x55fcdadda7a0, __in_chrg=<optimized out>) at items/qquickshadereffectsource.cpp:218
#16 0x00007f2f9cfdf317 in QQuickItemLayer::~QQuickItemLayer() (this=0x55fcdaa07600, __in_chrg=<optimized out>) at items/qquickitem.cpp:8298
#17 0x00007f2f9cfdf389 in QQuickItemLayer::~QQuickItemLayer() (this=0x55fcdaa07600, __in_chrg=<optimized out>) at items/qquickitem.cpp:8300
#18 0x00007f2f9cff41d8 in QQuickItem::~QQuickItem() (this=0x55fcdadde970, __in_chrg=<optimized out>) at items/qquickitem.cpp:2438
#19 0x00007f2f9d015e75 in QQmlPrivate::QQmlElement<QQuickShaderEffect>::~QQmlElement() (this=0x55fcdadde970, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#20 0x00007f2f9d015e75 in QQmlPrivate::QQmlElement<QQuickShaderEffect>::~QQmlElement() (this=0x55fcdadde970, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#21 0x00007f2f990c296b in QObjectPrivate::deleteChildren() (this=0x55fcdaadcc30) at kernel/qobject.cpp:2123
#22 0x00007f2f990cbf4e in QObject::~QObject() (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1107
#23 0x00007f2f9cff422d in QQuickItem::~QQuickItem() (this=0x55fcdaadcb70, __in_chrg=<optimized out>) at items/qquickitem.cpp:2383
#24 0x00007f2f9d014bb5 in QQmlPrivate::QQmlElement<QQuickItem>::~QQmlElement() (this=0x55fcdaadcb70, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#25 0x00007f2f9d014bb5 in QQmlPrivate::QQmlElement<QQuickItem>::~QQmlElement() (this=0x55fcdaadcb70, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#26 0x00007f2f990c296b in QObjectPrivate::deleteChildren() (this=0x55fcdaa8ef60) at kernel/qobject.cpp:2123
#27 0x00007f2f990cbf4e in QObject::~QObject() (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1107
#28 0x00007f2f9cff422d in QQuickItem::~QQuickItem() (this=0x55fcdaa8eea0, __in_chrg=<optimized out>) at items/qquickitem.cpp:2383
#29 0x00007f2f9d014bb5 in QQmlPrivate::QQmlElement<QQuickItem>::~QQmlElement() (this=0x55fcdaa8eea0, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#30 0x00007f2f9d014bb5 in QQmlPrivate::QQmlElement<QQuickItem>::~QQmlElement() (this=0x55fcdaa8eea0, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#31 0x00007f2f990c296b in QObjectPrivate::deleteChildren() (this=0x55fcdaa9cd50) at kernel/qobject.cpp:2123
#32 0x00007f2f990cbf4e in QObject::~QObject() (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1107
#33 0x00007f2f9cff422d in QQuickItem::~QQuickItem() (this=0x55fcdaa9cc90, __in_chrg=<optimized out>) at items/qquickitem.cpp:2383
#34 0x00007f2f9d014bb5 in QQmlPrivate::QQmlElement<QQuickItem>::~QQmlElement() (this=0x55fcdaa9cc90, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#35 0x00007f2f9d014bb5 in QQmlPrivate::QQmlElement<QQuickItem>::~QQmlElement() (this=0x55fcdaa9cc90, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#36 0x00007f2f990c296b in QObjectPrivate::deleteChildren() (this=0x55fcdac1eea0) at kernel/qobject.cpp:2123
#37 0x00007f2f990cbf4e in QObject::~QObject() (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1107
#38 0x00007f2f9cff422d in QQuickItem::~QQuickItem() (this=0x55fcdaa98d90, __in_chrg=<optimized out>) at items/qquickitem.cpp:2383
#39 0x00007f2f9d014dd5 in QQmlPrivate::QQmlElement<QQuickLoader>::~QQmlElement() (this=0x55fcdaa98d90, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#40 0x00007f2f9d014dd5 in QQmlPrivate::QQmlElement<QQuickLoader>::~QQmlElement() (this=0x55fcdaa98d90, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#41 0x00007f2f990c296b in QObjectPrivate::deleteChildren() (this=0x55fcdaae18b0) at kernel/qobject.cpp:2123
#42 0x00007f2f990cbf4e in QObject::~QObject() (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1107
#43 0x00007f2f9cff422d in QQuickItem::~QQuickItem() (this=0x55fcdaac4f10, __in_chrg=<optimized out>) at items/qquickitem.cpp:2383
#44 0x00007f2f9d014bb5 in QQmlPrivate::QQmlElement<QQuickItem>::~QQmlElement() (this=0x55fcdaac4f10, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#45 0x00007f2f9d014bb5 in QQmlPrivate::QQmlElement<QQuickItem>::~QQmlElement() (this=0x55fcdaac4f10, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#46 0x00007f2f990c296b in QObjectPrivate::deleteChildren() (this=0x55fcdac3db40) at kernel/qobject.cpp:2123
#47 0x00007f2f990cbf4e in QObject::~QObject() (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1107
#48 0x00007f2f9cff422d in QQuickItem::~QQuickItem() (this=0x55fcdaae17f0, __in_chrg=<optimized out>) at items/qquickitem.cpp:2383
#49 0x00007f2f9d014dd5 in QQmlPrivate::QQmlElement<QQuickLoader>::~QQmlElement() (this=0x55fcdaae17f0, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#50 0x00007f2f9d014dd5 in QQmlPrivate::QQmlElement<QQuickLoader>::~QQmlElement() (this=0x55fcdaae17f0, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#51 0x00007f2f990c296b in QObjectPrivate::deleteChildren() (this=0x55fcdaae73e0) at kernel/qobject.cpp:2123
#52 0x00007f2f990cbf4e in QObject::~QObject() (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1107
#53 0x00007f2f9cff422d in QQuickItem::~QQuickItem() (this=0x55fcdaa9c2b0, __in_chrg=<optimized out>) at items/qquickitem.cpp:2383
#54 0x00007f2f9d014bb5 in QQmlPrivate::QQmlElement<QQuickItem>::~QQmlElement() (this=0x55fcdaa9c2b0, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#55 0x00007f2f9d014bb5 in QQmlPrivate::QQmlElement<QQuickItem>::~QQmlElement() (this=0x55fcdaa9c2b0, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#56 0x00007f2f990c6225 in QObject::event(QEvent*) (this=this@entry=0x55fcdaa9c2b0, e=e@entry=0x55fcda59c2b0) at kernel/qobject.cpp:1326
#57 0x00007f2f9cff14db in QQuickItem::event(QEvent*) (this=0x55fcdaa9c2b0, ev=0x55fcda59c2b0) at items/qquickitem.cpp:8162
#58 0x00007f2f9a3d69ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=this@entry=0x55fcd6a0c6c0, receiver=receiver@entry=0x55fcdaa9c2b0, e=e@entry=0x55fcda59c2b0) at kernel/qapplication.cpp:3685
#59 0x00007f2f9a3ddbb0 in QApplication::notify(QObject*, QEvent*) (this=0x7ffe37311be0, receiver=0x55fcdaa9c2b0, e=0x55fcda59c2b0) at kernel/qapplication.cpp:3431
#60 0x00007f2f99093128 in QCoreApplication::notifyInternal2(QObject*, QEvent*) (receiver=0x55fcdaa9c2b0, event=0x55fcda59c2b0) at kernel/qcoreapplication.cpp:1075
#61 0x00007f2f990932fe in QCoreApplication::sendEvent(QObject*, QEvent*) (receiver=receiver@entry=0x55fcdaa9c2b0, event=event@entry=0x55fcda59c2b0) at kernel/qcoreapplication.cpp:1470
#62 0x00007f2f99095da1 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x55fcd6a01b00) at kernel/qcoreapplication.cpp:1815
#63 0x00007f2f99096338 in QCoreApplication::sendPostedEvents(QObject*, int) (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1674
#64 0x00007f2f990f2d83 in postEventSourceDispatch(GSource*, GSourceFunc, gpointer) (s=0x55fcd6a4bfa0) at kernel/qeventdispatcher_glib.cpp:277
#65 0x00007f2f9255c417 in g_main_context_dispatch () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#66 0x00007f2f9255c650 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#67 0x00007f2f9255c6dc in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#68 0x00007f2f990f242c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x55fcd6a45580, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#69 0x00007f2f990919aa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffe37311a70, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#70 0x00007f2f9909b120 in QCoreApplication::exec() () at kernel/qcoreapplication.cpp:1383
#71 0x000055fcd59140ca in main(int, char**) (argc=<optimized out>, argv=<optimized out>) at ./shell/main.cpp:222

Possible duplicates by query: bug 420946, bug 420899, bug 420897, bug 420885, bug 420837.

Reported using DrKonqi
Comment 1 Thiago Sueto 2020-08-29 13:16:05 UTC
Cannot reproduce on current master branch.

Operating System: openSUSE Tumbleweed 20200823
KDE Plasma Version: 5.19.80
KDE Frameworks Version: 5.74.0
Qt Version: 5.15.0
Kernel Version: 5.8.0-1-default
Comment 2 Patrick Silva 2020-08-29 13:29:09 UTC
me neither, let's consider this fixed :)