Bug 420910 - Dolphin crash when connecting a smb share
Summary: Dolphin crash when connecting a smb share
Status: RESOLVED WORKSFORME
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 19.12.3
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
: 421600 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-05-02 16:34 UTC by Paolo
Modified: 2020-06-15 04:33 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paolo 2020-05-02 16:34:52 UTC
Application: dolphin (19.12.3)

Qt Version: 5.12.8
Frameworks Version: 5.70.0
Operating System: Linux 5.4.0-29-generic x86_64
Windowing system: X11
Distribution: Ubuntu 20.04 LTS

-- Information about the crash:
I'm tring to connect a smb server share on my routet fritz!box smbv3, when i give username and password and click to connect, dolphin crash.

The crash can be reproduced every time.

-- Backtrace:
Application: Dolphin (dolphin), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb896b53800 (LWP 109709))]

Thread 8 (Thread 0x7fb87bab6700 (LWP 109716)):
#0  0x00007fb8991aad78 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fb8991ab240 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb8991ab2e3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb89b2c2583 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007fb89b2694db in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fb89b0a1785 in QThread::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fb89b0a29d2 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007fb899aec609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#8  0x00007fb89d4f3103 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 7 (Thread 0x7fb88d023700 (LWP 109715)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55fbe18a1ba8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55fbe18a1b58, cond=0x55fbe18a1b80) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55fbe18a1b80, mutex=0x55fbe18a1b58) at pthread_cond_wait.c:638
#3  0x00007fb88ed4335b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007fb88ed42f6b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007fb899aec609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007fb89d4f3103 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7fb88d824700 (LWP 109714)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55fbe18a1ba8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55fbe18a1b58, cond=0x55fbe18a1b80) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55fbe18a1b80, mutex=0x55fbe18a1b58) at pthread_cond_wait.c:638
#3  0x00007fb88ed4335b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007fb88ed42f6b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007fb899aec609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007fb89d4f3103 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7fb88e025700 (LWP 109713)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55fbe18a1ba8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55fbe18a1b58, cond=0x55fbe18a1b80) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55fbe18a1b80, mutex=0x55fbe18a1b58) at pthread_cond_wait.c:638
#3  0x00007fb88ed4335b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007fb88ed42f6b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007fb899aec609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007fb89d4f3103 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7fb88e826700 (LWP 109712)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55fbe18a1ba8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55fbe18a1b58, cond=0x55fbe18a1b80) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55fbe18a1b80, mutex=0x55fbe18a1b58) at pthread_cond_wait.c:638
#3  0x00007fb88ed4335b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007fb88ed42f6b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007fb899aec609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007fb89d4f3103 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7fb895073700 (LWP 109711)):
#0  0x00007fb89d4e696f in __GI___poll (fds=0x7fb888013020, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fb8991ab1ae in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb8991ab2e3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb89b2c2583 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007fb89b2694db in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fb89b0a1785 in QThread::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fb89b544efa in ?? () from /lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007fb89b0a29d2 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007fb899aec609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#9  0x00007fb89d4f3103 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7fb895c9d700 (LWP 109710)):
#0  0x00007fb89d4e696f in __GI___poll (fds=0x7fb895c9cca8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fb899aa7c1a in ?? () from /lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fb899aa990a in xcb_wait_for_event () from /lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fb89649c298 in ?? () from /lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007fb89b0a29d2 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fb899aec609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007fb89d4f3103 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7fb896b53800 (LWP 109709)):
[KCrash Handler]
#6  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:50
#7  0x00007fb89d3f6859 in __GI_abort () at abort.c:79
#8  0x00007fb89ccc3ded in ?? () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#9  0x00007fb89cdda223 in ?? () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#10 0x00007fb89b296458 in QMetaObject::activate(QObject*, int, int, void**) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007fb89c45cf9e in KJob::result (this=0x55fbe1fd0130, _t1=0x55fbe1fd0130, _t2=...) at /home/paolo/projects/kcoreaddons/build/src/lib/KF5CoreAddons_autogen/include/moc_kjob.cpp:573
#12 0x00007fb89c45ae67 in KJob::finishJob (this=0x55fbe1fd0130, emitResult=true) at /home/paolo/projects/kcoreaddons/src/lib/jobs/kjob.cpp:96
#13 0x00007fb89c45b5ed in KJob::emitResult (this=0x55fbe1fd0130) at /home/paolo/projects/kcoreaddons/src/lib/jobs/kjob.cpp:280
#14 0x00007fb89cd7baf8 in KIO::SimpleJob::slotFinished() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#15 0x00007fb89cd7306e in KIO::ListJob::slotFinished() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#16 0x00007fb89b296458 in QMetaObject::activate(QObject*, int, int, void**) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#17 0x00007fb89cd4c252 in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#18 0x00007fb89cd49f4f in KIO::SlaveInterface::dispatch() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#19 0x00007fb89cd53152 in KIO::Slave::gotInput() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#20 0x00007fb89b296458 in QMetaObject::activate(QObject*, int, int, void**) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#21 0x00007fb89b296d5a in QObject::event(QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#22 0x00007fb89bd5ba66 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#23 0x00007fb89bd650f0 in QApplication::notify(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#24 0x00007fb89b26a93a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#25 0x00007fb89b26d5b8 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#26 0x00007fb89b2c2f67 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#27 0x00007fb8991aafbd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007fb8991ab240 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fb8991ab2e3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fb89b2c2565 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#31 0x00007fb89b2694db in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#32 0x00007fb89b271246 in QCoreApplication::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#33 0x00007fb89d60f8b5 in kdemain () from /lib/x86_64-linux-gnu/libkdeinit5_dolphin.so
#34 0x00007fb89d3f80b3 in __libc_start_main (main=0x55fbe09f3060, argc=1, argv=0x7fffa958ef18, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffa958ef08) at ../csu/libc-start.c:308
#35 0x000055fbe09f309e in _start ()
[Inferior 1 (process 109709) detached]

Possible duplicates by query: bug 420874, bug 420414, bug 419828, bug 419798, bug 419640.

Reported using DrKonqi
Comment 1 Harald Sitter 2020-05-11 11:25:24 UTC
Please try to get debug symbols for libKF5KIOCore without it the two most relevant frames lack sufficient information to know what exactly it crashes on.

I've also noticed that kcoreaddons is a local build, is your system a mix of manually built frameworks and ubuntu's kde frameworks? That can easily cause trouble like this.
Comment 2 Nate Graham 2020-05-16 13:37:12 UTC
*** Bug 421600 has been marked as a duplicate of this bug. ***
Comment 3 Bug Janitor Service 2020-05-31 04:33:09 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Bug Janitor Service 2020-06-15 04:33:09 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!