Bug 420566 - Plasma crashed in TaskManager::servicesFromPid() after I dismiss the logout screen by quickly pressing ESC
Summary: Plasma crashed in TaskManager::servicesFromPid() after I dismiss the logout s...
Status: RESOLVED DUPLICATE of bug 431334
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: master
Platform: unspecified Linux
: HI crash
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords: drkonqi
: 413556 417765 419444 420685 421087 421204 422020 423275 423339 425671 429325 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-04-25 12:44 UTC by Patrick Silva
Modified: 2021-05-19 21:07 UTC (History)
13 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2020-04-25 12:44:18 UTC
Application: plasmashell (5.18.80)

Qt Version: 5.14.1
Frameworks Version: 5.70.0
Operating System: Linux 5.3.0-45-generic x86_64
Windowing system: X11
Distribution: KDE neon Unstable Edition

-- Information about the crash:
- What I was doing when the application crashed:
I pressed ctrl+alt+del to trigger the logout screen and then quickly pressed ESC to dismiss it.
Plasma crashed,

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault
Content of s_kcrashErrorMessage: [Current thread is 1 (Thread 0x7fba82899c80 (LWP 1428))]
[KCrash Handler]
#6  0x00007fba7e354adf in std::__atomic_base<int>::load(std::memory_order) const (__m=std::memory_order_relaxed, this=0x660066006f0053) at /usr/include/c++/7/bits/atomic_base.h:396
#7  0x00007fba7e354adf in QAtomicOps<int>::loadRelaxed<int>(std::atomic<int> const&) (_q_value=...) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qatomic_cxx11.h:239
#8  0x00007fba7e354adf in QBasicAtomicInteger<int>::loadRelaxed() const (this=0x660066006f0053) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qbasicatomic.h:107
#9  0x00007fba7e354adf in QtPrivate::RefCount::ref() (this=0x660066006f0053) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qrefcount.h:55
#10 0x00007fba7e354adf in QString::QString(QString const&) (other=..., this=0x7ffd17ad7480) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qstring.h:1051
#11 0x00007fba7e354adf in (anonymous namespace)::getProcessInfo(QString const&, KProcessList::KProcessInfo&) (procId=..., processInfo=...) at ./src/lib/util/kprocesslist_unix.cpp:91
#12 0x00007fba7e355be1 in KProcessList::processInfo(long long) (pid=pid@entry=21970) at ./src/lib/util/kprocesslist_unix.cpp:150
#13 0x00007fba5efa4a18 in TaskManager::servicesFromPid(unsigned int, QExplicitlySharedDataPointer<KSharedConfig>) (pid=pid@entry=21970, rulesConfig=...) at ./libtaskmanager/tasktools.cpp:534
#14 0x00007fba5efa55f5 in TaskManager::windowUrlFromMetadata(QString const&, unsigned int, QExplicitlySharedDataPointer<KSharedConfig>, QString const&) (appId=..., pid=pid@entry=21970, rulesConfig=..., xWindowsWMClassName=...) at ./libtaskmanager/tasktools.cpp:436
#15 0x00007fba5efb4110 in TaskManager::XWindowTasksModel::Private::windowUrl(unsigned long long) (this=this@entry=0x560c36b72ed0, window=<optimized out>) at ./libtaskmanager/xwindowtasksmodel.cpp:543
#16 0x00007fba5efb468b in TaskManager::XWindowTasksModel::Private::appData(unsigned long long) (this=0x560c36b72ed0, window=<optimized out>) at ./libtaskmanager/xwindowtasksmodel.cpp:447
#17 0x00007fba5efb8b47 in TaskManager::XWindowTasksModel::data(QModelIndex const&, int) const (this=0x560c36b7d610, index=..., role=<optimized out>) at ./libtaskmanager/xwindowtasksmodel.cpp:694
#18 0x00007fba7c8411e8 in QAbstractProxyModel::data(QModelIndex const&, int) const (this=<optimized out>, proxyIndex=..., role=293) at itemmodels/qabstractproxymodel.cpp:245
#19 0x00007fba5ed236d4 in KConcatenateRowsProxyModel::data(QModelIndex const&, int) const () at /usr/lib/x86_64-linux-gnu/libKF5ItemModels.so.5
#20 0x00007fba5ef8ac94 in QModelIndex::data(int) const (arole=293, this=0x7ffd17ad7be0) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qabstractitemmodel.h:460
#21 0x00007fba5ef8ac94 in TaskManager::TaskFilterProxyModel::acceptsRow(int) const (this=0x560c36bb5b40, sourceRow=1) at ./libtaskmanager/taskfilterproxymodel.cpp:251
#22 0x00007fba7c8557e9 in QSortFilterProxyModelPrivate::_q_sourceDataChanged(QModelIndex const&, QModelIndex const&, QVector<int> const&) (this=<optimized out>, source_top_left=..., source_bottom_right=..., roles=...) at itemmodels/qsortfilterproxymodel.cpp:1434
#23 0x00007fba7c858208 in QSortFilterProxyModel::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/moc_qsortfilterproxymodel.cpp:275
#24 0x00007fba7c8c2dc9 in doActivate<false>(QObject*, int, void**) (sender=0x560c36b93be0, signal_index=3, argv=0x7ffd17ad7f10) at kernel/qobject.cpp:3882
#25 0x00007fba7c8bd8a2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=<optimized out>, m=m@entry=0x7fba7cd540a0 <QAbstractItemModel::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffd17ad7f10) at kernel/qobject.cpp:3930
#26 0x00007fba7c8231cc in QAbstractItemModel::dataChanged(QModelIndex const&, QModelIndex const&, QVector<int> const&) (this=<optimized out>, _t1=..., _t2=..., _t3=...) at .moc/moc_qabstractitemmodel.cpp:557
#27 0x00007fba5ed23172 in  () at /usr/lib/x86_64-linux-gnu/libKF5ItemModels.so.5
#28 0x00007fba5ed24618 in  () at /usr/lib/x86_64-linux-gnu/libKF5ItemModels.so.5
#29 0x00007fba7c8c2dc9 in doActivate<false>(QObject*, int, void**) (sender=0x560c36b7d550, signal_index=3, argv=0x7ffd17ad80f0) at kernel/qobject.cpp:3882
#30 0x00007fba7c8bd8a2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=sender@entry=0x560c36b7d550, m=m@entry=0x7fba7cd540a0 <QAbstractItemModel::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffd17ad80f0) at kernel/qobject.cpp:3930
#31 0x00007fba7c8231cc in QAbstractItemModel::dataChanged(QModelIndex const&, QModelIndex const&, QVector<int> const&) (this=this@entry=0x560c36b7d550, _t1=..., _t2=..., _t3=...) at .moc/moc_qabstractitemmodel.cpp:557
#32 0x00007fba7c849c21 in QIdentityProxyModelPrivate::_q_sourceDataChanged(QModelIndex const&, QModelIndex const&, QVector<int> const&) (this=<optimized out>, topLeft=..., bottomRight=..., roles=...) at itemmodels/qidentityproxymodel.cpp:483
#33 0x00007fba7c84b8f8 in QIdentityProxyModel::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/moc_qidentityproxymodel.cpp:164
#34 0x00007fba7c8c2dc9 in doActivate<false>(QObject*, int, void**) (sender=0x560c36b7d610, signal_index=3, argv=0x7ffd17ad82f0) at kernel/qobject.cpp:3882
#35 0x00007fba7c8bd8a2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=<optimized out>, m=m@entry=0x7fba7cd540a0 <QAbstractItemModel::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffd17ad82f0) at kernel/qobject.cpp:3930
#36 0x00007fba7c8231cc in QAbstractItemModel::dataChanged(QModelIndex const&, QModelIndex const&, QVector<int> const&) (this=<optimized out>, _t1=..., _t2=..., _t3=...) at .moc/moc_qabstractitemmodel.cpp:557
#37 0x00007fba5efb3716 in TaskManager::XWindowTasksModel::Private::dataChanged(unsigned long long, QVector<int> const&) (this=this@entry=0x560c36b72ed0, window=<optimized out>, roles=...) at ./libtaskmanager/xwindowtasksmodel.cpp:422
#38 0x00007fba5efb6162 in TaskManager::XWindowTasksModel::Private::windowChanged(unsigned long long, QFlags<NET::Property>, QFlags<NET::Property2>) (this=0x560c36b72ed0, window=<optimized out>, properties=..., properties2=...) at ./libtaskmanager/xwindowtasksmodel.cpp:409
#39 0x00007fba7c8c2fe7 in QtPrivate::QSlotObjectBase::call(QObject*, void**) (a=0x7ffd17ad8530, r=0x560c36b7d610, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#40 0x00007fba7c8c2fe7 in doActivate<false>(QObject*, int, void**) (sender=0x560c348eeef0, signal_index=5, argv=0x7ffd17ad8530) at kernel/qobject.cpp:3870
#41 0x00007fba7c8bd8a2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=<optimized out>, m=m@entry=0x7fba5f1d34c0 <XWindowSystemEventBatcher::staticMetaObject>, local_signal_index=local_signal_index@entry=2, argv=argv@entry=0x7ffd17ad8530) at kernel/qobject.cpp:3930
#42 0x00007fba5efbb75b in XWindowSystemEventBatcher::windowChanged(unsigned long long, QFlags<NET::Property>, QFlags<NET::Property2>) (this=<optimized out>, _t1=<optimized out>, _t2=..., _t3=...) at ./obj-x86_64-linux-gnu/libtaskmanager/taskmanager_autogen/EWIEGA46WW/moc_xwindowsystemeventbatcher.cpp:176
#43 0x00007fba5efb2541 in XWindowSystemEventBatcher::<lambda(WId, NET::Properties, NET::Properties2)>::operator() (properties2=..., properties=..., window=<optimized out>, __closure=0x560c36b96fc0) at ./libtaskmanager/xwindowsystemeventbatcher.cpp:63
#46 0x00007fba5efb2541 in QtPrivate::QFunctorSlotObject<XWindowSystemEventBatcher::XWindowSystemEventBatcher(QObject*)::<lambda(WId, NET::Properties, NET::Properties2)>, 3, QtPrivate::List<long long unsigned int, QFlags<NET::Property>, QFlags<NET::Property2> >, void>::impl(int, QtPrivate::QSlotObjectBase *, QObject *, void **, bool *) (which=<optimized out>, this_=0x560c36b96fb0, r=<optimized out>, a=<optimized out>, ret=<optimized out>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qobjectdefs_impl.h:439
#47 0x00007fba7c8c2fe7 in QtPrivate::QSlotObjectBase::call(QObject*, void**) (a=0x7ffd17ad86e0, r=0x560c348eeef0, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#48 0x00007fba7c8c2fe7 in doActivate<false>(QObject*, int, void**) (sender=0x7fba7eedac60, signal_index=12, argv=0x7ffd17ad86e0) at kernel/qobject.cpp:3870
#49 0x00007fba7ecca7fb in KWindowSystem::windowChanged(unsigned long long, QFlags<NET::Property>, QFlags<NET::Property2>) () at /usr/lib/x86_64-linux-gnu/libKF5WindowSystem.so.5
#50 0x00007fba65896c86 in  () at /usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/org.kde.kwindowsystem.platforms/KF5WindowSystemX11Plugin.so
#51 0x00007fba7c884def in QAbstractEventDispatcher::filterNativeEvent(QByteArray const&, void*, long*) (this=<optimized out>, eventType=..., message=message@entry=0x7fba6801bef0, result=result@entry=0x7ffd17ad87f8) at kernel/qabstracteventdispatcher.cpp:488
#52 0x00007fba6fc3fbac in QXcbConnection::handleXcbEvent(xcb_generic_event_t*) (this=this@entry=0x560c3490f970, event=event@entry=0x7fba6801bef0) at qxcbconnection.cpp:550
#53 0x00007fba6fc406d6 in QXcbConnection::processXcbEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x560c3490f970, flags=flags@entry=...) at qxcbconnection.cpp:1029
#54 0x00007fba6fc64c83 in xcbSourceDispatch(GSource*, GSourceFunc, gpointer) (source=<optimized out>) at qxcbeventdispatcher.cpp:103
#55 0x00007fba75d51417 in g_main_context_dispatch () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#56 0x00007fba75d51650 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#57 0x00007fba75d516dc in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#58 0x00007fba7c8e70bc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x560c3495b8f0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#59 0x00007fba7c88663a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffd17ad8a90, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#60 0x00007fba7c88fdb0 in QCoreApplication::exec() () at kernel/qcoreapplication.cpp:1400
#61 0x0000560c339f6058 in main(int, char**) (argc=<optimized out>, argv=<optimized out>) at ./shell/main.cpp:220

Possible duplicates by query: bug 420495, bug 419922, bug 419444, bug 417542, bug 416032.

Reported using DrKonqi
Comment 1 Christoph Feck 2020-05-14 15:21:38 UTC
*** Bug 420685 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Feck 2020-05-14 15:22:10 UTC
*** Bug 421204 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Feck 2020-05-14 15:22:59 UTC
*** Bug 417765 has been marked as a duplicate of this bug. ***
Comment 4 Christoph Feck 2020-05-14 15:24:03 UTC
*** Bug 421087 has been marked as a duplicate of this bug. ***
Comment 5 Christoph Feck 2020-05-14 15:25:50 UTC
*** Bug 413556 has been marked as a duplicate of this bug. ***
Comment 6 Nate Graham 2021-02-27 04:47:25 UTC
*** Bug 425671 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2021-02-27 04:47:38 UTC
*** Bug 429325 has been marked as a duplicate of this bug. ***
Comment 8 Nate Graham 2021-02-27 04:47:57 UTC
*** Bug 423339 has been marked as a duplicate of this bug. ***
Comment 9 Nate Graham 2021-02-27 04:49:38 UTC
*** Bug 423275 has been marked as a duplicate of this bug. ***
Comment 10 Nate Graham 2021-02-27 04:49:49 UTC
*** Bug 422020 has been marked as a duplicate of this bug. ***
Comment 11 Nate Graham 2021-03-08 22:36:20 UTC
*** Bug 419444 has been marked as a duplicate of this bug. ***
Comment 12 David Edmundson 2021-05-19 21:07:02 UTC

*** This bug has been marked as a duplicate of bug 431334 ***