Bug 420559 - hash mismatch
Summary: hash mismatch
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Bundle-Windows (show other bugs)
Version: 6.4.0
Platform: Microsoft Windows Microsoft Windows
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-25 10:23 UTC by rvboutin9
Modified: 2022-01-01 17:06 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.5.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rvboutin9 2020-04-25 10:23:47 UTC
SUMMARY
I downloaded Digikam version 6.4.0 Windows 64bit installer initially from the 1st mirror (https://download.kde.org/stable/digikam/6.4.0/digiKam-6.4.0-Win64.exe), I got an alert from Windows Defender service saying that this software was unsafe, I tried to install anyway but the install stopped with an error. I then check the hash from that download and it did not match. I download it again from http://www-ftp.lip6.fr/pub/X11/kde/stable/digikam/6.4.0/digiKam-6.4.0-Win64.exe same again the hash did not match. I downloaded it from http://mirror.hs-esslingen.de/Mirrors/ftp.kde.org/pub/kde/stable/digikam/6.4.0/digiKam-6.4.0-Win64.exe then the hash matched and the install ran fine.


STEPS TO REPRODUCE
1. download from https://download.kde.org/stable/digikam/6.4.0/digiKam-6.4.0-Win64.exe >> wrong SHA-256 Hash
2. http://www-ftp.lip6.fr/pub/X11/kde/stable/digikam/6.4.0/digiKam-6.4.0-Win64.exe >> wrong SHA-256 Hash
3. http://mirror.hs-esslingen.de/Mirrors/ftp.kde.org/pub/kde/stable/digikam/6.4.0/digiKam-6.4.0-Win64.exe correct hash

Best regards,
Rv
Comment 1 Maik Qualmann 2020-04-25 11:55:45 UTC
I only tested this download:

http://www-ftp.lip6.fr/pub/X11/kde/stable/digikam/6.4.0/digiKam-6.4.0-Win64.exe

(f4292385ed047d65681b10ac904f5bb48e0143a12900147271d296fbe8ac9fa5)

The checksum is correct.

Maik
Comment 2 Maik Qualmann 2020-04-25 12:50:37 UTC
I checked all the specified download mirrors, the files are OK.

Maik
Comment 3 Maik Qualmann 2020-04-25 12:53:45 UTC
The Defender alarm is known, digiKam is an unknown program for Windows. Gilles has done a lot of work to compile digiKam with the MSVC. It is a prerequisite that digiKam can be included in the Windows App Store. Then the problem will no longer exist.

Maik
Comment 4 Maik Qualmann 2020-04-25 14:02:20 UTC

*** This bug has been marked as a duplicate of bug 398582 ***
Comment 5 caulier.gilles 2020-04-25 15:05:15 UTC
These mirror are managed out of space of digiKam team. We publish original on root server which are mirrored everywhere.

So the mirroring stage be can uncomplete and not well done. I don't know why.

This is why you have SHA256 sum to check if mirroring is safe or not...

Best

Gilles Caulier