Bug 420515 - Breeze Dark: Color of "today" does not differ from background
Summary: Breeze Dark: Color of "today" does not differ from background
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Applications
Component: monthview (show other bugs)
Version: 5.12.3
Platform: Other Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 421500 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-04-24 14:08 UTC by patj
Modified: 2021-09-28 16:49 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.18.2


Attachments
Visualization of the issue (4.72 KB, image/png)
2020-05-14 07:37 UTC, Thomas Tanghus
Details
KOrganizer, Breeze Dark theme (10.22 KB, image/png)
2021-09-04 02:07 UTC, gjditchfield
Details

Note You need to log in before you can comment on or make changes to this bug.
Description patj 2020-04-24 14:08:21 UTC
SUMMARY

If I choose "Breeze Dark" as global system theme, KOrganizer is also dark, which is fine. But in month view the tile of today's day is plain black and no (or only very little) different from the other tiles and almost not recognizable.


STEPS TO REPRODUCE
1. Set Breeze Dark global theme
2. Look at month view at today's day.

OBSERVED RESULT

"today" is just as black as the other days.


EXPECTED RESULT

"today" is somehow highlighted.


SOFTWARE/OS VERSIONS
Linux: Debian Testing
KDE Plasma Version: 5.17.5
KDE Frameworks 5.62.0
Qt 5.12.5 (kompiliert gegen 5.12.5)
Comment 1 Thomas Tanghus 2020-05-14 07:32:34 UTC
*** Bug 421500 has been marked as a duplicate of this bug. ***
Comment 2 Thomas Tanghus 2020-05-14 07:36:18 UTC
I managed to make a dupe #421500 before finding this.

Confirmed! ;)
Comment 3 Thomas Tanghus 2020-05-14 07:37:34 UTC
Created attachment 128443 [details]
Visualization of the issue
Comment 4 gjditchfield 2021-09-04 02:07:24 UTC
Created attachment 141281 [details]
KOrganizer, Breeze Dark theme
Comment 5 gjditchfield 2021-09-04 02:13:00 UTC
Do you still have this problem?  On my computer using current versions of Breeze Dark and KOrganizer, today's tile is quite a bit lighter than the others (see attachment).
Comment 6 Thomas Tanghus 2021-09-04 07:31:02 UTC
(In reply to gjditchfield from comment #5)
> Do you still have this problem?  On my computer using current versions of
> Breeze Dark and KOrganizer, today's tile is quite a bit lighter than the
> others (see attachment).

Akonadi has - again - crapped out, resulting in a non-functioning kdepim, so I can't test it myself.
It does look a bit sharper, but my old eyes would prefer some more distinction.
Comment 7 gjditchfield 2021-09-12 22:13:34 UTC
OK, I"ll leave the bug open but demote it to the wish list.
Comment 8 Allen Winter 2021-09-18 20:28:37 UTC
Glen,
What I'd like to see is a red box (or some striking color) drawn around the perimeter of the day box.
I don't think the background color of the title is bad.

-Allen
Comment 9 gjditchfield 2021-09-20 16:17:36 UTC
(In reply to Allen Winter from comment #8)
> What I'd like to see is a red box (or some striking color) drawn around the
> perimeter of the day box.

I like that idea -- visible, but not gaudy.  Thomas, please look at the screenshots in https://invent.kde.org/pim/eventviews/-/merge_requests/43
Comment 10 Thomas Tanghus 2021-09-20 20:18:04 UTC
(In reply to gjditchfield from comment #9)
> I like that idea -- visible, but not gaudy.  Thomas, please look at the
> screenshots in https://invent.kde.org/pim/eventviews/-/merge_requests/43

Something like that. Maybe not red as it's often used to indicate errors. Isn't there some color constants for each theme you can use for highlight?
Comment 11 gjditchfield 2021-09-25 02:34:36 UTC
(In reply to Thomas Tanghus from comment #10)
> Something like that. Maybe not red as it's often used to indicate errors.

I switched to a theme-dependent "positive" color (green for Breeze), and tinted the box with it as well.