Bug 420329 - Move tool's Position x/y spinboxes does not move the highlighted object
Summary: Move tool's Position x/y spinboxes does not move the highlighted object
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Tools/Move (show other bugs)
Version: 4.2.9
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-20 09:11 UTC by Tyson Tan
Modified: 2020-10-29 12:39 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tyson Tan 2020-04-20 09:11:00 UTC
Move tool -> Tool options -> Position
The x/y spinboxes does not move the highlighted object as the reference manual mentioned in:
#: ../../reference_manual/tools/move.rst:40
Gives the top-left coordinate of the layer, can also be manually edited.

Tested:
krita-4.2.9-x86_64.appimage
Comment 1 wolthera 2020-04-20 09:26:50 UTC
yeah, noticed this yesterday as well...
Comment 2 Halla Rempt 2020-04-20 10:21:12 UTC
I must be misunderstanding something? I opened an image with a layer, and changed the values of the x,y spinboxes, and the layer certainly moved for me.
Comment 3 Tyson Tan 2020-04-20 13:21:30 UTC
I cleared kritadisplayrc kritarc kritashortcutsrc and now it worked as intended. It's not the first time something like this happened though. Another Kubuntu user reported this 3 days before I confirmed it today. 

I used Appimages of 4.2.9, 4.3.0 5.0.0 on my installation, but only integrate one at a time. I also installed 4.2.9 from Manjaro's repository once but uninstalled it later. I wonder if this has something to do with it?

I've noticed that Krita from Manjaro's official repo has wonky pop-up palette triggering. Move tool's modifier keys were also completely broken which I didn't have time to report, but now I'm glad I didn't because they were fixed after deleting the settings as well. 

Meanwhile please close this bug if needed. If I find more information I will put them here later. Thank you for your time!
Comment 4 Halla Rempt 2020-04-20 13:41:17 UTC
The wonkiness in the manjaro build of Krita is probably because they haven't patched Qt. If you're using 5.0 appimages, please be aware that it's really unstable. It might make sense to use different XDG environment variables for 4.x and 5.x, to keep the resource folder and configs separate:

export XDG_DATA_HOME=$dev/.share
export XDG_CONFIG_HOME=$dev/.config
export XDG_CACHE_HOME=$dev/.cache
Comment 5 Dmitry Kazakov 2020-10-29 12:21:14 UTC
Git commit efe9ed8c0e5c5211a66919290dcff7e907e48840 by Dmitry Kazakov, on behalf of Mathias Wein.
Committed on 29/10/2020 at 12:20.
Pushed by dkazakov into branch 'krita/4.3'.

Fix malfunction of x/y position spin boxes in move tool's options

The signal connections had to be moved from the constructor to
activate(), since they get disconnected on every deactivate().

Also, manipulating the x or y position without clicking on the canvas first
doubled the initial value, because a new stroke gets created, which in turn
resets the handle rect.
Reading the value before starting the stroke and making sure it's not
currently unavailable until recalculated should prevent it.
Related: bug 423452

M  +23   -10   plugins/tools/basictools/kis_tool_move.cc

https://invent.kde.org/graphics/krita/commit/efe9ed8c0e5c5211a66919290dcff7e907e48840
Comment 6 Dmitry Kazakov 2020-10-29 12:22:37 UTC
Git commit 12b3293d4987291e044bd4e52070a7e54f7e73dc by Dmitry Kazakov, on behalf of Mathias Wein.
Committed on 29/10/2020 at 11:37.
Pushed by dkazakov into branch 'master'.

Fix malfunction of x/y position spin boxes in move tool's options

The signal connections had to be moved from the constructor to
activate(), since they get disconnected on every deactivate().

Also, manipulating the x or y position without clicking on the canvas first
doubled the initial value, because a new stroke gets created, which in turn
resets the handle rect.
Reading the value before starting the stroke and making sure it's not
currently unavailable until recalculated should prevent it.
Related: bug 423452

M  +23   -10   plugins/tools/basictools/kis_tool_move.cc

https://invent.kde.org/graphics/krita/commit/12b3293d4987291e044bd4e52070a7e54f7e73dc
Comment 7 Tyson Tan 2020-10-29 12:39:49 UTC
Thank you, Dmitry! :D