Bug 419911 - Konsole is confused about the system language
Summary: Konsole is confused about the system language
Status: RESOLVED DUPLICATE of bug 192019
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: 19.12.3
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-10 11:06 UTC by Sadi
Modified: 2021-09-30 19:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sadi 2020-04-10 11:06:33 UTC
SUMMARY
My default system language is American English.
However I often use British English as well. And I often use Turkish in documents, browse Turkish websites, etc. But when I add these 2 languages Konsole starts displaying output partially in Turkish and - probably due to lack of translation - partially in English.

STEPS TO REPRODUCE
1. Go to "System Settings > Regional Settings > Language".
2. Add "British English", and then Turkish, i.e. "Türkçe".
3. Log out and back in.
4. Start Konsole, and enter "sudo apt update".

OBSERVED RESULT
Konsole starts displaying output partially in Turkish and partially in English.

EXPECTED RESULT
Konsole should use the language setting in "System Settings > Regional Settings > Formats > Region" or the first language in "System Settings > Regional Settings > Language".

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Kubuntu 19.10
(available in About System)
KDE Plasma Version: 5.18.3
KDE Frameworks Version: 5.67.0
Qt Version: 5.12.4

ADDITIONAL INFORMATION
I might have seen this problem elsewhere in among KDE apps but I don't remember now...
Comment 1 Nate Graham 2020-04-15 03:22:19 UTC

*** This bug has been marked as a duplicate of bug 327757 ***
Comment 2 Nate Graham 2021-09-30 19:00:16 UTC

*** This bug has been marked as a duplicate of bug 192019 ***