Bug 419517 - Applets that have no custom settings have a different sidebar appearance from applets that do
Summary: Applets that have no custom settings have a different sidebar appearance from...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: general (show other bugs)
Version: 5.19.90
Platform: Archlinux Linux
: NOR minor
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2020-04-01 21:15 UTC by Patrick Silva
Modified: 2020-09-25 14:14 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.20


Attachments
settings window of touchpad indicator (37.93 KB, image/png)
2020-04-01 21:15 UTC, Patrick Silva
Details
settings window of Media Player (37.93 KB, image/png)
2020-04-01 21:22 UTC, Patrick Silva
Details
settings window of Media Player applet (38.50 KB, image/png)
2020-04-15 01:40 UTC, Patrick Silva
Details
screen recording (2.61 MB, video/webm)
2020-04-15 02:41 UTC, Patrick Silva
Details
settings window of notifications applet (38.46 KB, image/png)
2020-04-15 03:58 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2020-04-01 21:15:32 UTC
Created attachment 127180 [details]
settings window of touchpad indicator

SUMMARY
Compare the attached screenshots showing the settings windows of touchpad indicator and Media Player applets.
Side bar of settings window of touchpad indicator is white,
side bar of settings window of Media Player is not.

EXPECTED RESULT
consistency

SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.18.80
KDE Frameworks Version: 5.69.0
Qt Version: 5.14.1
Comment 1 Patrick Silva 2020-04-01 21:22:11 UTC
Created attachment 127182 [details]
settings window of Media Player

Settings window of Media Player has the same appearance on Arch Linux.
I can't test the touchpad indicator on this system because it's running on a desktop computer.
Comment 2 Nate Graham 2020-04-15 00:58:34 UTC
I think you attached the same screenshot for both of them.
Comment 3 Patrick Silva 2020-04-15 01:40:54 UTC
Created attachment 127557 [details]
settings window of Media Player applet

lol, sorry. Correct screenshot attached.
Comment 4 Nate Graham 2020-04-15 02:14:57 UTC
Thanks. However I still don't see it myself. Do you think you could attach a screen recording?
Comment 5 Patrick Silva 2020-04-15 02:41:51 UTC
Created attachment 127558 [details]
screen recording
Comment 6 Nate Graham 2020-04-15 03:48:08 UTC
Thanks. I still can't reproduce. Is your Media Player widget a 3rd-party widget by any chance? Its settings window is missing options present in mine.
Comment 7 Patrick Silva 2020-04-15 03:58:09 UTC
Created attachment 127559 [details]
settings window of notifications applet

(In reply to Nate Graham from comment #6)
> Is your Media Player widget a 3rd-party widget by any chance? 

No. It's official Plasma applet.
Settings windows of notifications and vaults applets are also affected.
Comment 8 Nate Graham 2020-04-15 14:47:42 UTC
Can reproduce for the notifications applet and Vaults.

Looks like the issue only happens for applets with no custom settings.
Comment 9 Bug Janitor Service 2020-09-25 11:43:30 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/162
Comment 10 David Redondo 2020-09-25 14:03:11 UTC
Git commit 18e1f4433fa77ea1a896404cf0737736ba1ad404 by David Redondo.
Committed on 25/09/2020 at 11:41.
Pushed by davidre into branch 'master'.

Always draw sidebar in applet configuration window

We now have two entries by default so we should always draw the sidebar now,
not only when the applet adds entries.
FIXED-IN:5.20

M  +0    -3    desktoppackage/contents/configuration/AppletConfiguration.qml

https://invent.kde.org/plasma/plasma-desktop/commit/18e1f4433fa77ea1a896404cf0737736ba1ad404
Comment 11 David Redondo 2020-09-25 14:14:44 UTC
Git commit 5e74109b6ebbf785c0c27f485182de38fa21913c by David Redondo.
Committed on 25/09/2020 at 14:14.
Pushed by davidre into branch 'Plasma/5.20'.

Always draw sidebar in applet configuration window

We now have two entries by default so we should always draw the sidebar now,
not only when the applet adds entries.
FIXED-IN:5.20

(cherry picked from commit 18e1f4433fa77ea1a896404cf0737736ba1ad404)

M  +0    -3    desktoppackage/contents/configuration/AppletConfiguration.qml

https://invent.kde.org/plasma/plasma-desktop/commit/5e74109b6ebbf785c0c27f485182de38fa21913c