Bug 419494 - "Identify" feature does not work properly with identically-named displays
Summary: "Identify" feature does not work properly with identically-named displays
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_kscreen (show other bugs)
Version: unspecified
Platform: Neon Linux
: NOR normal with 5 votes (vote)
Target Milestone: ---
Assignee: kscreen-bugs-null@kde.org
URL:
Keywords: regression, wayland
: 454486 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-04-01 13:56 UTC by Patrick Silva
Modified: 2022-09-12 23:42 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.26


Attachments
picture (1.57 MB, image/png)
2020-04-01 13:56 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2020-04-01 13:56:04 UTC
Created attachment 127161 [details]
picture

STEPS TO REPRODUCE
1. connect an external monitor to hdmi port
2. set multi-screen mode to "unify outputs"
3. open "Display configuration" kcm and click on "Identify" button

OBSERVED RESULT
both screens are identified with the same name.
See the attached picture.

EXPECTED RESULT
both screen should be correctly identified

SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.18.80
KDE Frameworks Version: 5.69.0
Qt Version: 5.14.1
Kernel Version: 5.3.0-45-generic
OS Type: 64-bit
Processors: 4 × Intel® Core™ i3-3110M CPU @ 2.40GHz
Memory: 7,7 GiB of RAM
Graphics Processor: Mesa DRI Intel® Ivybridge Mobile
Comment 1 David Edmundson 2020-04-01 14:05:50 UTC
For X this is not fixable, for wayland we may have an option
Comment 2 Patrick Silva 2022-05-22 22:37:33 UTC
Still an issue on neon unstable.

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.25.80
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.4
Graphics Platform: Wayland
Comment 3 Nate Graham 2022-06-01 17:15:09 UTC
*** Bug 454486 has been marked as a duplicate of this bug. ***
Comment 4 David Edmundson 2022-09-12 20:37:36 UTC
>for wayland we may have an option

This landed in 5.26