Bug 418912 - Akonadi IMAP resource in crash loop after moving and deleting folder
Summary: Akonadi IMAP resource in crash loop after moving and deleting folder
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Unclassified
Component: IMAP resource (show other bugs)
Version: 5.11.3
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-16 09:56 UTC by Dennis Schridde
Modified: 2021-05-16 12:04 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
akonadi_imap_resource-20200316-102944.kcrash.txt (8.77 KB, text/plain)
2020-03-16 10:08 UTC, Dennis Schridde
Details
New crash information added by DrKonqi (8.73 KB, text/plain)
2020-03-22 17:20 UTC, Dennis Schridde
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2020-03-16 09:56:40 UTC
SUMMARY

Akonadi IMAP resource constantly crashes, is being restarted, crashes, etc.  `akonadictl restart` does not help.


STEPS TO REPRODUCE
1. Move a mail folder from one IMAP server to another
2. See in KMail (expand the progress bar in the bottom right corner) that the Akonadi IMAP resource for the 2nd server got stuck in "Creating folder"
3. Sync the first server again
4. Notice that the folder reappeared there
5. Move all content from the 2nd server's folder back to the 1st
6. Delete now-empty folder on the 2nd server

OBSERVED RESULT

* Akonadi IMAP resource for the 2nd server got stuck in "Creating folder" after moving folder
* Akonadi IMAP resource goes into crash loop after deleting folder

EXPECTED RESULT

Akonadi is rock stable and handles the moving and deletion of folders and content gracefully

SOFTWARE/OS VERSIONS
Linux: 5.5.8, via Fedora 31
KDE Plasma Version: 5.17.5
KDE Applications Version: 19.04.3
KDE Frameworks Version: 5.67.0
Qt Version: 5.13.2
Comment 1 Dennis Schridde 2020-03-16 10:08:36 UTC
Created attachment 126824 [details]
akonadi_imap_resource-20200316-102944.kcrash.txt
Comment 2 Dennis Schridde 2020-03-16 10:14:41 UTC
Notable output from `akonadictl restart`:

org.kde.pim.akonadicontrol: ProcessControl: Application '/usr/bin/akonadi_imap_resource' returned with exit code 253 (Unknown error)
org.kde.pim.akonadiserver: New notification connection (registered as Akonadi::Server::NotificationSubscriber(0x7fcea00aa130) )
org.kde.pim.akonadiserver: Subscriber Akonadi::Server::NotificationSubscriber(0x7fcea00aa130) identified as "AgentBaseChangeRecorder - 94682505928208"
org.kde.pim.akonadiserver: Error while handling command FetchCollections on connection akonadi_imap_resource_0 (0x55948b647ce0)

It is not easy to figure out, but I believe that akonadi_imap_resource_0 is the resource for the 2nd IMAP server, the same one that is segfaulting constantly.
Comment 3 Dennis Schridde 2020-03-22 17:20:41 UTC
Created attachment 126951 [details]
New crash information added by DrKonqi

akonadi_imap_resource (5.13.2 (19.12.2)) using Qt 5.13.2

- What I was doing when the application crashed:

The issue persists in Fedora 32: Akonadi IMAP resource for this account is still in a crash loop.

-- Backtrace (Reduced):
#6  0x00007f55cc0216f0 in  ()
[...]
#8  0x00007f5609aa18a6 in Akonadi::ResourceScheduler::executeNext() () at /lib64/libKF5AkonadiAgentBase.so.5
#9  0x00007f5608211456 in QSingleShotTimer::timerEvent(QTimerEvent*) () at /lib64/libQt5Core.so.5
#10 0x00007f56082062cf in QObject::event(QEvent*) () at /lib64/libQt5Core.so.5
#11 0x00007f5608c6de66 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /lib64/libQt5Widgets.so.5
Comment 4 Ahmad Samir 2020-08-27 15:08:33 UTC
The backtrace isn't complete, seems to be missing debug symbols. If you can still reproduce this issue, please install the relevant -debuginfo packages and post another backtrace.
Comment 5 Bug Janitor Service 2020-09-11 04:33:10 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 6 Bug Janitor Service 2020-09-26 04:33:14 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!
Comment 7 Andrei A. Lomov 2021-05-16 12:04:54 UTC
(In reply to Ahmad Samir from comment #4)
> The backtrace isn't complete, seems to be missing debug symbols. If you can
> still reproduce this issue, please install the relevant -debuginfo packages
> and post another backtrace.

Ahmad, sorry, what -debuginfo packages I should install ?

In debian 11 I have the error 

org.kde.pim.akonadicontrol: ProcessControl: Application '/usr/bin/akonadiserver' returned with exit code 253

What is it?

Akonadi crashes permanently :(