Bug 418106 - configure error: Valgrind not working with Darwin version 18.14.2
Summary: configure error: Valgrind not working with Darwin version 18.14.2
Status: RESOLVED DUPLICATE of bug 399584
Alias: None
Product: valgrind
Classification: Developer tools
Component: general (show other bugs)
Version: 3.15 SVN
Platform: Homebrew (macOS) macOS
: NOR major
Target Milestone: ---
Assignee: Julian Seward
Depends on:
Reported: 2020-02-23 20:41 UTC by wtsegars
Modified: 2020-02-23 20:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description wtsegars 2020-02-23 20:41:13 UTC
I tried to install Valgrind on my macOS computer OS10 Mojave using Homebrew. However, when I tried to install it, I got an error thrown back at me in the terminal stating that Valgrind will only work with Darwin versions 10 - 17 but not 18.

1. Tried to install Valgrind by running 'brew install valgrind' in terminal, but this was returned: 'valgrind: This formula either does not compile or function as expected on macOS
versions newer than Sierra due to an upstream incompatibility.'
2. Followed the instructions on this site: https://www.gungorbudak.com/blog/2018/04/28/how-to-install-valgrind-on-macos-high-sierra/
3. Contacted Homebrew with the issue and they told me to contact the developers for Valgrind

This is what I got back in the terminal after running 'brew install --HEAD valgrind':
$ brew install --HEAD valgrind
Updating Homebrew...
==> Auto-updated Homebrew!
Updated 1 tap (homebrew/core).
==> Updated Formulae

==> Cloning git://sourceware.org/git/valgrind.git
Updating /Users/steelwind/Library/Caches/Homebrew/valgrind--git
==> Checking out branch master
Already on 'master'
Your branch is up to date with 'origin/master'.
HEAD is now at 6f8920f PPC64, fix for alignment of the rt_sigframe data structure.
==> ./autogen.sh
==> ./configure --prefix=/usr/local/Cellar/valgrind/HEAD-6f8920f --enable-only64
Last 15 lines from /Users/steelwind/Library/Logs/Homebrew/valgrind/02.configure:
checking for gcc-ar... no
checking for perl... /usr/bin/perl
checking for gdb... /no/gdb/was/found/at/configure/time
checking dependency style of clang... none
checking for diff -u... yes
checking for clang option to accept ISO C99... none needed
checking for a supported version of gcc... ok (Apple LLVM version 10.0.1)
checking build system type... x86_64-pc-darwin
checking host system type... x86_64-pc-darwin
checking for a supported CPU... ok (x86_64)
checking for a 64-bit only build... yes
checking for a 32-bit only build... no
checking for a supported OS... ok (darwin)
checking for the kernel version... unsupported (18.6.0)
configure: error: Valgrind works on Darwin 10.x, 11.x, 12.x, 13.x, 14.x, 15.x, 16.x and 17.x (Mac OS X 10.6/7/8/9/10/11 and macOS 10.12/13)

READ THIS: https://docs.brew.sh/Troubleshooting

The expected result should successfully install Valgrind on my computer with no problems 

Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

Comment 1 Tom Hughes 2020-02-23 20:58:02 UTC

*** This bug has been marked as a duplicate of bug 399584 ***