Bug 417979 - Kmail crashes when opening a special email
Summary: Kmail crashes when opening a special email
Status: RESOLVED DUPLICATE of bug 409001
Alias: None
Product: kmail2
Classification: Applications
Component: message list (show other bugs)
Version: 5.10.3
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-21 10:13 UTC by Andreas Beisemann
Modified: 2020-04-05 11:32 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
The EMail itself (839.50 KB, message/rfc822)
2020-02-21 10:13 UTC, Andreas Beisemann
Details
error.txt (26.33 KB, text/plain)
2020-02-21 10:13 UTC, Andreas Beisemann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Beisemann 2020-02-21 10:13:02 UTC
Created attachment 126245 [details]
The EMail itself

SUMMARY
KMail crash, when open 1 special Email with pdf attachments

STEPS TO REPRODUCE
1. open KMail
2. klick on email
3. KMail crashs and ask for open again

OBSERVED RESULT
app starts new

EXPECTED RESULT


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

Comment: opensuse 15.1, Plasma:5.12.8, Framework: 5.55.0, QT:5.9.7,
         Kernel: 4.12.14-lp151.28.36-default, 64 bit

ADDITIONAL INFORMATION

EMail is to read in any browser, not in kmail.

Please be careful with the passing on of the mail,
it is from a church organization where I work on a voluntary basis.
No way to install debug symbols, the attempt is immediately terminated with an error.
Comment 1 Andreas Beisemann 2020-02-21 10:13:48 UTC
Created attachment 126246 [details]
error.txt
Comment 2 Laurent Montel 2020-02-21 16:22:07 UTC
/usr/lib64/qt5/plugins/messageviewer/bodypartformatter/messageviewer_bodypartformatter_semantic.so

5.10.3 is very old.
You can remove this plugin it will fix your crash.

Otherwise you need to increase pim version.
Regards
Comment 3 Stefan Gruber 2020-04-05 11:04:02 UTC
Same problem here on current opensuse 15.1.

Even akonadiconsole crashes when browsing the 'toxic' e-mail.

How can I disable bodypartformatter-plugin?
Comment 4 Wolfgang Bauer 2020-04-05 11:32:28 UTC
(In reply to Stefan Gruber from comment #3)
> How can I disable bodypartformatter-plugin?
Delete the file /usr/lib64/qt5/plugins/messageviewer/bodypartformatter/messageviewer_bodypartformatter_semantic.so, there is no other way.

This is a duplicate though.

And see https://bugzilla.opensuse.org/show_bug.cgi?id=1165440 for an openSUSE bug report.

*** This bug has been marked as a duplicate of bug 409001 ***