Bug 417640 - unintuitive right mouse click default behavior for create new
Summary: unintuitive right mouse click default behavior for create new
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 19.12.2
Platform: Manjaro Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
: 417720 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-02-14 13:55 UTC by apache
Modified: 2020-03-10 17:41 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 20.04.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description apache 2020-02-14 13:55:08 UTC
When I do right mouse click in empty folder, the default behavior is correct: the first item on a list is "create new":
https://i.imgur.com/K7LSNrz.png

But when there is some content in a folder but also there is some "empty space" and I click on this "empty space", not on any file or folder, the default behavior shows "open with" on the first position, which makes no sense at all, because I don't want to open "empty space". When I click on "empty space" this means that I want to create a new folder or a new file.
https://i.imgur.com/ZV8zrCX.png

"Open with" should be as an option on the first position only when user click on file or folder.

Operating System: Manjaro Linux 
KDE Plasma Version: 5.17.5
KDE Frameworks Version: 5.66.0
Qt Version: 5.14.1
Kernel Version: 5.4.18-1-MANJARO
OS Type: 64-bit
Comment 1 Nate Graham 2020-02-14 15:04:12 UTC
Will be fixed by https://phabricator.kde.org/D27267
Comment 2 Nate Graham 2020-02-14 15:52:44 UTC
Git commit 4c923a531f77bc4c44b5c8687fe18dd6438eb9c5 by Nate Graham.
Committed on 14/02/2020 at 15:52.
Pushed by ngraham into branch 'master'.

Restore former position of "Create New" menu item in viewport context menu

Summary:
I've seem various complaints from users about the fact that the {nav Create New...} menu
item in the viewport context menu is now below {nav Open With} item. All the other
changes to menus seem to have been well-received but this one has garnered criticism.
Looking through D23757 and D11884, I can't actually see that this was intentional, so
it might even be a bug.

Either way, this patch restores the old position of the {nav Create New} menu items at
the top of the Viewport context menu.
FIXED-IN: 20.04.0

Test Plan: {F8093605}

Reviewers: #vdg, #dolphin, elvisangelaccio, ndavis

Reviewed By: #vdg, ndavis

Subscribers: asturmlechner, markuss, kfm-devel

Tags: #dolphin

Differential Revision: https://phabricator.kde.org/D27267

M  +6    -6    src/dolphincontextmenu.cpp

https://commits.kde.org/dolphin/4c923a531f77bc4c44b5c8687fe18dd6438eb9c5
Comment 3 Nate Graham 2020-02-16 21:11:33 UTC
*** Bug 417720 has been marked as a duplicate of this bug. ***
Comment 4 Storm Engineer 2020-03-09 22:00:51 UTC
As of today on Arch, this is still not fixed.
Comment 5 Nate Graham 2020-03-10 17:41:37 UTC
This was fixed in Dolphin 20.04.0. The latest released version in Arch is 19.12.3.