Bug 417495 - Application launcher shortcuts well recorded but launch nothing
Summary: Application launcher shortcuts well recorded but launch nothing
Status: CLOSED DUPLICATE of bug 421329
Alias: None
Product: kmenuedit
Classification: Applications
Component: general (show other bugs)
Version: 5.18.5
Platform: Kubuntu Linux
: VHI normal with 70 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: regression
: 418871 419297 420199 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-02-12 14:12 UTC by Philippe ROUBACH
Modified: 2022-08-25 09:35 UTC (History)
20 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
kglobalshortcutrc (16.90 KB, text/plain)
2020-03-18 14:36 UTC, Till Schäfer
Details
must contain "Alt+N" for toggling "night Color" (20.08 KB, text/plain)
2020-03-18 14:51 UTC, Philippe ROUBACH
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe ROUBACH 2020-02-12 14:12:02 UTC
SUMMARY


STEPS TO REPRODUCE
1. define Alt+N as a shortcut for night color
2. type Alt+N
3. 

OBSERVED RESULT

Night color is not enabled/disabled

EXPECTED RESULT

Night color is enabled/disabled

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 5.18.0
KDE Frameworks Version: 5.67.0
Qt Version: 5.14.1

ADDITIONAL INFORMATION

kde apps 19.12.2

it seems it's a random phenomenon
Comment 1 Philippe ROUBACH 2020-02-25 12:43:50 UTC
I discover same problem with openSuse Leap 15.2 when creating a shortcut for Firefox.

openSuse Leap 15.2 and openSuse Argon Leap 15.1 get two things in common:

plasma 5.18
kde frameworks 5.67
Comment 2 Philippe ROUBACH 2020-02-25 12:48:49 UTC
i thing the problem is about kde menu editor not "night color"
Comment 3 Philippe ROUBACH 2020-02-26 06:21:46 UTC
I redefine the problem.

It is about shortcuts:

- to launch app thus using kde menu editor
- to execute an action as for example "toggle night color" thus using kde settings > shortcut
- to execute an action as for example "enable bluetooth" thus using systray settings

the experiment:

With kmenu editor I create a shortcut to launch Firefox
then the shortcut does not work
then
with kde settings I create a shortcut to toggle "night color"
then the shortcut does not work
then
with systray settings I create a shortcut to toggle "night color"
then I get a message about reassigning the shortcut and shortcut works.

There is something bad around this three ways to define a shortcut.
Comment 4 David Lakatos 2020-03-15 08:50:53 UTC
Keyboard shortcuts set in KDE Menu Editor are not working at all. This issue severely affects my productivity as a sw developer on OpenSuSE Tumbleweed. Could you please any of the KDE maintainers look at this issue? Is there a temporary workaround I could use in the meantime?

My setup:
- OpenSuSE Tumbleweed (up-to-date)
- KDE Plasma 5.18.2
- Linux 5.5.7-1-default x86_64 kernel

Thank you in advance.
Comment 5 YAFU 2020-03-16 21:34:22 UTC
*** Bug 418871 has been marked as a duplicate of this bug. ***
Comment 6 YAFU 2020-03-16 21:35:19 UTC
System: Kubuntu 20.04 (beta) 64bits
KDE/Plasma 5.18.3

I have installed Kubuntu 20.04 pre beta a couple of months ago (upgrading it from Kubuntu 18.04). Keyboard shortcuts configured from "KDE menu editor" worked about a month ago. I think from some Kubuntu update about a month ago, new keyboard shortcuts configured from "KDE menu editor" don't work (old shortcuts configured from "KDE menu editor" still work).
Comment 7 Till Schäfer 2020-03-18 12:06:06 UTC
*** Bug 418753 has been marked as a duplicate of this bug. ***
Comment 8 Till Schäfer 2020-03-18 12:07:04 UTC
I can confirm the problem here on Gentoo with 

Frameworks 5.68.0
Plasma 5.18.3
Apps 19.12.3
Qt 5.14.1
Xorg Server 1.20.7
Kernel 5.5.9
Comment 9 Till Schäfer 2020-03-18 12:11:52 UTC
I think this has a broader scope than just the menu editor. Creating global shortcuts in the system settings also does not work.
Comment 10 Till Schäfer 2020-03-18 12:14:41 UTC
Forthermore, I have notices that previously created custom global application launcher shortcuts work well, but whenever I create a new global shortcut or re-assign them, they stop working.
Comment 11 Till Schäfer 2020-03-18 12:24:27 UTC
Workaround: Create a (In reply to Till Schäfer from comment #9)
> I think this has a broader scope than just the menu editor. Creating global
> shortcuts in the system settings also does not work.

To be more precise. This only affects Application Launcher shortcuts in the system settings. 

Workaround: Create an entry in Custom Shortcuts System Settings and assign the Application to it.
Comment 12 David Edmundson 2020-03-18 12:59:05 UTC
Please include your .config/kglobalshortcutsrc

highlighting what's newly added

> Creating global shortcuts in the system settings also does not work.
>Workaround: Create an entry in Custom Shortcuts System Settings 

what's the difference between these two?
Comment 13 Till Schäfer 2020-03-18 14:36:46 UTC
Created attachment 126874 [details]
kglobalshortcutrc

Failing shortcut example: Meta+z to launch xournal
Comment 14 Till Schäfer 2020-03-18 14:49:42 UTC
(In reply to David Edmundson from comment #12)
> Please include your .config/kglobalshortcutsrc
> 
> highlighting what's newly added
> 
> > Creating global shortcuts in the system settings also does not work.
> >Workaround: Create an entry in Custom Shortcuts System Settings 
> 
> what's the difference between these two?

First one is system-settings -> Shortcuts -> Global Shortcuts (Section Application Launcher)

Second one is system-settings -> Shortcuts -> Custom Shortcuts (Section KMenuEdit)

In my example above (see kglobalshortcutrc) xournal is listed in the first place, but not in the second. It seems however, that some of the older entries are listed in both locations. Is this related to the problem?

I dont know, the technical differences.
Comment 15 Philippe ROUBACH 2020-03-18 14:51:10 UTC
Created attachment 126875 [details]
must contain "Alt+N" for toggling "night Color"
Comment 16 YAFU 2020-04-04 22:23:57 UTC
Hi. Have the developers been able to reproduce this problem? Do you need us to share more information about our systems where the problem is present?
I hope this issue is resolved before Kubuntu 20.04 is officially released.
Comment 17 Nick Elliott 2020-05-11 08:43:13 UTC
This is also an issue on my clean install of Kubuntu 20.04. In 19.10 and earlier I had no such problems.

There seems to be a disconnect between the various ways of setting keyboard shortcuts.

KDE Menu Editor allow shortcuts to be assigned but they do not work.

Global Shortcuts in System Settings allow shortcuts to be assigned but only some of them work, for example I now have working shortcuts for Muon and KeepassXC but not for others e.g. Vivaldi, KMyMoney.
Comment 18 Jiri Slaby 2020-06-15 09:32:04 UTC
*** This bug has been confirmed by popular vote. ***
Comment 19 Nate Graham 2020-06-19 14:19:29 UTC
*** Bug 420199 has been marked as a duplicate of this bug. ***
Comment 20 Nate Graham 2020-06-19 14:19:34 UTC
*** Bug 419297 has been marked as a duplicate of this bug. ***
Comment 21 Tharrrk 2020-06-23 16:19:39 UTC
I have the same issue with KDE Neon based on Ubuntu 18.04 (AFAIK).

ii  kmenuedit             4:5.19.0-0xneon+18.04+bionic+build53     amd64     XDG menu editor
ii  khotkeys              4:5.19.0-0xneon+18.04+bionic+build56     amd64     configure input actions settings
ii  libkf5globalaccel-bin 5.70.0-0xneon+18.04+bionic+build38       amd64     Configurable global shortcut support.
ii  systemsettings        4:5.19.0-0xneon+18.04+bionic+build68     amd64     System Settings interface
ii  kded5                 5.70.0-0xneon+18.04+bionic+build48       amd64     Extensible daemon for providing session services
ii  plasma-workspace      4:5.19.0-0xneon+18.04+bionic+build73     amd64     Plasma Workspace for KF5
ii  plasma-desktop        4:5.19.0-0xneon+18.04+bionic+build88     amd64     Tools and widgets for the desktop


It seems the workaround from the posts above works.

When the shortcut is stored in "Settings" -> "Shortcuts" -> "Global Shortcuts" -> "Applications" it is mapped to ~/.config/kglobalshortcutsrc and NOT WORKING.

When it's stored in "Settings" -> "Shortcuts" -> "Custom Shortcuts" -> "KMenuEdit" it is mapped to ~/.config/khotkeysrc and is WORKING FINE.
The structure of the files seem very different so it could not be easily "converted" from one to another.


There seem to be some new updates pending I'll try to report back after update/reboot.
Comment 22 David Edmundson 2020-06-30 16:15:10 UTC
Is this the same as 421329?
Comment 23 Nate Graham 2020-06-30 16:25:38 UTC
The description makes it seem a bit different, but maybe https://invent.kde.org/frameworks/kglobalaccel/-/merge_requests/2will fix them both?
Comment 24 Méven Car 2020-07-02 09:40:12 UTC
(In reply to Nate Graham from comment #23)
> The description makes it seem a bit different, but maybe
> https://invent.kde.org/frameworks/kglobalaccel/-/merge_requests/2 will fix
> them both?

I think it might do indeed.
Could not test given the specific case.
Comment 25 Méven Car 2020-07-10 12:05:32 UTC

*** This bug has been marked as a duplicate of bug 421329 ***
Comment 26 Matt M (gardotd426) 2020-09-02 20:45:03 UTC
I also have this bug on Manjaro Linux 20.0.3 (Plasma 5.19.4). Weirdly my old install that I just wiped the other day, that had been around for months, had working shortcuts (they must have been grandfathered, as others have said). But now all new shortcuts fail unless I use the "Custom Shortcuts" menu instead of the "Global Shortcuts" as intended.
Comment 27 Hazmil Azis 2020-09-08 03:07:12 UTC
I confirm this bug also appears on my new and updated Kubuntu 20.04.1 installation.
I heavily use the shortcuts to quickly open apps. This works well in my previous Kubuntu 18.04 installation, my workflow is quite impaired without this functionality.
Hopefully this can be resolved soon.
Comment 28 Matt M (gardotd426) 2020-09-08 03:58:14 UTC
Actually I've now discovered that this bug is even present on window actions. For example, the default KDE shortcut for "Close" is CTRL+W, which I kept, and added Meta+Shift+Q as an alternate. Neither work (and I tested the CTRL+W before I touched anything, and it doesn't work either). 

It seems that the majority of all of KDE's global shortcuts are broken.
Comment 29 Matt M (gardotd426) 2020-09-08 03:58:36 UTC
How is this not confirmed yet?
Comment 30 Nate Graham 2020-09-08 04:26:52 UTC
...Because it's already been fixed. :) This bug report was correctly marked as a duplicate of Bug 421329 which was fixed in KDE Frameworks 5.74. Please don't re-open bugs if they're still affecting you because you don't have the fixed version yet.

*** This bug has been marked as a duplicate of bug 421329 ***
Comment 31 YAFU 2020-12-13 12:33:05 UTC
Not only has this never been fixed, it is even worse. KDE Menu Editor won't even let me enter new combinations keys.
So, what to do?

Using KDE 5.76.0 from KDE Neon (Testing)
Comment 32 Martin B 2021-01-21 12:40:59 UTC
Had the same wrong behavior after a fresh - not further updated - install of KDE NEON 5.20 german version where I have not even been able to set a shortcut for a quickstart of an application, not in the menu editor and not in Settings > shortcuts: I activated the shortcut field but my keyboard input was not recorded.

After install of all automatic upcoming updates now I have
KDE-Plasma-Version: 5.20.5
KDE-Frameworks-Version: 5.78.0
QT-Version: 5.12.2
Kernel-Version: 5.4.0-58-generic

and the problems are gone.

For Kubuntu 20.04 LTS after a fresh install and after installing all updates the faulty behavior I had was
- it is possible to setup a shortcut for an application in menu editor
- and in Settings > Shortcuts
- but the application does not start
This error was with all kind of shortcut (Shift-x, Alt-X, Ctrl-x and kombinations).

I received a hint in Kubuntuforums.net there was the same faulty behavior some years ago in an older version of Kubuntu and followed the resolve action:
- not a must but best practice: delete all your already setup application shortcuts 
- go to "~/.config/kglobalshortcutsrc" and rename this e.g. to "~/.config/kglobalshortcutsrc_org"
- reboot the system
- check the file has been recreated
and for me from the on on two differnts notebooks this fixed the problem.

Hope this helps ...
Comment 33 Liam Coogan 2022-08-25 09:35:31 UTC
I am experiencing this exact issue.

STEPS TO REPRODUCE
1. Define Meta+3 as a shortcut for the 'Firefox' entry in KDE Menu Editor
2. Type Meta+3

OBSERVED RESULT
Firefox does not launch after pressing Meta+3

EXPECTED RESULT
Firefox launches after pressing Meta+3

SOFTWARE VERSIONS
KDE Plasma Version: 5.25.4
KDE Frameworks Version: 5.97.0
Qt Version: 5.15.5

When I set Meta+3 as the launcher for a native KDE app that initially had a different shortcut, e.g. Dolphin, it works as expected. I have now tried Meta+3 on a variety of non-KDE applications, and none launch with the shortcut. I have also tried a variety of other keyboard shortcuts, including shortcuts not involving the Meta key, and none launch Firefox.