Bug 417247 - Crash when selecting German language preference
Summary: Crash when selecting German language preference
Status: RESOLVED WORKSFORME
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_translations (show other bugs)
Version: 5.16.5
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-02-06 20:47 UTC by mail
Modified: 2020-11-11 04:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mail 2020-02-06 20:47:06 UTC
Application: systemsettings5 (5.16.5)

Qt Version: 5.12.4
Frameworks Version: 5.62.0
Operating System: Linux 5.3.0-29-generic x86_64
Distribution: Ubuntu 19.10

-- Information about the crash:
- What I was doing when the application crashed:

Selected German language in language preferences, before I already had added American English

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f7cdb02e840 (LWP 3621))]

Thread 8 (Thread 0x7f7cb9017700 (LWP 23961)):
#0  0x00007f7cdeebac2f in __GI___poll (fds=0x5590cc3cde60, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f7cdd1bda3e in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7cdd1bddc3 in g_main_loop_run () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7cc127a59a in  () at /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f7cdd1e7111 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f7cded83669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#6  0x00007f7cdeec7323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 7 (Thread 0x7f7cc22a2700 (LWP 23960)):
#0  0x00007f7cdeebac2f in __GI___poll (fds=0x5590cd1b4b80, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f7cdd1bda3e in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7cdd1bdb73 in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7cdd1bdbc1 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f7cdd1e7111 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f7cded83669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#6  0x00007f7cdeec7323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7f7cba01e700 (LWP 3650)):
#0  0x00007f7cdeeb62ac in __GI___libc_read (nbytes=10, buf=0x7f7cba01db9e, fd=37) at ../sysdeps/unix/sysv/linux/read.c:26
#1  0x00007f7cdeeb62ac in __GI___libc_read (fd=37, buf=0x7f7cba01db9e, nbytes=10) at ../sysdeps/unix/sysv/linux/read.c:24
#2  0x00007f7ccb5ad955 in pa_read () at /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecommon-13.0.so
#3  0x00007f7ccb62f406 in pa_mainloop_prepare () at /usr/lib/x86_64-linux-gnu/libpulse.so.0
#4  0x00007f7ccb62fea4 in pa_mainloop_iterate () at /usr/lib/x86_64-linux-gnu/libpulse.so.0
#5  0x00007f7ccb62ff60 in pa_mainloop_run () at /usr/lib/x86_64-linux-gnu/libpulse.so.0
#6  0x00007f7ccb63e10d in  () at /usr/lib/x86_64-linux-gnu/libpulse.so.0
#7  0x00007f7ccb5dc37c in  () at /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecommon-13.0.so
#8  0x00007f7cded83669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#9  0x00007f7cdeec7323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7f7cbb3aa700 (LWP 3646)):
#0  0x00007f7cdd1ba58d in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f7cdd1bbbac in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7cdd1bd38f in g_main_context_check () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7cdd1bd9e2 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f7cdd1bdb73 in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f7cdf4616c3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f7cdf40863b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f7cdf241a75 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f7cde50b319 in  () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007f7cdf242cc2 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f7cded83669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#11 0x00007f7cdeec7323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f7cc8b24700 (LWP 3627)):
#0  0x00007f7cdeeb62ac in __GI___libc_read (nbytes=16, buf=0x7f7cc8b23b30, fd=27) at ../sysdeps/unix/sysv/linux/read.c:26
#1  0x00007f7cdeeb62ac in __GI___libc_read (fd=27, buf=0x7f7cc8b23b30, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:24
#2  0x00007f7cdd20563f in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7cdd1bd58e in g_main_context_check () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f7cdd1bd9e2 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f7cdd1bdb73 in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f7cdf4616c3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f7cdf40863b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f7cdf241a75 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f7cde50b319 in  () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#10 0x00007f7cdf242cc2 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007f7cded83669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#12 0x00007f7cdeec7323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f7ccb140700 (LWP 3626)):
#0  0x00007f7cdeeb62ac in __GI___libc_read (nbytes=16, buf=0x7f7ccb13fb30, fd=14) at ../sysdeps/unix/sysv/linux/read.c:26
#1  0x00007f7cdeeb62ac in __GI___libc_read (fd=14, buf=0x7f7ccb13fb30, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:24
#2  0x00007f7cdd20563f in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7cdd1bd58e in g_main_context_check () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f7cdd1bd9e2 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f7cdd1bdb73 in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f7cdf4616c3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f7cdf40863b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f7cdf241a75 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f7cde50b319 in  () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#10 0x00007f7cdf242cc2 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007f7cded83669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#12 0x00007f7cdeec7323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f7cd8db4700 (LWP 3624)):
#0  0x00007f7cdeebac2f in __GI___poll (fds=0x7f7ccc019f80, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f7cdd1bda3e in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7cdd1bdb73 in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7cdf4616c3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f7cdf40863b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f7cdf241a75 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f7cdf6e2efa in  () at /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007f7cdf242cc2 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f7cded83669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#9  0x00007f7cdeec7323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f7cdb02e840 (LWP 3621)):
[KCrash Handler]
#6  0x00007f7cde38b7f9 in QV4::QObjectWrapper::wrap(QV4::ExecutionEngine*, QObject*) () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f7cde42c8dc in QV4::ExecutionEngine::fromVariant(QVariant const&) () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f7cde388e7c in  () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007f7cde389d52 in QV4::QQmlContextWrapper::getPropertyAndBase(QV4::QQmlContextWrapper const*, QV4::PropertyKey, QV4::Value const*, bool*, QV4::Value*, QV4::Lookup*) () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#10 0x00007f7cde38a614 in QV4::QQmlContextWrapper::resolveQmlContextPropertyLookupGetter(QV4::Lookup*, QV4::ExecutionEngine*, QV4::Value*) () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#11 0x00007f7cd01f1b7c in  ()
#12 0x0000000000000000 in  ()
[Inferior 1 (process 3621) detached]

Reported using DrKonqi
Comment 1 Nate Graham 2020-10-12 21:18:17 UTC
Does this happen with a newer version of Plasma? Like 5.19 or 5.20?
Comment 2 Bug Janitor Service 2020-10-27 04:33:39 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Bug Janitor Service 2020-11-11 04:34:08 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!