Bug 417142 - cannot find yahoo finance under online quotes
Summary: cannot find yahoo finance under online quotes
Status: RESOLVED FIXED
Alias: None
Product: kmymoney
Classification: Unclassified
Component: importer (show other bugs)
Version: 5.0.6
Platform: Other Microsoft Windows
: NOR normal (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-04 12:36 UTC by baramire
Modified: 2020-06-05 04:07 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.1.0


Attachments
attachment-325-0.html (7.40 KB, text/html)
2020-02-05 01:41 UTC, baramire
Details

Note You need to log in before you can comment on or make changes to this bug.
Description baramire 2020-02-04 12:36:07 UTC
SUMMARY
cannot find yahoo finance under online quotes to update stocks. documentation states that yahoo finance is the default but does not show as a selection. tried version 5.0.6 and 5.0.8 same results. need help what to do, please advise.

using microsoft windows 10. 

STEPS TO REPRODUCE
1. 
2. 
3. 

OBSERVED RESULT


EXPECTED RESULT


SOFTWARE/OS VERSIONS
Windows: 10
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
Comment 1 Jack 2020-02-04 14:49:11 UTC
The documentation is likely out of date here, although I'm not sure what is the current default, or if there is any point in actualy having a default.  (And I am responsible for the docs, so I only blame myself.)

For most people, Yahoo finance stopped working for price updates a long time ago, as they stopped providing that service in a way that can be used by programs.  The same is true for several other sources, so you will just have to try multiple sources until you find one which works for you.

There have been multiple discussions of this issue on the mailing list and in the forum, and it basically remains an unsolved issue, because when a service changes the layout of the web site, it will stop working in KMM until someone changes the regular expression used to find the necessary data on the page, and then users copy the updated version into their own settings.  

In addition, there is work going on to add a different method to download stock and currency prices, but there is no estimate when that will be working and available.  You might also try Finance::Quote (see the checkbox at the top of the page where you specify the source to use) but I am not certain whether it will work on Windows, and it certainly requires you have Perl and it's Finance::Quote module installed.
Comment 2 Brendan 2020-02-05 00:02:08 UTC
First, to be clear, the Yahoo quote problem started when Verizon
bought them. This is Verizon problem.

After having trouble with Yahoo quotes several times after Verizon
took over and adjusting my settings at least 2 or 3 times they have
been working flawlessly for me for quite a while.

I'm hoping I don't jinx myself by mentioning it here. I have not tried
"Use Finance:Quote" and probably won't until it's a global setting or
Verizon screws up Yahoo quotes again.

Here are my settings:

URL: https://query1.finance.yahoo.com/v7/finance/quote?fields=regularMarketPrice&symbols=%1
CSV URL: (blank)
Identifier: %1
Identified by: Symbol
Price: "regularMarketPrice":((\d+|\d{1,3}(?:[,]\d{3})).\d+)
Date: "regularMarketTime":([\d]+)
Date Format: (blank)

Check the box "Skip HTML stripping"



----
Brendan Coupe


----
Brendan Coupe


On Tue, Feb 4, 2020 at 7:49 AM Jack <bugzilla_noreply@kde.org> wrote:
>
> https://bugs.kde.org/show_bug.cgi?id=417142
>
> --- Comment #1 from Jack <ostroffjh@users.sourceforge.net> ---
> The documentation is likely out of date here, although I'm not sure what is the
> current default, or if there is any point in actualy having a default.  (And I
> am responsible for the docs, so I only blame myself.)
>
> For most people, Yahoo finance stopped working for price updates a long time
> ago, as they stopped providing that service in a way that can be used by
> programs.  The same is true for several other sources, so you will just have to
> try multiple sources until you find one which works for you.
>
> There have been multiple discussions of this issue on the mailing list and in
> the forum, and it basically remains an unsolved issue, because when a service
> changes the layout of the web site, it will stop working in KMM until someone
> changes the regular expression used to find the necessary data on the page, and
> then users copy the updated version into their own settings.
>
> In addition, there is work going on to add a different method to download stock
> and currency prices, but there is no estimate when that will be working and
> available.  You might also try Finance::Quote (see the checkbox at the top of
> the page where you specify the source to use) but I am not certain whether it
> will work on Windows, and it certainly requires you have Perl and it's
> Finance::Quote module installed.
>
> --
> You are receiving this mail because:
> You are the assignee for the bug.
Comment 3 baramire 2020-02-05 01:41:45 UTC
Created attachment 125679 [details]
attachment-325-0.html

 Hi Brendan,Thanks for the responds. Unfortunately, the entries did not work. The error message was: CSV source Yahoo Finance does not exist.
Looks like I'll have to continue searching.
Bernard-
    On Tuesday, February 4, 2020, 04:02:10 PM PST, bugzilla_noreply@kde.org <bugzilla_noreply@kde.org> wrote:  
 
 https://bugs.kde.org/show_bug.cgi?id=417142

--- Comment #2 from Brendan@CoupeWare.com ---
First, to be clear, the Yahoo quote problem started when Verizon
bought them. This is Verizon problem.

After having trouble with Yahoo quotes several times after Verizon
took over and adjusting my settings at least 2 or 3 times they have
been working flawlessly for me for quite a while.

I'm hoping I don't jinx myself by mentioning it here. I have not tried
"Use Finance:Quote" and probably won't until it's a global setting or
Verizon screws up Yahoo quotes again.

Here are my settings:

URL:
https://query1.finance.yahoo.com/v7/finance/quote?fields=regularMarketPrice&symbols=%1
CSV URL: (blank)
Identifier: %1
Identified by: Symbol
Price: "regularMarketPrice":((\d+|\d{1,3}(?:[,]\d{3})).\d+)
Date: "regularMarketTime":([\d]+)
Date Format: (blank)

Check the box "Skip HTML stripping"



----
Brendan Coupe


----
Brendan Coupe


On Tue, Feb 4, 2020 at 7:49 AM Jack <bugzilla_noreply@kde.org> wrote:
>
> https://bugs.kde.org/show_bug.cgi?id=417142
>
> --- Comment #1 from Jack <ostroffjh@users.sourceforge.net> ---
> The documentation is likely out of date here, although I'm not sure what is the
> current default, or if there is any point in actualy having a default.  (And I
> am responsible for the docs, so I only blame myself.)
>
> For most people, Yahoo finance stopped working for price updates a long time
> ago, as they stopped providing that service in a way that can be used by
> programs.  The same is true for several other sources, so you will just have to
> try multiple sources until you find one which works for you.
>
> There have been multiple discussions of this issue on the mailing list and in
> the forum, and it basically remains an unsolved issue, because when a service
> changes the layout of the web site, it will stop working in KMM until someone
> changes the regular expression used to find the necessary data on the page, and
> then users copy the updated version into their own settings.
>
> In addition, there is work going on to add a different method to download stock
> and currency prices, but there is no estimate when that will be working and
> available.  You might also try Finance::Quote (see the checkbox at the top of
> the page where you specify the source to use) but I am not certain whether it
> will work on Windows, and it certainly requires you have Perl and it's
> Finance::Quote module installed.
>
> --
> You are receiving this mail because:
> You are the assignee for the bug.
Comment 4 Brendan 2020-02-05 01:54:47 UTC
Maybe a Windows 10 issue? I'm running on Fedora with the latest build from the master branch. I don't think it's a KMM version issue since it's been working for me for a while, probably before 5.0.6.
Comment 5 Jack 2020-02-09 23:58:02 UTC
(In reply to baramire from comment #3)
> The error message was: CSV source Yahoo Finance does not exist.
I think we may be confusing different issues here.  Brendan is talking about changes made to the Yahoo service, which cause retrieving prices to fail, but I think the error is about not finding the price or date.  This seems to be about not even finding the Yahoo Finance source itself.

Baramire - I'm specifically curious about the "CSV source Yahoo Finance does not exist."  Where did you make the changes Brendan suggested?  Also, did you perhaps put something in the CSV URL field, instead of leaving it blank?  If you were trying to get a price for a specific equity, when you edit that equity, what source is selected on the last page of the wizard?  Separately, when you click Settings / Configure KMyMoney and select the Online Quotes entry, what are the last few entries on the list of sources, specifically all those starting with "Yahoo ..."  I see Yahoo, Yahoo Canada, Yahoo Currency, Yahoo France, and Yahoo UK, but not Yahoo Finance.

[If you reply by email and not the bugs.kde.org website, please trim what you are replying to, except the minimum needed for context, since otherwise it just duplicates all that information within the bug entries.  Thanks.]
Comment 6 Dawid Wróbel 2020-04-12 05:15:55 UTC
Git commit 1cff1f9ec55e81f2feff041d595774bfa9983c9a by Dawid Wróbel.
Committed on 12/04/2020 at 05:15.
Pushed by wrobelda into branch 'master'.

Bring back the Yahoo Finance quotes. Tested for a few months and continues to work, so assuming it is stable enough to push it to mainline.

M  +12   -0    kmymoney/converter/webpricequote.cpp

https://commits.kde.org/kmymoney/1cff1f9ec55e81f2feff041d595774bfa9983c9a
Comment 7 Thomas Baumgart 2020-04-12 08:03:07 UTC
Git commit b0c87004737691582b9416e5a21264ce067f8f78 by Thomas Baumgart.
Committed on 12/04/2020 at 07:59.
Pushed by tbaumgart into branch '5.0'.

Bring back the Yahoo Finance quotes

Tested for a few months by the original poster and continues to work, so
assuming it is stable enough to push it to mainline.
FIXED-IN: 5.0.9

(cherry picked from commit 1cff1f9ec55e81f2feff041d595774bfa9983c9a)

M  +12   -0    kmymoney/converter/webpricequote.cpp

https://commits.kde.org/kmymoney/b0c87004737691582b9416e5a21264ce067f8f78