Bug 417057 - Synched SDDM theme struck to a previous colourscheme
Summary: Synched SDDM theme struck to a previous colourscheme
Status: RESOLVED DUPLICATE of bug 440957
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_sddm (show other bugs)
Version: 5.17.5
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-02 11:42 UTC by Stefano
Modified: 2022-05-17 13:46 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefano 2020-02-02 11:42:38 UTC
SUMMARY
Some time ago I used the new Synch feature of SDDM to make it match my colour scheme, that was "Macaroni Time". Then, I wanted to change it back to default breeze, but it seems that I can't do it. SDDM is still keeping the "Macaroni Time" colour scheme.

This happens only with the default breeze plasma theme: if I synchronize it to Breeze Dark, Materia, or even Breeze Light, it will use the correct colour scheme. Maybe because their colours are fixed, indifferent from the choosen colour scheme.



STEPS TO REPRODUCE
1. Choose Macaroni Time as colour scheme and Plasma as theme
2. Synch SDDM
3. Logout
4. Login
5. Restore SDDM settings
6. Logout

OBSERVED RESULT
Text field background, border and buttons still have the Macaroni Time colour scheme. Foreground text color looks reverted to default Breeze, making it unreadable (dark gray on dark gray) on the text field.


EXPECTED RESULT
Every color and theme should be reverted to default Breeze.


SOFTWARE/OS VERSIONS
Operating System: Kubuntu 19.10
KDE Plasma Version: 5.17.5
KDE Frameworks Version: 5.66.0
Qt Version: 5.12.4
Kernel Version: 5.3.0-29-generic
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-4790 CPU @ 3.60GHz
Memory: 15,6 GiB


ADDITIONAL INFORMATION
One thing to observe is that Macaroni Time contains a little hack to make the windows titlebar translucent. It looks like you can specify an alpha value after the triplet of colours.
The same hack is present in another colour scheme, that is Breeze Dark Transparent that was used in this bug report https://bugs.kde.org/show_bug.cgi?id=413309
Comment 1 Stefano 2020-02-02 15:14:50 UTC
It seems to be cache related. I was able to restore properly the default theme and colour by deleting /var/lib/sddm/.cache by hand.

See also: https://www.reddit.com/r/kde/comments/ewoazw/q_synched_sddm_theme_struck_to_a_previous/
Comment 2 Filip Fila 2020-02-02 23:49:30 UTC
I thought we've been deleting the cache when resetting the settings but turns out I was wrong.

Made a patch: https://phabricator.kde.org/D27113
Comment 3 Marco 2022-05-17 13:45:53 UTC
The issue is still present in plasma 5.24.5. The colour scheme did not synchronize, but  it did after I deleted the .cache directory, as suggested.
Comment 4 Nate Graham 2022-05-17 13:46:52 UTC

*** This bug has been marked as a duplicate of bug 440957 ***